apt-0.5.15lorg3.95-23.git522.fc24.i686.rpm


Advertisement

Description

apt - Debian's Advanced Packaging Tool with RPM support

Property Value
Distribution Fedora 25
Repository Fedora i386
Package name apt
Package version 0.5.15lorg3.95
Package release 23.git522.fc24
Package architecture i686
Package type rpm
Installed size 2.44 MB
Download size 794.71 KB
Official Mirror dl.fedoraproject.org
APT-RPM is a port of Debian's apt tools for RPM based distributions.
It provides the apt-get utility that provides a simple, safe way to
install and upgrade packages. APT features complete installation
ordering, multiple source capability and several other useful
features.

Alternatives

Package Version Architecture Repository
apt-0.5.15lorg3.95-23.git522.fc24.i686.rpm 0.5.15lorg3.95 i686 Fedora
apt-0.5.15lorg3.95-23.git522.fc24.x86_64.rpm 0.5.15lorg3.95 x86_64 Fedora
apt - - -

Requires

Name Value
apt-config -
bzip2 -
gnupg -
libbz2.so.1 -
libc.so.6(GLIBC_2.15) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
liblua-5.3.so -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libncurses.so.6 -
libreadline.so.6 -
librpm.so.7 -
librpmio.so.7 -
libsqlite3.so.0 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.10) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libtinfo.so.6 -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.5.0) -
libxml2.so.2(LIBXML2_2.5.7) -
libxml2.so.2(LIBXML2_2.6.0) -
libz.so.1 -
rtld(GNU_HASH) -
system-release >= 4
systemd-sysv -
systemd-units -

Provides

Name Value
apt = 0.5.15lorg3.95-23.git522.fc24
apt(x86-32) = 0.5.15lorg3.95-23.git522.fc24
config(apt) = 0.5.15lorg3.95-23.git522.fc24
libapt-pkg.so.3 -

Obsoletes

Name Value
apt-plugins-groupinstall < 0.5.15lorg3.95-23.git522.fc24

Download

Type URL
Binary Package apt-0.5.15lorg3.95-23.git522.fc24.i686.rpm
Source Package apt-0.5.15lorg3.95-23.git522.fc24.src.rpm

Install Howto

Install the apt rpm package:

# dnf install apt

Files

Path
/etc/apt/apt.conf
/etc/apt/preferences
/etc/apt/rpmpriorities
/etc/apt/sources.list
/etc/apt/vendors.list
/etc/apt/apt.conf.d/default.conf
/etc/apt/apt.conf.d/multilib.conf
/etc/apt/sources.list.d/
/etc/apt/vendors.list.d/
/etc/cron.daily/apt.cron
/etc/sysconfig/apt
/usr/bin/apt-cache
/usr/bin/apt-cdrom
/usr/bin/apt-config
/usr/bin/apt-get
/usr/bin/apt-shell
/usr/bin/countpkglist
/usr/bin/genbasedir
/usr/bin/genpkglist
/usr/bin/gensrclist
/usr/lib/libapt-pkg.so.3
/usr/lib/libapt-pkg.so.3.0.0
/usr/lib/apt/
/usr/lib/apt/methods/bzip2
/usr/lib/apt/methods/cdrom
/usr/lib/apt/methods/copy
/usr/lib/apt/methods/file
/usr/lib/apt/methods/ftp
/usr/lib/apt/methods/gpg
/usr/lib/apt/methods/gzip
/usr/lib/apt/methods/http
/usr/lib/apt/methods/rsh
/usr/lib/apt/methods/ssh
/usr/lib/systemd/system/apt.service
/usr/share/apt/
/usr/share/apt/scripts/gpg-check.lua
/usr/share/apt/scripts/upgradevirt.lua
/usr/share/doc/apt/ABOUT-NLS
/usr/share/doc/apt/AUTHORS
/usr/share/doc/apt/AUTHORS.RPM
/usr/share/doc/apt/COPYING
/usr/share/doc/apt/COPYING.GPL
/usr/share/doc/apt/ChangeLog
/usr/share/doc/apt/TODO
/usr/share/doc/apt/comps2prio.xsl
/usr/share/doc/apt/contrib/
/usr/share/doc/apt/contrib/allow-duplicated/README
/usr/share/doc/apt/contrib/allow-duplicated/allow-duplicated.conf
/usr/share/doc/apt/contrib/allow-duplicated/allow-duplicated.lua
/usr/share/doc/apt/contrib/apt-cron/apt.cron
/usr/share/doc/apt/contrib/apt-cron/apt.init
/usr/share/doc/apt/contrib/apt-cron/apt.sysconfig
/usr/share/doc/apt/contrib/apt-files/README
/usr/share/doc/apt/contrib/apt-files/apt-files.conf
/usr/share/doc/apt/contrib/apt-files/apt-files.lua
/usr/share/doc/apt/contrib/apt-files/convert.py
/usr/share/doc/apt/contrib/apt-groupinstall/README
/usr/share/doc/apt/contrib/apt-groupinstall/apt-groupinstall.conf
/usr/share/doc/apt/contrib/apt-groupinstall/apt-groupinstall.lua
/usr/share/doc/apt/contrib/apt-groupinstall/groupinstall-backend-comps.py
/usr/share/doc/apt/contrib/apt-groupinstall/groupinstall-backend-suse
/usr/share/doc/apt/contrib/apt-wrapper/apt
/usr/share/doc/apt/contrib/apt-wrapper/apt.1
/usr/share/doc/apt/contrib/apt-wrapper/apt.1.xml
/usr/share/doc/apt/contrib/apt-wrapper/apt.ent
/usr/share/doc/apt/contrib/gpg-check/README
/usr/share/doc/apt/contrib/gpg-check/gpg-check.conf
/usr/share/doc/apt/contrib/gpg-check/gpg-check.lua
/usr/share/doc/apt/contrib/gpg-check/gpg-import.conf
/usr/share/doc/apt/contrib/gpg-check/gpg-import.lua
/usr/share/doc/apt/contrib/guess/README
/usr/share/doc/apt/contrib/guess/guess.conf
/usr/share/doc/apt/contrib/guess/guess.lua
/usr/share/doc/apt/contrib/install-devel/README
/usr/share/doc/apt/contrib/install-devel/install-devel.lua
/usr/share/doc/apt/contrib/list-extras/README
/usr/share/doc/apt/contrib/list-extras/list-extras.conf
/usr/share/doc/apt/contrib/list-extras/list-extras.lua
/usr/share/doc/apt/contrib/list-nodeps/README
/usr/share/doc/apt/contrib/list-nodeps/list-nodeps.conf
/usr/share/doc/apt/contrib/list-nodeps/list-nodeps.lua
/usr/share/doc/apt/contrib/log/README
/usr/share/doc/apt/contrib/log/log.conf
/usr/share/doc/apt/contrib/log/log.lua
/usr/share/doc/apt/contrib/preserve-conf/preserve-conf.conf
/usr/share/doc/apt/contrib/preserve-conf/preserve-conf.lua
/usr/share/doc/apt/contrib/proxypasswd/README
/usr/share/doc/apt/contrib/proxypasswd/proxypasswd.lua
/usr/share/doc/apt/examples/apt.conf
/usr/share/doc/apt/examples/configure-index
/usr/share/doc/apt/examples/sources.list
/usr/share/locale/de_DE/LC_MESSAGES/apt.mo
/usr/share/locale/es_ES/LC_MESSAGES/apt.mo
/usr/share/locale/it_IT/LC_MESSAGES/apt.mo
/usr/share/locale/ja/LC_MESSAGES/apt.mo
/usr/share/locale/pt_BR/LC_MESSAGES/apt.mo
/usr/share/locale/pt_PT/LC_MESSAGES/apt.mo
/usr/share/locale/ru/LC_MESSAGES/apt.mo
/usr/share/man/man5/apt.conf.5.gz
/usr/share/man/man5/apt_preferences.5.gz
/usr/share/man/man5/sources.list.5.gz
/usr/share/man/man5/vendors.list.5.gz
/usr/share/man/man8/apt-cache.8.gz
/usr/share/man/man8/apt-cdrom.8.gz
/usr/share/man/man8/apt-config.8.gz
/usr/share/man/man8/apt-get.8.gz
/usr/share/man/man8/apt.8.gz
/var/cache/apt/
/var/cache/apt/archives/
/var/cache/apt/archives/partial/
/var/cache/apt/genpkglist/
/var/cache/apt/gensrclist/
/var/lib/apt/
/var/lib/apt/lists/
/var/lib/apt/lists/partial/

Changelog

2016-02-03 - Fedora Release Engineering <releng@fedoraproject.org> - 0.5.15lorg3.95-23.git522
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
2015-10-22 - Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 0.5.15lorg3.95-22.git522
- Add ppc64le support
2015-07-29 - Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.5.15lorg3.95-21.git522
- Rebuilt for librpm
2015-07-14 - Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 0.5.15lorg3.95-20.git522
- Add AArch64 support
2015-06-17 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.15lorg3.95-19.git522
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
2015-05-02 - Kalev Lember <kalevlember@gmail.com> - 0.5.15lorg3.95-18.git522
- Rebuilt for GCC 5 C++11 ABI change
2015-03-11 - Mosaab Alzoubi <moceap@hotmail.com> - 0.5.15lorg3.95-17.git522
- Accept Vaclav Pavlin patch #850028
- Support F21 with old lua
- Set apt.service attr to 644 #1158853
2015-03-11 - Václav Pavlín <vpavlin@redhat.com> - 0.5.15lorg3.95-16.git522
- Scriptlets replaced with new systemd macros (#850028)
2015-01-15 - Tom Callaway <spot@fedoraproject.org> - 0.5.15lorg3.95-15.git522
- add lua 5.3 support
2014-12-10 - Tom Callaway <spot@fedoraproject.org> - 0.5.15lorg3.95-14.git522
- fix lua patch again
- fix build with modern RPM
- disable python support (it is bitrotten and broken)

See Also

Package Description
apt-cacher-ng-0.9.0-1.fc24.i686.rpm Caching proxy for package files from Debian
apt-devel-0.5.15lorg3.95-23.git522.fc24.i686.rpm Development files and documentation for APT's libapt-pkg
apt-plugins-list-0.5.15lorg3.95-23.git522.fc24.i686.rpm Additional commands to list extra packages and leaves
apt-plugins-log-0.5.15lorg3.95-23.git522.fc24.i686.rpm Log the changes being introduced by the transaction
apvlv-0.1.4-11.fc25.i686.rpm PDF viewer which behaves like Vim
apx-0.1-12.fc25.noarch.rpm QIX clone, cut into and claim the square area
apx-fonts-0.1-12.fc25.noarch.rpm Fonts for the game apx
aqbanking-5.6.10-1.fc25.i686.rpm A library for online banking functions and financial data import/export
aqbanking-devel-5.6.10-1.fc25.i686.rpm Development headers for Aqbanking
aqemu-0.9.2-1.fc25.i686.rpm A QT graphical interface to QEMU and KVM
aqsis-1.8.2-23.fc25.i686.rpm Open source 3D rendering solution adhering to the RenderMan standard
aqsis-core-1.8.2-23.fc25.i686.rpm Command-line tools for Aqsis Renderer
aqsis-data-1.8.2-23.fc25.noarch.rpm Example content for Aqsis Renderer
aqsis-devel-1.8.2-23.fc25.i686.rpm Development files for Aqsis Renderer
aqsis-libs-1.8.2-23.fc25.i686.rpm Library files for Aqsis Renderer
Advertisement
Advertisement