binutils-devel-2.26.1-1.fc25.x86_64.rpm


Advertisement

Description

binutils-devel - BFD and opcodes static and dynamic libraries and header files

Distribution: Fedora 25
Repository: Fedora x86_64
Package name: binutils-devel
Package version: 2.26.1
Package release: 1.fc25
Package architecture: x86_64
Package type: rpm
Installed size: 4.37 MB
Download size: 881.18 KB
Official Mirror: dl.fedoraproject.org
This package contains BFD and opcodes static and dynamic libraries. The dynamic libraries are in this package, rather than a seperate base package because they are actually linker scripts that force the use of the static libraries. This is because the API of the BFD library is too unstable to be used dynamically. The static libraries are here because they are now needed by the dynamic libraries. Developers starting new projects are strongly encouraged to consider using libelf instead of BFD.

Requires

Provides

  • binutils-devel = 2.26.1-1.fc25
  • binutils-devel(x86-64) = 2.26.1-1.fc25
  • binutils-static = 2.26.1-1.fc25

    Install Howto

    Install the binutils-devel rpm package:

    # dnf install binutils-devel

    Files

    • /usr/include/ansidecl.h
    • /usr/include/bfd.h
    • /usr/include/bfdlink.h
    • /usr/include/demangle.h
    • /usr/include/dis-asm.h
    • /usr/include/libiberty.h
    • /usr/include/plugin-api.h
    • /usr/include/symcat.h
    • /usr/lib64/libbfd.a
    • /usr/lib64/libbfd.so
    • /usr/lib64/libiberty.a
    • /usr/lib64/libopcodes.a
    • /usr/lib64/libopcodes.so
    • /usr/share/info/bfd.info.gz

    Changelog

    Advertisement
    Advertisement