compat-flex-2.5.4a-15.fc24.x86_64.rpm


Advertisement

Description

compat-flex - Legacy version of flex, a tool for creating scanners

Property Value
Distribution Fedora 25
Repository Fedora x86_64
Package name compat-flex
Package version 2.5.4a
Package release 15.fc24
Package architecture x86_64
Package type rpm
Installed size 302.52 KB
Download size 171.25 KB
Official Mirror dl.fedoraproject.org
This is legacy version of flex, a program that generates scanners.
Scanners are programs which can recognize lexical patterns in text.
Flex takes pairs of regular expressions and C code as input and
generates a C source file as output.  The output file is compiled and
linked with a library to produce an executable.  The executable
searches through its input for occurrences of the regular expressions.
When a match is found, it executes the corresponding C code.  Flex was
designed to work with both Yacc and Bison, and is used by many
programs as part of their build process.
You should install flex if you are going to use your system for
application development.

Alternatives

Package Version Architecture Repository
compat-flex-2.5.4a-15.fc24.i686.rpm 2.5.4a i686 Fedora
compat-flex - - -

Requires

Name Value
/sbin/install-info -
libc.so.6(GLIBC_2.7)(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
compat-flex = 2.5.4a-15.fc24
compat-flex(x86-64) = 2.5.4a-15.fc24

Download

Type URL
Binary Package compat-flex-2.5.4a-15.fc24.x86_64.rpm
Source Package compat-flex-2.5.4a-15.fc24.src.rpm

Install Howto

Install the compat-flex rpm package:

# dnf install compat-flex

Files

Path
/usr/bin/flex-2.5.4a
/usr/bin/flex-2.5.4a++
/usr/include/flex-2.5.4a/FlexLexer.h
/usr/lib64/flex-2.5.4a/libfl.a
/usr/share/doc/compat-flex/COPYING
/usr/share/doc/compat-flex/NEWS
/usr/share/doc/compat-flex/README
/usr/share/doc/compat-flex/README.fedora
/usr/share/info/flex-2.5.4a.info.gz
/usr/share/man/man1/flex-2.5.4a++.1.gz
/usr/share/man/man1/flex-2.5.4a.1.gz

Changelog

2016-02-03 - Fedora Release Engineering <releng@fedoraproject.org> - 2.5.4a-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
2015-06-17 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.4a-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
2014-08-16 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.4a-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
2014-06-07 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.4a-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
2013-08-16 - Petr Machata <pmachata@redhat.com> - 2.5.4a-11
- Fix "raising the section level of @section" bug that texinfo 5.0
complains about (flex-2.5.4a-texinfo-section.patch)
2013-02-13 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.4a-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
2012-07-18 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.4a-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
2012-01-12 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.4a-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
2011-02-08 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.4a-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
2009-07-24 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.4a-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

See Also

Package Description
compat-gcc-34-3.4.6-41.fc25.x86_64.rpm Compatibility GNU Compiler Collection
compat-gcc-34-c++-3.4.6-41.fc25.x86_64.rpm C++ support for compatibility compiler
compat-gcc-34-g77-3.4.6-41.fc25.x86_64.rpm Fortran 77 support for compatibility compiler
compat-gdbm-1.8.3-22.fc24.i686.rpm A GNU set of database routines compatibility library
compat-gdbm-1.8.3-22.fc24.x86_64.rpm A GNU set of database routines compatibility library
compat-gdbm-devel-1.8.3-22.fc24.i686.rpm Development libraries and header files for the gdbm library
compat-gdbm-devel-1.8.3-22.fc24.x86_64.rpm Development libraries and header files for the gdbm library
compat-gnutls28-3.3.21-1.fc24.i686.rpm Compat package with gnutls library ABI version 28
compat-gnutls28-3.3.21-1.fc24.x86_64.rpm Compat package with gnutls library ABI version 28
compat-gtkhtml314-3.32.2-8.fc24.i686.rpm GtkHTML library
compat-gtkhtml314-3.32.2-8.fc24.x86_64.rpm GtkHTML library
compat-gtkhtml314-devel-3.32.2-8.fc24.i686.rpm Libraries, includes, etc to develop gtkhtml applications
compat-gtkhtml314-devel-3.32.2-8.fc24.x86_64.rpm Libraries, includes, etc to develop gtkhtml applications
compat-guichan05-0.5.0-20.fc24.i686.rpm Compatibility libraries for older guichan versions
compat-guichan05-0.5.0-20.fc24.x86_64.rpm Compatibility libraries for older guichan versions
Advertisement
Advertisement