compat-readline5-devel-5.2-26.fc24.i686.rpm


Advertisement

Description

compat-readline5-devel - Files needed to develop programs which use the readline library

Property Value
Distribution Fedora 25
Repository Fedora x86_64
Package name compat-readline5-devel
Package version 5.2
Package release 26.fc24
Package architecture i686
Package type rpm
Installed size 61.41 KB
Download size 31.89 KB
Official Mirror dl.fedoraproject.org
The Readline library provides a set of functions that allow users to
edit typed command lines. If you want to develop programs that will
use the readline library, you need to have the readline-devel package
installed. You also need to have the readline package installed.

Alternatives

Package Version Architecture Repository
compat-readline5-devel-5.2-26.fc24.i686.rpm 5.2 i686 Fedora
compat-readline5-devel-5.2-26.fc24.x86_64.rpm 5.2 x86_64 Fedora
compat-readline5-devel - - -

Requires

Name Value
compat-readline5 = 5.2-26.fc24
libhistory.so.5 -
libreadline.so.5 -
ncurses-devel -

Provides

Name Value
compat-readline5-devel = 5.2-26.fc24
compat-readline5-devel(x86-32) = 5.2-26.fc24

Download

Type URL
Binary Package compat-readline5-devel-5.2-26.fc24.i686.rpm
Source Package compat-readline5-5.2-26.fc24.src.rpm

Install Howto

Install the compat-readline5-devel rpm package:

# dnf install compat-readline5-devel

Files

Path
/usr/include/readline5/
/usr/include/readline5/readline/chardefs.h
/usr/include/readline5/readline/history.h
/usr/include/readline5/readline/keymaps.h
/usr/include/readline5/readline/readline.h
/usr/include/readline5/readline/rlconf.h
/usr/include/readline5/readline/rlstdc.h
/usr/include/readline5/readline/rltypedefs.h
/usr/include/readline5/readline/tilde.h
/usr/lib/readline5/libhistory.so
/usr/lib/readline5/libreadline.so

Changelog

See compat-readline5-5.2-26.fc24.i686.rpm changelog.

See Also

Package Description
compat-readline5-static-5.2-26.fc24.i686.rpm Static libraries for the readline library
compat-readline5-static-5.2-26.fc24.x86_64.rpm Static libraries for the readline library
compat-tolua++-1.0.93-4.fc24.i686.rpm lua-5.1 compatible version of tolua++ (C++ Lua integration)
compat-tolua++-1.0.93-4.fc24.x86_64.rpm lua-5.1 compatible version of tolua++ (C++ Lua integration)
compat-tolua++-devel-1.0.93-4.fc24.i686.rpm Development files for compat-tolua++
compat-tolua++-devel-1.0.93-4.fc24.x86_64.rpm Development files for compat-tolua++
compat-wxBase3-gtk2-3.0.2-7.fc24.i686.rpm Non-GUI support classes from the wxWidgets library
compat-wxBase3-gtk2-3.0.2-7.fc24.x86_64.rpm Non-GUI support classes from the wxWidgets library
compat-wxGTK3-gtk2-3.0.2-7.fc24.i686.rpm GTK2 port of the wxWidgets GUI library
compat-wxGTK3-gtk2-3.0.2-7.fc24.x86_64.rpm GTK2 port of the wxWidgets GUI library
compat-wxGTK3-gtk2-devel-3.0.2-7.fc24.i686.rpm Development files for the wxGTK3 library
compat-wxGTK3-gtk2-devel-3.0.2-7.fc24.x86_64.rpm Development files for the wxGTK3 library
compat-wxGTK3-gtk2-docs-3.0.2-7.fc24.noarch.rpm Documentation for the wxGTK3 library
compat-wxGTK3-gtk2-gl-3.0.2-7.fc24.i686.rpm OpenGL add-on for the wxWidgets library
compat-wxGTK3-gtk2-gl-3.0.2-7.fc24.x86_64.rpm OpenGL add-on for the wxWidgets library
Advertisement
Advertisement