ampy-1.0.1-1.fc26.noarch.rpm


Advertisement

Description

ampy - Command line tool to interact with a MicroPython board over a serial connection

Property Value
Distribution Fedora 26
Repository Fedora x86_64
Package name ampy
Package version 1.0.1
Package release 1.fc26
Package architecture noarch
Package type rpm
Installed size 85.31 KB
Download size 28.17 KB
Official Mirror archives.fedoraproject.org
Adafruit MicroPython tool is a command line tool to interact with a MicroPython
board over a serial connection.
Ampy is meant to be a simple command line tool to manipulate files and run code
on a MicroPython board over its serial connection. With ampy you can send files
from your computer to a MicroPython board's file system, download files from a
board to your computer, and even send a Python script to a board to be
executed.
Note that ampy by design is meant to be simple and does not support advanced
interaction like a shell or terminal to send input to a board.

Alternatives

Package Version Architecture Repository
ampy-1.0.1-1.fc26.noarch.rpm 1.0.1 noarch Fedora
ampy - - -

Requires

Name Value
/usr/bin/python3 -
python(abi) = 3.6
python3-click -
python3-pyserial -
python3-setuptools -

Provides

Name Value
adafruit-ampy = 1.0.1-1.fc26
ampy = 1.0.1-1.fc26
python3-adafruit-ampy = 1.0.1-1.fc26
python3.6dist(adafruit-ampy) = 1.0.1
python3dist(adafruit-ampy) = 1.0.1

Download

Type URL
Binary Package ampy-1.0.1-1.fc26.noarch.rpm
Source Package ampy-1.0.1-1.fc26.src.rpm

Install Howto

Install the ampy rpm package:

# dnf install ampy

Files

Path
/usr/bin/ampy
/usr/lib/python3.6/site-packages/adafruit_ampy-1.0.1-py3.6.egg-info/PKG-INFO
/usr/lib/python3.6/site-packages/adafruit_ampy-1.0.1-py3.6.egg-info/SOURCES.txt
/usr/lib/python3.6/site-packages/adafruit_ampy-1.0.1-py3.6.egg-info/dependency_links.txt
/usr/lib/python3.6/site-packages/adafruit_ampy-1.0.1-py3.6.egg-info/entry_points.txt
/usr/lib/python3.6/site-packages/adafruit_ampy-1.0.1-py3.6.egg-info/requires.txt
/usr/lib/python3.6/site-packages/adafruit_ampy-1.0.1-py3.6.egg-info/top_level.txt
/usr/lib/python3.6/site-packages/ampy/__init__.py
/usr/lib/python3.6/site-packages/ampy/cli.py
/usr/lib/python3.6/site-packages/ampy/files.py
/usr/lib/python3.6/site-packages/ampy/pyboard.py
/usr/lib/python3.6/site-packages/ampy/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ampy/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/ampy/__pycache__/cli.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ampy/__pycache__/cli.cpython-36.pyc
/usr/lib/python3.6/site-packages/ampy/__pycache__/files.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ampy/__pycache__/files.cpython-36.pyc
/usr/lib/python3.6/site-packages/ampy/__pycache__/pyboard.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ampy/__pycache__/pyboard.cpython-36.pyc
/usr/share/doc/ampy/README.md
/usr/share/licenses/ampy/LICENSE

Changelog

2017-03-14 - Miro HronĨok <mhroncok@redhat.com> - 1.0.1-1
- Initial package

See Also

Package Description
amqp-1.0-6.20150701svn1688630.fc26.noarch.rpm The AMQP specification
amqp-devel-1.0-6.20150701svn1688630.fc26.noarch.rpm Development files for amqp
ams-2.1.1-8.fc26.x86_64.rpm Alsa Modular Synth, a realtime modular synthesizer
amsynth-1.7.1-1.fc26.x86_64.rpm A classic synthesizer with dual oscillators
amsynth-data-1.7.1-1.fc26.noarch.rpm Data files for amsynth
amtterm-1.6-1.fc26.x86_64.rpm Serial-over-lan (sol) client for Intel AMT
anaconda-26.21.11-1.fc26.x86_64.rpm Graphical system installer
anaconda-core-26.21.11-1.fc26.x86_64.rpm Core of the Anaconda installer
anaconda-dracut-26.21.11-1.fc26.x86_64.rpm The anaconda dracut module
anaconda-gui-26.21.11-1.fc26.x86_64.rpm Graphical user interface for the Anaconda installer
anaconda-realmd-0.2-6.fc26.noarch.rpm Anaconda addon which interacts with realmd to join domains
anaconda-tui-26.21.11-1.fc26.x86_64.rpm Textual user interface for the Anaconda installer
anaconda-user-help-26.1-5.fc26.noarch.rpm Content for the Anaconda built-in help system
anaconda-widgets-26.21.11-1.fc26.i686.rpm A set of custom GTK+ widgets for use with anaconda
anaconda-widgets-26.21.11-1.fc26.x86_64.rpm A set of custom GTK+ widgets for use with anaconda
Advertisement
Advertisement