phpcov-4.0.4-1.fc27.noarch.rpm


Advertisement

Description

phpcov - CLI frontend for PHP_CodeCoverage

Property Value
Distribution Fedora 27
Repository Fedora Updates i386
Package name phpcov
Package version 4.0.4
Package release 1.fc27
Package architecture noarch
Package type rpm
Installed size 25.17 KB
Download size 16.03 KB
Official Mirror download-ib01.fedoraproject.org
phpcov is a command-line frontend for the PHP_CodeCoverage library.

Alternatives

Package Version Architecture Repository
phpcov-6.0.0-1.fc27.remi.noarch.rpm 6.0.0 noarch Les RPM de Remi
phpcov-6.0.0-1.fc27.remi.noarch.rpm 6.0.0 noarch Les RPM de Remi
phpcov-5.0.0-1.fc27.remi.noarch.rpm 5.0.0 noarch Les RPM de Remi
phpcov-5.0.0-1.fc27.remi.noarch.rpm 5.0.0 noarch Les RPM de Remi
phpcov-4.0.4-1.fc27.noarch.rpm 4.0.4 noarch Fedora Updates
phpcov-4.0.1-2.fc27.noarch.rpm 4.0.1 noarch Fedora
phpcov-4.0.1-2.fc27.noarch.rpm 4.0.1 noarch Fedora
phpcov - - -

Requires

Name Value
(php-composer(phpunit/php-code-coverage) >= 5.2.1 with php-composer(phpunit/php-code-coverage) < 6)
(php-composer(sebastian/diff) >= 2 with php-composer(sebastian/diff) < 3)
(php-composer(sebastian/finder-facade) >= 1.1 with php-composer(sebastian/finder-facade) < 2)
(php-composer(sebastian/version) >= 2.0 with php-composer(sebastian/version) < 3)
(php-composer(symfony/console) >= 3.0 with php-composer(symfony/console) < 5)
/usr/bin/env -
php(language) >= 7.0
phpunit6 -

Provides

Name Value
php-composer(phpunit/phpcov) = 4.0.4
php-phpunit-phpcov = 4.0.4
phpcov = 4.0.4-1.fc27

Obsoletes

Name Value
php-phpunit-phpcov < 4

Download

Type URL
Binary Package phpcov-4.0.4-1.fc27.noarch.rpm
Source Package phpcov-4.0.4-1.fc27.src.rpm

Install Howto

Install phpcov rpm package:

# dnf install phpcov

Files

Path
/usr/bin/phpcov
/usr/share/doc/phpcov/README.md
/usr/share/doc/phpcov/composer.json
/usr/share/licenses/phpcov/LICENSE
/usr/share/php/SebastianBergmann/PHPCOV/Application.php
/usr/share/php/SebastianBergmann/PHPCOV/BaseCommand.php
/usr/share/php/SebastianBergmann/PHPCOV/ExecuteCommand.php
/usr/share/php/SebastianBergmann/PHPCOV/MergeCommand.php
/usr/share/php/SebastianBergmann/PHPCOV/PatchCoverage.php
/usr/share/php/SebastianBergmann/PHPCOV/PatchCoverageCommand.php
/usr/share/php/SebastianBergmann/PHPCOV/autoload.php

Changelog

2018-01-18 - Remi Collet <remi@remirepo.net> - 4.0.4-1
- Update to 4.0.4 (no change)
- raise dependency on symfony/console 3
- use range dependency on F27
2017-11-19 - Remi Collet <remi@remirepo.net> - 4.0.3-1
- Update to 4.0.3
- Allow Symfony 4
2017-10-22 - Remi Collet <remi@remirepo.net> - 4.0.2-1
- Update to 4.0.2
- raise dependency on phpunit/php-code-coverage 5.2.1
- drop dependency on php-phpunit-diff
- add dependency on php-sebastian-diff2
2017-07-27 - Fedora Release Engineering <releng@fedoraproject.org> - 4.0.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-04-28 - Remi Collet <remi@remirepo.net> - 4.0.1-1
- Update to 4.0.1
2017-04-24 - Remi Collet <remi@remirepo.net> - 4.0.0-2
- fix composer provide (from review #1420384)
- fix composer.json perm
2017-02-08 - Remi Collet <remi@fedoraproject.org> - 4.0.0-1
- rename to phpcov
- update to 4.0.0
- change dependencies to PHPUnit v6
2016-06-03 - Remi Collet <remi@fedoraproject.org> - 3.1.0-1
- Update to 3.1.0
- raise dependency on phpunit/php-code-coverage >= 4.0
- drop the autoloader template, simply generate it
2016-04-18 - Remi Collet <remi@fedoraproject.org> - 3.0.0-3
- allow sebastian/version 2.0
2016-01-09 - Remi Collet <remi@fedoraproject.org> - 3.0.0-1
- update to 3.0.0
- raise minimal PHP version to 5.6
- raise dependencies on phpunit ~5.0, php-code-coverage ~3.0
- allow symfony 3
- run test suite with both PHP 6 and 7 when available

See Also

Package Description
phpunit6-6.5.13-1.fc27.noarch.rpm The PHP Unit Testing framework
picmi-17.12.1-1.fc27.i686.rpm A nonogram logic game
pidgin-2.13.0-1.fc27.i686.rpm A Gtk+ based multiprotocol instant messaging client
pidgin-devel-2.13.0-1.fc27.i686.rpm Development headers and libraries for pidgin
pidgin-discord-0-20.20180628git84fe764.fc27.noarch.rpm Adds pixmaps, icons and smileys for Discord protocol
pidgin-docs-2.13.0-1.fc27.i686.rpm API docs for pidgin and libpurple
pidgin-hangouts-0-60.20180731hge4ccf26.fc27.noarch.rpm Adds pixmaps, icons and smileys for Hangouts protocol
pidgin-libsteam-1.6.1-23.20180801gitb16a636.fc27.noarch.rpm Adds pixmaps, icons and smileys for Steam protocol
pidgin-matrix-0-9.20180325git49ea988.fc27.noarch.rpm Adds pixmaps, icons and smileys for Matrix protocol
pidgin-perl-2.13.0-1.fc27.i686.rpm Perl scripting support for Pidgin
pidgin-sipe-1.24.0-1.fc27.i686.rpm Pidgin protocol plugin to connect to MS Office Communicator
pidgin-skypeweb-1.5-3.20180720git2290013.fc27.noarch.rpm Adds pixmaps, icons and smileys for Skype protocol
piglit-1.0.20171027-7.GIT65b4b197.fc27.i686.rpm Collection of automated tests for OpenGL implementations
pigz-2.4-1.fc27.i686.rpm Parallel implementation of gzip
pim-data-exporter-17.12.3-1.fc27.i686.rpm Pim Data Exporter
Advertisement
Advertisement