polkit-0.113-16.fc27.i686.rpm


Advertisement

Description

polkit - An authorization framework

Property Value
Distribution Fedora 27
Repository Fedora Updates i386
Package name polkit
Package version 0.113
Package release 16.fc27
Package architecture i686
Package type rpm
Installed size 291.26 KB
Download size 136.35 KB
Official Mirror download-ib01.fedoraproject.org
polkit is a toolkit for defining and handling authorizations.  It is
used for allowing unprivileged processes to speak to privileged
processes.

Alternatives

Package Version Architecture Repository
polkit-0.113-16.fc27.x86_64.rpm 0.113 x86_64 Fedora Updates
polkit-0.113-15.fc27.x86_64.rpm 0.113 x86_64 Fedora
polkit-0.113-15.fc27.i686.rpm 0.113 i686 Fedora
polkit - - -

Requires

Name Value
/sbin/ldconfig -
dbus -
libc.so.6(GLIBC_2.7) -
libexpat.so.1 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libmozjs-17.0.so -
libmozjs-17.0.so(mozjs_17.0) -
libpam.so.0 -
libpam.so.0(LIBPAM_1.0) -
libpolkit-agent-1.so.0 -
libpolkit-gobject-1.so.0 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
libsystemd.so.0 -
libsystemd.so.0(LIBSYSTEMD_209) -
libsystemd.so.0(LIBSYSTEMD_213) -
polkit-libs(x86-32) = 0.113-16.fc27
polkit-pkla-compat -
rtld(GNU_HASH) -
shadow-utils -
systemd -

Provides

Name Value
PolicyKit = 0.11
polkit = 0.113-16.fc27
polkit(x86-32) = 0.113-16.fc27
polkit-desktop-policy = 0.103
polkit-js-engine = 0.113-16.fc27

Conflicts

Name Value
polkit-gnome < 0.97

Obsoletes

Name Value
PolicyKit <= 0.10
polkit < 0.113-3
polkit-desktop-policy < 0.103
polkit-js-engine < 0.110-4

Download

Type URL
Binary Package polkit-0.113-16.fc27.i686.rpm
Source Package polkit-0.113-16.fc27.src.rpm

Install Howto

Install polkit rpm package:

# dnf install polkit

Files

Path
/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
/etc/pam.d/polkit-1
/etc/polkit-1/
/etc/polkit-1/rules.d/50-default.rules
/usr/bin/pkaction
/usr/bin/pkcheck
/usr/bin/pkexec
/usr/bin/pkttyagent
/usr/lib/.build-id/
/usr/lib/.build-id/4a/8e70163f142ba90b290eada9e41170a882cbb4
/usr/lib/.build-id/50/169b53cb42181cf1c9a2d9d8bb7211f6fa1a3a
/usr/lib/.build-id/a9/8fcc577f849bb6390500acf578338a7bf5bbd0
/usr/lib/.build-id/aa/1085dfa9ad6e220b73eff4df47d013664de9fd
/usr/lib/.build-id/af/dc0618b6f549e138fe6b6eeb5a6310b7ed81af
/usr/lib/.build-id/e5/a818c4c02dc8808d5af03da9757d636b668514
/usr/lib/polkit-1/polkit-agent-helper-1
/usr/lib/polkit-1/polkitd
/usr/lib/systemd/system/polkit.service
/usr/share/dbus-1/system-services/org.freedesktop.PolicyKit1.service
/usr/share/doc/polkit/COPYING
/usr/share/doc/polkit/NEWS
/usr/share/doc/polkit/README
/usr/share/locale/cs/LC_MESSAGES/polkit-1.mo
/usr/share/locale/da/LC_MESSAGES/polkit-1.mo
/usr/share/man/man1/pkaction.1.gz
/usr/share/man/man1/pkcheck.1.gz
/usr/share/man/man1/pkexec.1.gz
/usr/share/man/man1/pkttyagent.1.gz
/usr/share/man/man8/polkit.8.gz
/usr/share/man/man8/polkitd.8.gz
/usr/share/polkit-1/
/usr/share/polkit-1/actions/org.freedesktop.policykit.policy
/usr/share/polkit-1/rules.d/

Changelog

2018-07-11 - Miloslav Trmač <mitr@redhat.com> - 0.113-16
- Fix CVE-2018-1116
2017-08-03 - Fedora Release Engineering <releng@fedoraproject.org> - 0.113-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
2017-07-27 - Fedora Release Engineering <releng@fedoraproject.org> - 0.113-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-04-13 - Richard Hughes <rhughes@redhat.com> - 0.113-13
- Add the its files from upstream.
2017-04-04 - Miloslav Trmač <mitr@redhat.com> - 0.113-12
- Fix a memory leak in PolkitPermission.
Patch by Rui Matos <tiagomatos@gmail.com>
Resolves: #1433915
2017-04-04 - Miloslav Trmač <mitr@redhat.com> - 0.113-11
- Revert back to the state in 0.113-7, undoing the untested changes.
2017-04-04 - Peter Robinson <pbrobinson@fedoraproject.org> 0.113-10
- Move to an upstream snapshot, rebase patches
2017-03-31 - Rex Dieter <rdieter@fedoraproject.org> - 0.113-9
- restore Provides: polkit-desktop-policy polkit-js-engine
2017-03-30 - Peter Robinson <pbrobinson@fedoraproject.org> 0.113-8
- Use %license, license needs to be in -libs as it's the only guaranteed installed package
- Move to mozjs38
- Other upstream fixes
- Spec cleanups
2017-02-13 - Miloslav Trmač <mitr@redhat.com> - 0.113-7
- Fix memory leaks when calling authentication agents
Resolves: #1380166

See Also

Package Description
polkit-devel-0.113-16.fc27.i686.rpm Development files for polkit
polkit-docs-0.113-16.fc27.noarch.rpm Development documentation for polkit
polkit-kde-5.12.7-1.fc27.i686.rpm PolicyKit integration for KDE Desktop
polkit-libs-0.113-16.fc27.i686.rpm Libraries for polkit
polymake-3.1-11.fc27.i686.rpm Algorithms on convex polytopes and polyhedra
polymake-doc-3.1-11.fc27.i686.rpm Documentation for polymake
polymake-singular-3.1-11.fc27.i686.rpm Plugin to access Singular from polymake
polyml-5.7.1-1.fc27.i686.rpm Poly/ML compiler and runtime system
polyml-doc-5.7.1-1.fc27.noarch.rpm Poly/ML documentation
polyml-libs-5.7.1-1.fc27.i686.rpm Poly/ML runtime libraries
pop-gtk-theme-2.2.3.0-2.fc27.noarch.rpm Version 2 of the Pop GTK+ Theme
pop-icon-theme-0.1.0-0.3.20180405gitb1b46e8.fc27.noarch.rpm System76 Pop icon theme for Linux
poppler-0.57.0-10.fc27.i686.rpm PDF rendering library
poppler-cpp-0.57.0-10.fc27.i686.rpm Pure C++ wrapper for poppler
poppler-cpp-devel-0.57.0-10.fc27.i686.rpm Development files for C++ wrapper
Advertisement
Advertisement