poppler-glib-0.57.0-10.fc27.i686.rpm


Advertisement

Description

poppler-glib - Glib wrapper for poppler

Property Value
Distribution Fedora 27
Repository Fedora Updates i386
Package filename poppler-glib-0.57.0-10.fc27.i686.rpm
Package name poppler-glib
Package version 0.57.0
Package release 10.fc27
Package architecture i686
Package type rpm
Homepage -
License -
Maintainer -
Download size 154.59 KB
Installed size 432.92 KB
Glib wrapper for poppler.

Alternatives

Package Version Architecture Repository
poppler-glib-0.57.0-10.fc27.x86_64.rpm 0.57.0 x86_64 Fedora Updates
poppler-glib-0.57.0-10.fc27.i686.rpm 0.57.0 i686 Fedora Updates
poppler-glib-0.57.0-2.fc27.x86_64.rpm 0.57.0 x86_64 Fedora
poppler-glib-0.57.0-2.fc27.i686.rpm 0.57.0 i686 Fedora
poppler-glib-0.57.0-2.fc27.i686.rpm 0.57.0 i686 Fedora
poppler-glib - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4) -
libcairo.so.2 -
libfreetype.so.6 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libpoppler.so.68 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.20) -
poppler(x86-32) = 0.57.0-10.fc27
rtld(GNU_HASH) -

Provides

Name Value
libpoppler-glib.so.8 -
poppler-glib = 0.57.0-10.fc27
poppler-glib(x86-32) = 0.57.0-10.fc27

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package poppler-glib-0.57.0-10.fc27.i686.rpm
Source Package poppler-0.57.0-10.fc27.src.rpm

Install Howto

Install poppler-glib rpm package:

# dnf install poppler-glib

Files

Path
/usr/lib/libpoppler-glib.so.8
/usr/lib/libpoppler-glib.so.8.9.0
/usr/lib/.build-id/
/usr/lib/.build-id/03/c59eb097e20600ac07ba3e6f84dcb042f09b45
/usr/lib/girepository-1.0/Poppler-0.18.typelib

Changelog

2018-07-26 - Marek Kasik <mkasik@redhat.com> - 0.57.0-10
- Fix crash when Object has negative number (CVE-2018-13988)
- Resolves: #1607461
2018-05-28 - Marek Kasik <mkasik@redhat.com> - 0.57.0-9
- Fix infinite recursion (CVE-2017-18267)
- Resolves: #1578780
2018-01-16 - Caolán McNamara <caolanm@redhat.com> - 0.57.0-8
- Resolves: rhbz#1534706 unable to open some valid pdf files
2018-01-05 - David Tardon <dtardon@redhat.com> - 0.57.0-7
- Resolves: rhbz#1531383 CVE-2017-1000456 Invalid read in TextPool::addWord()
causes crash and can lead to overflow in subsequent calculations
2017-11-09 - David Tardon <dtardon@redhat.com> - 0.57.0-6
- Resolves: rhbz#1510980 CVE-2017-15565
2017-10-11 - David Tardon <dtardon@redhat.com> - 0.57.0-5
- Resolves: rhbz#1500326 CVE-2017-14926 CVE-2017-14927 CVE-2017-14928
2017-10-10 - David Tardon <dtardon@redhat.com> - 0.57.0-4
- Resolves: rhbz#1499906 CVE-2017-14617
2017-10-08 - David Tardon <dtardon@redhat.com> - 0.57.0-3
- Resolves: rhbz#1499168 CVE-2017-14517 CVE-2017-14518 CVE-2017-14519
CVE-2017-14929
2017-09-25 - Caolán McNamara <caolanm@redhat.com> - 0.57.0-2
- Resolves: rhbz#1494583 CVE-2017-14520
2017-08-03 - David Tardon <dtardon@redhat.com> - 0.57.0-1
- new upstream release

See Also

Package Description
poppler-glib-devel-0.57.0-10.fc27.i686.rpm Development files for glib wrapper
poppler-glib-doc-0.57.0-10.fc27.noarch.rpm Documentation for glib wrapper
poppler-qt-0.57.0-10.fc27.i686.rpm Qt4 wrapper for poppler
poppler-qt-devel-0.57.0-10.fc27.i686.rpm Development files for Qt4 wrapper
poppler-qt5-0.57.0-10.fc27.i686.rpm Qt5 wrapper for poppler
poppler-qt5-devel-0.57.0-10.fc27.i686.rpm Development files for Qt5 wrapper
poppler-utils-0.57.0-10.fc27.i686.rpm Command line utilities for converting PDF files
popub-local-0-0.3.20171007git6ffa11c.fc27.i686.rpm Publish a service from localhost onto your server - client side
popub-relay-0-0.3.20171007git6ffa11c.fc27.i686.rpm Publish a service from localhost onto your server - server side
porcupine-0.1.0-1.fc27.noarch.rpm Web browser to copy URL to clipboard
postbooks-4.10.1-17.fc27.i686.rpm xTuple Accounting/ERP suite desktop client
postbooks-devel-4.10.1-17.fc27.i686.rpm PostBooks development files
postbooks-libs-4.10.1-17.fc27.i686.rpm Shared libraries for PostBooks
postfix-3.2.6-1.fc27.i686.rpm Postfix Mail Transport Agent
postfix-cdb-3.2.6-1.fc27.i686.rpm Postfix CDB map support
Advertisement
Advertisement