poppler-qt5-devel-0.57.0-10.fc27.i686.rpm


Advertisement

Description

poppler-qt5-devel - Development files for Qt5 wrapper

Property Value
Distribution Fedora 27
Repository Fedora Updates i386
Package filename poppler-qt5-devel-0.57.0-10.fc27.i686.rpm
Package name poppler-qt5-devel
Package version 0.57.0
Package release 10.fc27
Package architecture i686
Package type rpm
Homepage -
License -
Maintainer -
Download size 57.05 KB
Installed size 127.47 KB
Development files for Qt5 wrapper.

Alternatives

Package Version Architecture Repository
poppler-qt5-devel-0.57.0-10.fc27.x86_64.rpm 0.57.0 x86_64 Fedora Updates
poppler-qt5-devel-0.57.0-10.fc27.i686.rpm 0.57.0 i686 Fedora Updates
poppler-qt5-devel-0.57.0-2.fc27.x86_64.rpm 0.57.0 x86_64 Fedora
poppler-qt5-devel-0.57.0-2.fc27.i686.rpm 0.57.0 i686 Fedora
poppler-qt5-devel-0.57.0-2.fc27.i686.rpm 0.57.0 i686 Fedora
poppler-qt5-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libpoppler-qt5.so.1 -
pkgconfig(poppler) = 0.57.0
poppler-devel(x86-32) = 0.57.0-10.fc27
poppler-qt5(x86-32) = 0.57.0-10.fc27
qt5-qtbase-devel -

Provides

Name Value
pkgconfig(poppler-qt5) = 0.57.0
poppler-qt5-devel = 0.57.0-10.fc27
poppler-qt5-devel(x86-32) = 0.57.0-10.fc27

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package poppler-qt5-devel-0.57.0-10.fc27.i686.rpm
Source Package poppler-0.57.0-10.fc27.src.rpm

Install Howto

Install poppler-qt5-devel rpm package:

# dnf install poppler-qt5-devel

Files

Path
/usr/include/poppler/qt5/poppler-annotation.h
/usr/include/poppler/qt5/poppler-export.h
/usr/include/poppler/qt5/poppler-form.h
/usr/include/poppler/qt5/poppler-link-private.h
/usr/include/poppler/qt5/poppler-link.h
/usr/include/poppler/qt5/poppler-media.h
/usr/include/poppler/qt5/poppler-optcontent.h
/usr/include/poppler/qt5/poppler-page-transition.h
/usr/include/poppler/qt5/poppler-qt5.h
/usr/lib/libpoppler-qt5.so
/usr/lib/pkgconfig/poppler-qt5.pc

Changelog

2018-07-26 - Marek Kasik <mkasik@redhat.com> - 0.57.0-10
- Fix crash when Object has negative number (CVE-2018-13988)
- Resolves: #1607461
2018-05-28 - Marek Kasik <mkasik@redhat.com> - 0.57.0-9
- Fix infinite recursion (CVE-2017-18267)
- Resolves: #1578780
2018-01-16 - Caolán McNamara <caolanm@redhat.com> - 0.57.0-8
- Resolves: rhbz#1534706 unable to open some valid pdf files
2018-01-05 - David Tardon <dtardon@redhat.com> - 0.57.0-7
- Resolves: rhbz#1531383 CVE-2017-1000456 Invalid read in TextPool::addWord()
causes crash and can lead to overflow in subsequent calculations
2017-11-09 - David Tardon <dtardon@redhat.com> - 0.57.0-6
- Resolves: rhbz#1510980 CVE-2017-15565
2017-10-11 - David Tardon <dtardon@redhat.com> - 0.57.0-5
- Resolves: rhbz#1500326 CVE-2017-14926 CVE-2017-14927 CVE-2017-14928
2017-10-10 - David Tardon <dtardon@redhat.com> - 0.57.0-4
- Resolves: rhbz#1499906 CVE-2017-14617
2017-10-08 - David Tardon <dtardon@redhat.com> - 0.57.0-3
- Resolves: rhbz#1499168 CVE-2017-14517 CVE-2017-14518 CVE-2017-14519
CVE-2017-14929
2017-09-25 - Caolán McNamara <caolanm@redhat.com> - 0.57.0-2
- Resolves: rhbz#1494583 CVE-2017-14520
2017-08-03 - David Tardon <dtardon@redhat.com> - 0.57.0-1
- new upstream release

See Also

Package Description
poppler-utils-0.57.0-10.fc27.i686.rpm Command line utilities for converting PDF files
popub-local-0-0.3.20171007git6ffa11c.fc27.i686.rpm Publish a service from localhost onto your server - client side
popub-relay-0-0.3.20171007git6ffa11c.fc27.i686.rpm Publish a service from localhost onto your server - server side
porcupine-0.1.0-1.fc27.noarch.rpm Web browser to copy URL to clipboard
postbooks-4.10.1-17.fc27.i686.rpm xTuple Accounting/ERP suite desktop client
postbooks-devel-4.10.1-17.fc27.i686.rpm PostBooks development files
postbooks-libs-4.10.1-17.fc27.i686.rpm Shared libraries for PostBooks
postfix-3.2.6-1.fc27.i686.rpm Postfix Mail Transport Agent
postfix-cdb-3.2.6-1.fc27.i686.rpm Postfix CDB map support
postfix-ldap-3.2.6-1.fc27.i686.rpm Postfix LDAP map support
postfix-mysql-3.2.6-1.fc27.i686.rpm Postfix MySQL map support
postfix-pcre-3.2.6-1.fc27.i686.rpm Postfix PCRE map support
postfix-perl-scripts-3.2.6-1.fc27.i686.rpm Postfix utilities written in perl
postfix-pgsql-3.2.6-1.fc27.i686.rpm Postfix PostgreSQL map support
postfix-sqlite-3.2.6-1.fc27.i686.rpm Postfix SQLite map support
Advertisement
Advertisement