ptpython3-0.41-3.fc27.noarch.rpm


Advertisement

Description

ptpython3 - Python REPL build on top of prompt_toolkit

Property Value
Distribution Fedora 27
Repository Fedora Updates i386
Package name ptpython3
Package version 0.41
Package release 3.fc27
Package architecture noarch
Package type rpm
Installed size 325.60 KB
Download size 90.51 KB
Official Mirror download-ib01.fedoraproject.org
Ptpython is an advanced Python REPL built on top of the prompt_toolkit library.
It features syntax highlighting, multiline editing (the up arrow works),
autocompletion, mouse support, support for color schemes, support for bracketed
paste, both Vi and Emacs key bindings, support for double width (Chinese)
characters, and many other things.

Alternatives

Package Version Architecture Repository
ptpython3-0.41-3.fc27.noarch.rpm 0.41 noarch Fedora Updates
ptpython3-0.39-2.fc27.noarch.rpm 0.39 noarch Fedora
ptpython3-0.39-2.fc27.noarch.rpm 0.39 noarch Fedora
ptpython3 - - -

Requires

Name Value
/usr/bin/python3 -
python(abi) = 3.6
python3-docopt -
python3-jedi >= 0.9.0
python3-prompt_toolkit >= 1.0.14
python3-pygments -

Provides

Name Value
ptpython3 = 0.41-3.fc27
python3-ptpython = 0.41-3.fc27
python3.6dist(ptpython) = 0.41
python3dist(ptpython) = 0.41

Download

Type URL
Binary Package ptpython3-0.41-3.fc27.noarch.rpm
Source Package ptpython-0.41-3.fc27.src.rpm

Install Howto

Install ptpython3 rpm package:

# dnf install ptpython3

Files

Path
/usr/bin/ptipython3
/usr/bin/ptipython3.6
/usr/bin/ptpython3
/usr/bin/ptpython3.6
/usr/lib/python3.6/site-packages/ptpython/__init__.py
/usr/lib/python3.6/site-packages/ptpython/__main__.py
/usr/lib/python3.6/site-packages/ptpython/completer.py
/usr/lib/python3.6/site-packages/ptpython/eventloop.py
/usr/lib/python3.6/site-packages/ptpython/filters.py
/usr/lib/python3.6/site-packages/ptpython/history_browser.py
/usr/lib/python3.6/site-packages/ptpython/ipython.py
/usr/lib/python3.6/site-packages/ptpython/key_bindings.py
/usr/lib/python3.6/site-packages/ptpython/layout.py
/usr/lib/python3.6/site-packages/ptpython/prompt_style.py
/usr/lib/python3.6/site-packages/ptpython/python_input.py
/usr/lib/python3.6/site-packages/ptpython/repl.py
/usr/lib/python3.6/site-packages/ptpython/style.py
/usr/lib/python3.6/site-packages/ptpython/utils.py
/usr/lib/python3.6/site-packages/ptpython/validator.py
/usr/lib/python3.6/site-packages/ptpython-0.41-py3.6.egg-info/PKG-INFO
/usr/lib/python3.6/site-packages/ptpython-0.41-py3.6.egg-info/SOURCES.txt
/usr/lib/python3.6/site-packages/ptpython-0.41-py3.6.egg-info/dependency_links.txt
/usr/lib/python3.6/site-packages/ptpython-0.41-py3.6.egg-info/entry_points.txt
/usr/lib/python3.6/site-packages/ptpython-0.41-py3.6.egg-info/requires.txt
/usr/lib/python3.6/site-packages/ptpython-0.41-py3.6.egg-info/top_level.txt
/usr/lib/python3.6/site-packages/ptpython/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/__main__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/__main__.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/completer.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/completer.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/eventloop.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/eventloop.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/filters.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/filters.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/history_browser.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/history_browser.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/ipython.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/ipython.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/key_bindings.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/key_bindings.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/layout.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/layout.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/prompt_style.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/prompt_style.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/python_input.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/python_input.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/repl.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/repl.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/style.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/style.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/utils.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/utils.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/validator.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/__pycache__/validator.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/contrib/__init__.py
/usr/lib/python3.6/site-packages/ptpython/contrib/asyncssh_repl.py
/usr/lib/python3.6/site-packages/ptpython/contrib/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/contrib/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/contrib/__pycache__/asyncssh_repl.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/contrib/__pycache__/asyncssh_repl.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/entry_points/__init__.py
/usr/lib/python3.6/site-packages/ptpython/entry_points/run_ptipython.py
/usr/lib/python3.6/site-packages/ptpython/entry_points/run_ptpython.py
/usr/lib/python3.6/site-packages/ptpython/entry_points/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/entry_points/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/entry_points/__pycache__/run_ptipython.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/entry_points/__pycache__/run_ptipython.cpython-36.pyc
/usr/lib/python3.6/site-packages/ptpython/entry_points/__pycache__/run_ptpython.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/ptpython/entry_points/__pycache__/run_ptpython.cpython-36.pyc
/usr/share/doc/ptpython3/CHANGELOG
/usr/share/doc/ptpython3/README.rst
/usr/share/licenses/ptpython3/LICENSE

Changelog

2017-11-28 - Carl George <carl@george.computer> - 0.41-3
- Re-rebuild for F27
2017-09-25 - Carl George <carl@george.computer> - 0.41-2
- Require python2-jedi
2017-07-27 - Carl George <carl@george.computer> - 0.41-1
- Latest upstream
2017-07-27 - Fedora Release Engineering <releng@fedoraproject.org> - 0.39-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-05-02 - Carl George <carl.george@rackspace.com> - 0.39-1
- Latest upstream
- Add patch0 to undo https://github.com/jonathanslenders/ptpython/commit/16e4e31
2017-03-18 - Carl George <carl.george@rackspace.com> - 0.36-1
- Initial package.

See Also

Package Description
ptscotch-mpich-6.0.5-1.fc27.i686.rpm PT-Scotch libraries compiled against mpich
ptscotch-mpich-devel-6.0.5-1.fc27.i686.rpm Development libraries for PT-Scotch (mpich)
ptscotch-mpich-devel-parmetis-6.0.5-1.fc27.i686.rpm Parmetis compatibility header for scotch
ptscotch-openmpi-6.0.5-1.fc27.i686.rpm PT-Scotch libraries compiled against openmpi
ptscotch-openmpi-devel-6.0.5-1.fc27.i686.rpm Development libraries for PT-Scotch (openmpi)
ptscotch-openmpi-devel-parmetis-6.0.5-1.fc27.i686.rpm Parmetis compatibility header for scotch
publicsuffix-list-20180514-1.fc27.noarch.rpm Cross-vendor public domain suffix database
publicsuffix-list-dafsa-20180514-1.fc27.noarch.rpm Cross-vendor public domain suffix database in DAFSA form
pulldown-cmark-0.1.0-2.fc27.i686.rpm Pull parser for CommonMark
pulledpork-0.7.3-1.fc27.noarch.rpm Pulled Pork for Snort and Suricata rule management
pulp-admin-client-2.13.4-3.fc27.noarch.rpm Admin tool to administer the pulp server
pulp-agent-2.13.4-3.fc27.noarch.rpm The Pulp agent
pulp-consumer-client-2.13.4-3.fc27.noarch.rpm Consumer tool to administer the pulp consumer
pulp-doc-2.13.4-3.fc27.noarch.rpm Pulp documentation
pulp-nodes-admin-extensions-2.13.4-3.fc27.noarch.rpm Pulp admin client extensions
Advertisement
Advertisement