rpm-libs-4.14.2.1-1.fc27.i686.rpm


Advertisement

Description

rpm-libs - Libraries for manipulating RPM packages

Property Value
Distribution Fedora 27
Repository Fedora Updates i386
Package filename rpm-libs-4.14.2.1-1.fc27.i686.rpm
Package name rpm-libs
Package version 4.14.2.1
Package release 1.fc27
Package architecture i686
Package type rpm
Homepage -
License -
Maintainer -
Download size 356.90 KB
Installed size 726.45 KB
This package contains the RPM shared libraries.

Alternatives

Package Version Architecture Repository
rpm-libs-4.14.2.1-1.fc27.x86_64.rpm 4.14.2.1 x86_64 Fedora Updates
rpm-libs-4.14.2.1-1.fc27.i686.rpm 4.14.2.1 i686 Fedora Updates
rpm-libs-4.14.0-2.fc27.x86_64.rpm 4.14.0 x86_64 Fedora
rpm-libs-4.14.0-2.fc27.i686.rpm 4.14.0 i686 Fedora
rpm-libs-4.14.0-2.fc27.i686.rpm 4.14.0 i686 Fedora
rpm-libs - - -

Requires

Name Value
/sbin/ldconfig -
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libacl.so.1 -
libacl.so.1(ACL_1.0) -
libbz2.so.1 -
libc.so.6(GLIBC_2.17) -
libcap(x86-32) >= 2.16
libcap.so.2 -
libcrypto.so.1.1 -
libcrypto.so.1.1(OPENSSL_1_1_0) -
libdb-5.3.so -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libelf.so.1 -
libelf.so.1(ELFUTILS_1.0) -
liblua-5.3.so -
liblzma.so.5 -
liblzma.so.5(XZ_5.0) -
liblzma.so.5(XZ_5.2) -
libm.so.6 -
libpopt.so.0 -
libpopt.so.0(LIBPOPT_0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libz.so.1 -
libz.so.1(ZLIB_1.2.3.3) -
libzstd.so.1 -
rpm = 4.14.2.1-1.fc27
rpm-plugin-selinux(x86-32) = 4.14.2.1-1.fc27
rtld(GNU_HASH) -

Provides

Name Value
librpm.so.8 -
librpmio.so.8 -
rpm-libs = 4.14.2.1-1.fc27
rpm-libs(x86-32) = 4.14.2.1-1.fc27

Obsoletes

Name Value
compat-librpm3 < 4.14.2.1-1.fc27

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package rpm-libs-4.14.2.1-1.fc27.i686.rpm
Source Package rpm-4.14.2.1-1.fc27.src.rpm

Install Howto

Install rpm-libs rpm package:

# dnf install rpm-libs

Files

Path
/usr/lib/librpm.so.8
/usr/lib/librpm.so.8.1.0
/usr/lib/librpmio.so.8
/usr/lib/librpmio.so.8.1.0
/usr/lib/.build-id/
/usr/lib/.build-id/5b/dd83309b3582ea8e55baaeefd86addae1edb36
/usr/lib/.build-id/66/5c98c893191c83ff0ee7d8a813aee59e4af940
/usr/lib/rpm-plugins/

Changelog

2018-10-22 - Panu Matilainen <pmatilai@redhat.com> - 4.14.2.1-1
- Update to rpm 4.14.2.1 (http://rpm.org/wiki/Releases/4.14.2.1)
2018-09-06 - Panu Matilainen <pmatilai@redhat.com> - 4.14.2-1
- Rebase to 4.14.2 (http://rpm.org/wiki/Releases/4.14.2)
- ima-evm-utils packaging is now same as in newer Fedoras, update BR
2018-02-01 - Panu Matilainen <pmatilai@redhat.com> - 4.14.1-1
- Rebase to 4.14.1 (http://rpm.org/wiki/Releases/4.14.1)
2017-10-12 - Panu Matilainen <pmatilai@redhat.com> - 4.14.0-2
- Dump out test-suite log in case of failures again
- Don't assume per-user groups in test-suite
2017-10-12 - Panu Matilainen <pmatilai@redhat.com> - 4.14.0-1
- Rebase to rpm 4.14.0 final (http://rpm.org/wiki/Releases/4.14.0)
2017-10-10 - Troy Dawson <tdawson@redhat.com> - 4.14.0-0.rc2.6
- Cleanup spec file conditionals
2017-10-03 - Panu Matilainen <pmatilai@redhat.com> - 4.14.0-0.rc2.5
- Add build conditionals for zstd and lmdb support
- Enable zstd support
2017-10-03 - Panu Matilainen <pmatilai@redhat.com> - 4.14.0-0.rc2.4
- Spec cleanups
2017-09-29 - Panu Matilainen <pmatilai@redhat.com> - 4.14.0-0.rc2.3
- BuildRequire gnupg2 for the testsuite
2017-09-29 - Panu Matilainen <pmatilai@redhat.com> - 4.14.0-0.rc2.2
- ima-evm-utils only has a -devel package in fedora >= 28

See Also

Package Description
rpm-ostree-2018.4-1.fc27.i686.rpm Hybrid image/package system
rpm-ostree-devel-2018.4-1.fc27.i686.rpm Development headers for rpm-ostree
rpm-ostree-libs-2018.4-1.fc27.i686.rpm Shared library for rpm-ostree
rpm-plugin-ima-4.14.2.1-1.fc27.i686.rpm Rpm plugin ima file signatures
rpm-plugin-prioreset-4.14.2.1-1.fc27.i686.rpm Rpm plugin for resetting scriptlet priorities for SysV init
rpm-plugin-selinux-4.14.2.1-1.fc27.i686.rpm Rpm plugin for SELinux functionality
rpm-plugin-syslog-4.14.2.1-1.fc27.i686.rpm Rpm plugin for syslog functionality
rpm-plugin-systemd-inhibit-4.14.2.1-1.fc27.i686.rpm Rpm plugin for systemd inhibit functionality
rpm-sign-4.14.2.1-1.fc27.i686.rpm Package signing support
rpmbuild-order-0.2.1-1.fc27.i686.rpm Order RPM packages by dependencies
rpmdeplint-1.4-1.fc27.noarch.rpm Tool to find errors in RPM packages in the context of their dependency graph
rpmdevtools-8.10-6.fc27.noarch.rpm RPM Development Tools
rpmgrill-0.33-1.fc27.noarch.rpm A utility for catching problems in koji builds
rpmlint-1.10-5.fc27.noarch.rpm Tool for checking common errors in RPM packages
rpy-2.8.6-8.fc27.i686.rpm Python interface to the R language
Advertisement
Advertisement