webkitgtk4-2.22.4-1.fc27.i686.rpm


Advertisement

Description

webkitgtk4 - GTK+ Web content engine library

Property Value
Distribution Fedora 27
Repository Fedora Updates Testing i386
Package filename webkitgtk4-2.22.4-1.fc27.i686.rpm
Package name webkitgtk4
Package version 2.22.4
Package release 1.fc27
Package architecture i686
Package type rpm
Homepage -
License -
Maintainer -
Download size 15.10 MB
Installed size 51.24 MB
WebKitGTK+ is the port of the portable web rendering engine WebKit to the
GTK+ platform.
This package contains WebKitGTK+ for GTK+ 3.

Alternatives

Package Version Architecture Repository
webkitgtk4-2.22.4-1.fc27.i686.rpm 2.22.4 i686 Fedora Updates Testing
webkitgtk4-2.22.4-1.fc27.x86_64.rpm 2.22.4 x86_64 Fedora Updates Testing
webkitgtk4-2.22.2-2.fc27.x86_64.rpm 2.22.2 x86_64 Fedora Updates
webkitgtk4-2.22.2-2.fc27.i686.rpm 2.22.2 i686 Fedora Updates
webkitgtk4-2.22.2-2.fc27.i686.rpm 2.22.2 i686 Fedora Updates
webkitgtk4-2.18.0-2.fc27.x86_64.rpm 2.18.0 x86_64 Fedora
webkitgtk4-2.18.0-2.fc27.i686.rpm 2.18.0 i686 Fedora
webkitgtk4-2.18.0-2.fc27.i686.rpm 2.18.0 i686 Fedora
webkitgtk4 - - -

Requires

Name Value
/sbin/ldconfig -
geoclue2 -
ld linux.so.2
ld linux.so.2(GLIBC_2.3)
libEGL.so.1 -
libGL.so.1 -
libX11.so.6 -
libXcomposite.so.1 -
libXdamage.so.1 -
libXrender.so.1 -
libXt.so.6 -
libatk 1.0.so.0
libc.so.6(GLIBC_2.11) -
libcairo gobject.so.2
libcairo.so.2 -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libenchant.so.1 -
libfontconfig.so.1 -
libfreetype.so.6 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.4) -
libgcc_s.so.1(GCC_4.0.0) -
libgcc_s.so.1(GCC_7.0.0) -
libgcc_s.so.1(GLIBC_2.0) -
libgcrypt.so.20 -
libgcrypt.so.20(GCRYPT_1.6) -
libgdk 3.so.0
libgdk_pixbuf 2.0.so.0
libgio 2.0.so.0
libglib 2.0.so.0
libgmodule 2.0.so.0
libgobject 2.0.so.0
libgstapp 1.0.so.0
libgstaudio 1.0.so.0
libgstbase 1.0.so.0
libgstfft 1.0.so.0
libgstgl 1.0.so.0
libgstpbutils 1.0.so.0
libgstreamer 1.0.so.0
libgsttag 1.0.so.0
libgstvideo 1.0.so.0
libgtk 3.so.0
libharfbuzz icu.so.0
libharfbuzz.so.0 -
libhyphen.so.0 -
libicudata.so.57 -
libicui18n.so.57 -
libicuuc.so.57 -
libjavascriptcoregtk 4.0.so.18
libjpeg.so.62 -
libjpeg.so.62(LIBJPEG_6.2) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libnotify.so.4 -
libpango 1.0.so.0
libpangocairo 1.0.so.0
libpng16.so.16 -
libpng16.so.16(PNG16_0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.12) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.2.3) -
libpthread.so.0(GLIBC_2.3.2) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -
libsecret 1.so.0
libsoup 2.4.so.1
libsqlite3.so.0 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.14) -
libstdc++.so.6(GLIBCXX_3.4.18) -
libstdc++.so.6(GLIBCXX_3.4.19) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.22) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libtasn1.so.6 -
libtasn1.so.6(LIBTASN1_0_3) -
libwayland client.so.0
libwayland egl.so.1
libwayland server.so.0
libwebp.so.7 -
libwebpdemux.so.2 -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.6.0) -
libxml2.so.2(LIBXML2_2.6.6) -
libxslt.so.1 -
libxslt.so.1(LIBXML2_1.0.11) -
libxslt.so.1(LIBXML2_1.0.22) -
libxslt.so.1(LIBXML2_1.0.24) -
libxslt.so.1(LIBXML2_1.1.9) -
libz.so.1 -
libz.so.1(ZLIB_1.2.0) -
rtld(GNU_HASH) -
webkitgtk4-jsc(x86-32) = 2.22.4-1.fc27

Provides

Name Value
bundled(angle) -
bundled(brotli) -
bundled(woff2) -
libwebkit2gtk = 2.22.4-1.fc27
libwebkit2gtk 4.0.so.37
webkitgtk4 = 2.22.4-1.fc27
webkitgtk4(x86-32) = 2.22.4-1.fc27

Obsoletes

Name Value
libwebkit2gtk < 2.5.0
webkitgtk4 < 2.12.0-3

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package webkitgtk4-2.22.4-1.fc27.i686.rpm
Source Package webkitgtk4-2.22.4-1.fc27.src.rpm

Install Howto

Install webkitgtk4 rpm package:

# dnf --enablerepo=updates-testing install webkitgtk4

Files

Path
/usr/bin/WebKitWebDriver
/usr/lib/libwebkit2gtk-4.0.so.37
/usr/lib/libwebkit2gtk-4.0.so.37.33.5
/usr/lib/.build-id/
/usr/lib/.build-id/21/0bc756e86b5e0d91cd79dddd1e451e30756ff2
/usr/lib/.build-id/2d/4511288c4a9ddad43512a870a07e6df78d19c9
/usr/lib/.build-id/3a/974bfdf69bcced944c74fae33f47987f93e3e3
/usr/lib/.build-id/57/580e5cf903853b306b8a3eab7ce465df8201b2
/usr/lib/.build-id/6d/8fef1acdfac5fe2a32ef389034ecf4d6e8dee0
/usr/lib/.build-id/6d/af9a5dc3389f556bdd046baec8c1ab6d9f5a92
/usr/lib/.build-id/73/9edb8279e1eabf6cee96adef06401328a53a9e
/usr/lib/.build-id/88/6b1e3659f9547d94e4ef008093545acf38f94d
/usr/lib/.build-id/8f/e969d7244b2c30cef4e71aa318cf18231ebad4
/usr/lib/.build-id/dd/e62d44f1fa6e128a485f85e06aaaa7cc80b829
/usr/lib/girepository-1.0/WebKit2-4.0.typelib
/usr/lib/girepository-1.0/WebKit2WebExtension-4.0.typelib
/usr/lib/webkit2gtk-4.0/
/usr/lib/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
/usr/libexec/webkit2gtk-4.0/MiniBrowser
/usr/libexec/webkit2gtk-4.0/WebKitNetworkProcess
/usr/libexec/webkit2gtk-4.0/WebKitPluginProcess
/usr/libexec/webkit2gtk-4.0/WebKitStorageProcess
/usr/libexec/webkit2gtk-4.0/WebKitWebProcess
/usr/libexec/webkit2gtk-4.0/jsc
/usr/share/licenses/webkitgtk4/Source.ThirdParty.ANGLE.LICENSE
/usr/share/licenses/webkitgtk4/Source.ThirdParty.ANGLE.src.common.third_party.smhasher.LICENSE
/usr/share/licenses/webkitgtk4/Source.ThirdParty.ANGLE.src.third_party.compiler.LICENSE
/usr/share/licenses/webkitgtk4/Source.ThirdParty.ANGLE.src.third_party.libXNVCtrl.LICENSE
/usr/share/licenses/webkitgtk4/Source.ThirdParty.brotli.LICENSE
/usr/share/licenses/webkitgtk4/Source.ThirdParty.woff2.LICENSE
/usr/share/licenses/webkitgtk4/Source.WTF.icu.LICENSE
/usr/share/licenses/webkitgtk4/Source.WTF.wtf.dtoa.COPYING
/usr/share/licenses/webkitgtk4/Source.WTF.wtf.dtoa.LICENSE
/usr/share/licenses/webkitgtk4/Source.WebCore.LICENSE-APPLE
/usr/share/licenses/webkitgtk4/Source.WebCore.LICENSE-LGPL-2
/usr/share/licenses/webkitgtk4/Source.WebCore.LICENSE-LGPL-2.1
/usr/share/licenses/webkitgtk4/Source.WebCore.icu.LICENSE
/usr/share/licenses/webkitgtk4/Source.WebInspectorUI.UserInterface.External.CodeMirror.LICENSE
/usr/share/licenses/webkitgtk4/Source.WebInspectorUI.UserInterface.External.ESLint.LICENSE
/usr/share/licenses/webkitgtk4/Source.WebInspectorUI.UserInterface.External.Esprima.LICENSE
/usr/share/licenses/webkitgtk4/Source.WebInspectorUI.UserInterface.External.three.js.LICENSE
/usr/share/locale/ar/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/as/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/bg/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/ca/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/cs/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/de/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/el/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/en_CA/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/en_GB/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/eo/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/es/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/et/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/eu/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/fi/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/fr/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/gl/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/gu/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/he/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/hi/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/hu/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/id/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/it/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/ja/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/kn/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/ko/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/lt/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/lv/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/ml/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/mr/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/nb/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/nl/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/or/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/pa/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/pl/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/pt/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/pt_BR/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/ro/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/ru/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/sl/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/sr/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/sr@latin/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/sv/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/ta/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/te/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/tr/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/uk/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/vi/LC_MESSAGES/WebKit2GTK-4.0.mo
/usr/share/locale/zh_CN/LC_MESSAGES/WebKit2GTK-4.0.mo

Changelog

2018-11-22 - Tomáš Popela <tpopela@redhat.com> - 2.22.4-1
- Update to 2.22.4
2018-10-29 - Tomas Popela <tpopela@redhat.com> - 2.22.3-1
- Update to 2.22.3
2018-10-19 - Tomas Popela <tpopela@redhat.com> - 2.22.2-2
- Fix WebProcess crash while printing
- Resolves: rhbz#1639754
2018-09-23 - Tomas Popela <tpopela@redhat.com> - 2.22.2-1
- Update to 2.22.2
2018-09-20 - Tomas Popela <tpopela@redhat.com> - 2.22.1-1
- Update to 2.22.1
2018-09-03 - Tomas Popela <tpopela@redhat.com> - 2.22.0-1
- Update to 2.22.0
2018-08-14 - Tomas Popela <tpopela@redhat.com> - 2.20.5-1
- Update to 2.20.5
2018-08-06 - Tomas Popela <tpopela@redhat.com> - 2.20.4-1
- Update to 2.20.4
2018-06-11 - Tomas Popela <tpopela@redhat.com> - 2.20.3-1
- Update to 2.20.3
2018-05-09 - Tomas Popela <tpopela@redhat.com> - 2.20.2-1
- Update to 2.20.2

See Also

Package Description
webkitgtk4-devel-2.22.4-1.fc27.i686.rpm Development files for webkitgtk4
webkitgtk4-doc-2.22.4-1.fc27.noarch.rpm Documentation files for webkitgtk4
webkitgtk4-jsc-2.22.4-1.fc27.i686.rpm JavaScript engine from webkitgtk4
webkitgtk4-jsc-devel-2.22.4-1.fc27.i686.rpm Development files for JavaScript engine from webkitgtk4
webkitgtk4-plugin-process-gtk2-2.22.4-1.fc27.i686.rpm GTK+ 2 based NPAPI plugins support for webkitgtk4
weechat-2.3-1.fc27.i686.rpm Portable, fast, light and extensible IRC client
weechat-devel-2.3-1.fc27.i686.rpm Development files for weechat
xaos-3.6-6.fc27.i686.rpm A fast, portable real-time interactive fractal zoomer
xerces-c27-2.7.0-28.fc27.i686.rpm Validating XML Parser
xerces-c27-devel-2.7.0-28.fc27.i686.rpm Header files, libraries and development documentation for xerces-c27
xerces-c27-doc-2.7.0-28.fc27.i686.rpm Documentation for Xerces-C++ validating XML parser
xrdp-0.9.8-2.fc27.i686.rpm Open source remote desktop protocol (RDP) server
xrdp-devel-0.9.8-2.fc27.i686.rpm Headers and pkg-config files needed to compile xrdp backends
xrdp-selinux-0.9.8-2.fc27.i686.rpm SELinux policy module required tu run xrdp
xstatic-angular-uuid-common-0.0.4.0-2.fc27.noarch.rpm Angular-UUID (XStatic packaging standard)
Advertisement
Advertisement