anaconda-gui-27.20.4-6.fc27.x86_64.rpm


Advertisement

Description

anaconda-gui - Graphical user interface for the Anaconda installer

Property Value
Distribution Fedora 27
Repository Fedora Updates x86_64
Package filename anaconda-gui-27.20.4-6.fc27.x86_64.rpm
Package name anaconda-gui
Package version 27.20.4
Package release 6.fc27
Package architecture x86_64
Package type rpm
Homepage -
License -
Maintainer -
Download size 438.62 KB
Installed size 1.34 MB
This package contains graphical user interface for the Anaconda installer.

Alternatives

Package Version Architecture Repository
anaconda-gui-27.20.4-6.fc27.i686.rpm 27.20.4 i686 Fedora Updates
anaconda-gui-27.20.4-4.fc27.x86_64.rpm 27.20.4 x86_64 Fedora
anaconda-gui-27.20.4-4.fc27.i686.rpm 27.20.4 i686 Fedora
anaconda-gui - - -

Requires

Name Value
NetworkManager-wifi -
adwaita-icon-theme -
anaconda-core = 27.20.4-6.fc27
anaconda-user-help >= 22.1-1
anaconda-widgets = 27.20.4-6.fc27
blivet-gui-runtime >= 2.1.5-2
keybinder3 -
libgnomekbd -
libtimezonemap >= 0.4.1-2
libxklavier >= 5.4
nm-connection-editor -
python(abi) = 3.6
python3-meh-gui >= 0.23-1
system-logos -
tigervnc-server-minimal -
yelp -
zenity -

Provides

Name Value
anaconda-gui = 27.20.4-6.fc27
anaconda-gui(x86-64) = 27.20.4-6.fc27

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package anaconda-gui-27.20.4-6.fc27.x86_64.rpm
Source Package anaconda-27.20.4-6.fc27.src.rpm

Install Howto

Install anaconda-gui rpm package:

# dnf install anaconda-gui

Files

Path
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__init__.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/helpers.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/utils.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/xkl_wrapper.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__pycache__/__init__.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__pycache__/helpers.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__pycache__/helpers.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__pycache__/utils.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__pycache__/utils.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__pycache__/xkl_wrapper.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__pycache__/xkl_wrapper.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__init__.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/progress.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/summary.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__pycache__/__init__.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__pycache__/progress.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__pycache__/progress.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__pycache__/summary.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__pycache__/summary.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__init__.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advanced_storage.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/blivet_gui.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/custom_storage.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/datetime_spoke.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/installation_source.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/keyboard.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/language_support.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/network.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/root_password.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/software_selection.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/storage.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/user.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/welcome.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/__init__.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/advanced_storage.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/advanced_storage.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/blivet_gui.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/blivet_gui.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/custom_storage.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/custom_storage.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/datetime_spoke.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/datetime_spoke.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/installation_source.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/installation_source.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/keyboard.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/keyboard.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/language_support.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/language_support.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/network.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/network.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/root_password.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/root_password.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/software_selection.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/software_selection.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/storage.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/storage.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/user.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/user.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/welcome.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__pycache__/welcome.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/__init__.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/dasd.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/fcoe.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/iscsi.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/zfcp.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/__pycache__/__init__.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/__pycache__/dasd.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/__pycache__/dasd.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/__pycache__/fcoe.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/__pycache__/fcoe.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/__pycache__/iscsi.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/__pycache__/iscsi.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/__pycache__/zfcp.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/advstorage/__pycache__/zfcp.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__init__.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/custom_storage_helpers.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/dasdfmt.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/detailederror.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/entropy_dialog.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/lang_locale_handler.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/passphrase.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/refresh.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/summary.py
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/__init__.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/accordion.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/accordion.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/cart.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/cart.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/custom_storage_helpers.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/custom_storage_helpers.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/dasdfmt.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/dasdfmt.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/detailederror.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/detailederror.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/entropy_dialog.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/entropy_dialog.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/lang_locale_handler.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/lang_locale_handler.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/passphrase.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/passphrase.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/refresh.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/refresh.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/resize.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/resize.cpython-36.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/summary.cpython-36.opt-1.pyc
/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/lib/__pycache__/summary.cpython-36.pyc

Changelog

2018-01-11 - Martin Kolman <mkolman@redhat.com> - 27.20.4-6
- kickstart: use F27_Firewall, not F28_Firewall (dusty)
2018-01-08 - Martin Kolman <mkolman@redhat.com> - 27.20.4-5
- kickstart: support firewall --use-system-defaults (#1526450) (dusty)
- Set correct pykickstart version (jkonecny)
2017-11-02 - Martin Kolman <mkolman@redhat.com> - 27.20.4-4
- Really install all the right packages on Mac UEFI installs (adamw)
2017-10-30 - Martin Kolman <mkolman@redhat.com> - 27.20.4-3
- Add logging to TUI software selection spoke (#1505090) (jkonecny)
- Fix changing source don't erase old environment TUI (#1505090) (jkonecny)
- Add modular server repo to the base repositories (#1506894) (jkonecny)
2017-10-12 - Martin Kolman <mkolman@redhat.com> - 27.20.4-2
- network: create default ifcfg also for missing default NM connection (#1478141) (rvykydal)
- Mac EFI installs need grub2-tools (#1503496) (adamw)
2017-10-12 - Martin Kolman <mkolman@redhat.com> - 27.20.4-1
- Fix a translation check error (mkolman)
2017-10-12 - Martin Kolman <mkolman@redhat.com> - 27.20.3-1
- Mark the mount point assignment in TUI as experimental (vpodzime)
- Reset storage on change in text mode (vpodzime)
- Only allow the supported file systems in text mode (vpodzime)
- Textual configuration of mount points (vpodzime)
- Add support for the new 'mount' kickstart command (vpodzime)
- Fix dnf exception repository not set (#1495211) (jkonecny)
- Add logging of complete spokes in GUI. (rvykydal)
- Do not execute storage when the spoke is left with no selected disk
(#1496327) (rvykydal)
- Add checks for group names (#1497676) (vponcova)
- Add new checks for user names (#1491006) (vponcova)
2017-09-29 - Martin Kolman <mkolman@redhat.com> - 27.20.2-1
- Use name instead of index in TUI env selection (#1495204) (jkonecny)
- Fix missing container in TUI source spoke (#1494801) (jkonecny)
- Add MOCK_EXTRA_ARGS to Makefile (jkonecny)
- tui source spoke: initialize nfs values when switching to nfs (rvykydal)
- Deselect encryption when switching to blivet-gui partitioning (vtrefny)
- Fix missing id to name environment transition (#1491119) (jkonecny)
- Fix test for unset TUI software environment (#1491119) (jkonecny)
- Rename processingDone to processing_done variable (jkonecny)
- network: add support for kickstart --bindto=mac for virtual devices
(#1328576) (rvykydal)
- network: support mac bound network settings as first class (#1328576)
(rvykydal)
- network: add support for kickstart --bindto=mac for wired devices (#1328576)
(rvykydal)
- Don't setup the hub twice (#1491333) (vponcova)
- rpmostreepayload: Substitute ${basearch} in ostreesetup ref (walters)
- Bump Simpleline version (jkonecny)
- Perform repo checks only when there are checks available. (rvykydal)
- Add support for repo --metalink (GUI) (#1464843) (rvykydal)
- Add support for repo --metalink (kickstart, tui) (#1464843) (rvykydal)
- Make EFIGRUB._efi_binary a property, not a method (awilliam)
- Better storing logs from build and tests (jkonecny)
- Provide a default install class. (vponcova)
- Do not use hidden install classes. (vponcova)
- Make geolocation with kickstart possible (#1358331) (mkolman)
- Run python-meh as modal in TUI (jkonecny)
- Use GLib event loop in the simpleline (jkonecny)
- TUI progress reporting is handled by show_all (jkonecny)
- Fix catch TUI not main thread exceptions (jkonecny)
- Add efi_dir to the BaseInstallClass (#1412391) (vponcova)
- Document Anaconda branching workflow (mkolman)
- Use constants for version number bumps and additions (mkolman)
- Fix closest mirror now needs network (jkonecny)
- Fix restart payload thread in Network spoke GUI (#1478970) (jkonecny)
- Network spoke freeze when testing availability (#1478970) (jkonecny)
- Add support for adding version numbers to makebumpver (mkolman)
- Add support for major version bump to makebumpver (mkolman)
- Fix proxy settings badly used when testing repos (#1478970) (jkonecny)
- Add inst.notmux option (dusty)

See Also

Package Description
anaconda-tui-27.20.4-6.fc27.x86_64.rpm Textual user interface for the Anaconda installer
anaconda-widgets-27.20.4-6.fc27.i686.rpm A set of custom GTK+ widgets for use with anaconda
anaconda-widgets-27.20.4-6.fc27.x86_64.rpm A set of custom GTK+ widgets for use with anaconda
anaconda-widgets-devel-27.20.4-6.fc27.i686.rpm Development files for anaconda-widgets
anaconda-widgets-devel-27.20.4-6.fc27.x86_64.rpm Development files for anaconda-widgets
analitza-17.12.3-1.fc27.i686.rpm Library of mathematical features
analitza-17.12.3-1.fc27.x86_64.rpm Library of mathematical features
analitza-devel-17.12.3-1.fc27.i686.rpm Developer files for analitza
analitza-devel-17.12.3-1.fc27.x86_64.rpm Developer files for analitza
android-tools-20170311gite7195be7725a-5.fc27.x86_64.rpm Android platform tools(adb, fastboot)
anki-2.0.52-1.fc27.noarch.rpm Flashcard program for using space repetition learning
ansible-2.6.5-1.fc27.noarch.rpm SSH-based configuration management, deployment, and task execution system
ansible-doc-2.6.5-1.fc27.noarch.rpm Documentation for Ansible
ansible-inventory-grapher-2.4.2-1.fc27.noarch.rpm Creates graphs representing ansible inventory
ansible-lint-3.4.19-1.fc27.noarch.rpm Best practices checker for Ansible
Advertisement
Advertisement