compat-libf2c-34-3.4.6-46.fc27.i686.rpm


Advertisement

Description

compat-libf2c-34 - Fortran 77 compatibility runtime

Property Value
Distribution Fedora 27
Repository Fedora Updates x86_64
Package name compat-libf2c-34
Package version 3.4.6
Package release 46.fc27
Package architecture i686
Package type rpm
Installed size 110.99 KB
Download size 61.10 KB
Official Mirror dl.fedoraproject.org
This package contains Fortran 77 shared library which is needed to run
Fortran 77 dynamically linked programs.

Alternatives

Package Version Architecture Repository
compat-libf2c-34-3.4.6-46.fc27.i686.rpm 3.4.6 i686 Fedora Updates
compat-libf2c-34-3.4.6-46.fc27.x86_64.rpm 3.4.6 x86_64 Fedora Updates
compat-libf2c-34-3.4.6-41.fc26.i686.rpm 3.4.6 i686 Fedora
compat-libf2c-34-3.4.6-41.fc26.i686.rpm 3.4.6 i686 Fedora
compat-libf2c-34-3.4.6-41.fc26.x86_64.rpm 3.4.6 x86_64 Fedora
compat-libf2c-34 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.3) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -

Provides

Name Value
compat-libf2c-34 = 3.4.6-46.fc27
compat-libf2c-34(x86-32) = 3.4.6-46.fc27
libg2c.so.0 -

Obsoletes

Name Value
compat-libf2c-32 -
libf2c -

Download

Type URL
Binary Package compat-libf2c-34-3.4.6-46.fc27.i686.rpm
Source Package compat-gcc-34-3.4.6-46.fc27.src.rpm

Install Howto

Install the compat-libf2c-34 rpm package:

# dnf install compat-libf2c-34

Files

Path
/usr/lib/libg2c.so.0
/usr/lib/libg2c.so.0.0.0
/usr/lib/.build-id/
/usr/lib/.build-id/2f/fcc3cae0a693503b4f09d8b7b9d224b5fd995f

Changelog

2018-02-08 - Jakub Jelinek  <jakub@redhat.com> 3.4.6-46
- don't conflict with libstdc++ [78].x, it is still backwards ABI compatible
- strip -mcet and -fcf-protection from OPT_FLAGS
2018-02-08 - Rafal Luzynski  <digitalfreak@lingonborough.com>
- add a patch to fix build of the info docs (#1423303)
- use ucontext_t instead of struct ucontext (#1423303)
- also strip more combinations of -march=... and -mtune=... from OPT_FLAGS
on s390, s390x, actually there was a problem with -march=zEC12 and -mtune=z13
(#519507, #1423303)
- disable the annotated build feature and strip -fstack-clash-protection
from OPT_FLAGS (#1423303)
2018-02-07 - Fedora Release Engineering <releng@fedoraproject.org> - 3.4.6-45
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2017-08-02 - Fedora Release Engineering <releng@fedoraproject.org> - 3.4.6-44
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
2017-07-26 - Fedora Release Engineering <releng@fedoraproject.org> - 3.4.6-43
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-02-10 - Fedora Release Engineering <releng@fedoraproject.org> - 3.4.6-42
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
2016-08-12 - Peter Robinson <pbrobinson@fedoraproject.org> 3.4.6-41
- excludearch aarch64, unsupported in older gcc
2016-05-05 - Jakub Jelinek  <jakub@redhat.com> 3.4.6-40
- buildrequire data files for localedef
- use -std=gnu89 in the host compiler
2016-03-18 - Jakub Jelinek  <jakub@redhat.com> 3.4.6-39
- don't conflict with libstdc++ 6.x, it is still backwards ABI compatible
2016-02-03 - Fedora Release Engineering <releng@fedoraproject.org> - 3.4.6-38
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

See Also

Package Description
compat-openssl10-1.0.2o-1.fc27.i686.rpm Compatibility version of the OpenSSL library
compat-openssl10-1.0.2o-1.fc27.x86_64.rpm Compatibility version of the OpenSSL library
compat-openssl10-devel-1.0.2o-1.fc27.i686.rpm Files for development of applications which have to use OpenSSL-1.0.2
compat-openssl10-devel-1.0.2o-1.fc27.x86_64.rpm Files for development of applications which have to use OpenSSL-1.0.2
compat-tracker1-1.12.4-1.fc27.i686.rpm Compatibility package with the tracker client-side libraries
compat-tracker1-1.12.4-1.fc27.x86_64.rpm Compatibility package with the tracker client-side libraries
compiler-rt-5.0.2-1.fc27.x86_64.rpm LLVM "compiler-rt" runtime libraries
compose-utils-0.1.23-1.fc27.noarch.rpm Utilities for working with composes
composer-1.6.5-1.fc27.noarch.rpm Dependency Manager for PHP
compsize-1.1-1.fc27.x86_64.rpm Utility for measuring compression ratio of files on btrfs
compton-0.1-0.1.beta3.fc27.x86_64.rpm A compositor for X11
concurrentunit-0.4.3-1.fc27.noarch.rpm Toolkit for testing multi-threaded and asynchronous applications
concurrentunit-javadoc-0.4.3-1.fc27.noarch.rpm Javadoc files for concurrentunit
condor-8.6.11-1.fc27.x86_64.rpm HTCondor: High Throughput Computing
condor-classads-8.6.11-1.fc27.i686.rpm HTCondor's classified advertisement language
Advertisement
Advertisement