php-egulias-email-validator2-2.1.5-1.fc27.noarch.rpm


Advertisement

Description

php-egulias-email-validator2 - A library for validating emails

Property Value
Distribution Fedora 27
Repository Fedora Updates x86_64
Package name php-egulias-email-validator2
Package version 2.1.5
Package release 1.fc27
Package architecture noarch
Package type rpm
Installed size 56.46 KB
Download size 29.46 KB
Official Mirror dl.fedoraproject.org
A library for validating emails.
Autoloader: /usr/share/php/Egulias/EmailValidator2/autoload.php

Alternatives

Package Version Architecture Repository
php-egulias-email-validator2-2.1.7-1.fc27.remi.noarch.rpm 2.1.7 noarch Les RPM de Remi
php-egulias-email-validator2-2.1.7-1.fc27.remi.noarch.rpm 2.1.7 noarch Les RPM de Remi
php-egulias-email-validator2-2.1.6-1.fc27.remi.noarch.rpm 2.1.6 noarch Les RPM de Remi
php-egulias-email-validator2-2.1.6-1.fc27.remi.noarch.rpm 2.1.6 noarch Les RPM de Remi
php-egulias-email-validator2-2.1.5-1.fc27.noarch.rpm 2.1.5 noarch Fedora Updates
php-egulias-email-validator2 - - -

Requires

Name Value
(php-composer(doctrine/lexer) >= 1.0.1 with php-composer(doctrine/lexer) < 2.0)
php(language) >= 5.5
php-composer(fedora/autoloader) -
php-intl -
php-pcre -
php-spl -

Provides

Name Value
php-composer(egulias/email-validator) = 2.1.5
php-egulias-email-validator2 = 2.1.5-1.fc27

Download

Type URL
Binary Package php-egulias-email-validator2-2.1.5-1.fc27.noarch.rpm
Source Package php-egulias-email-validator2-2.1.5-1.fc27.src.rpm

Install Howto

Install php-egulias-email-validator2 rpm package:

# dnf install php-egulias-email-validator2

Files

Path
/usr/share/doc/php-egulias-email-validator2/README.md
/usr/share/doc/php-egulias-email-validator2/composer.json
/usr/share/licenses/php-egulias-email-validator2/LICENSE
/usr/share/php/Egulias/
/usr/share/php/Egulias/EmailValidator2/EmailLexer.php
/usr/share/php/Egulias/EmailValidator2/EmailParser.php
/usr/share/php/Egulias/EmailValidator2/EmailValidator.php
/usr/share/php/Egulias/EmailValidator2/autoload.php
/usr/share/php/Egulias/EmailValidator2/Exception/AtextAfterCFWS.php
/usr/share/php/Egulias/EmailValidator2/Exception/CRLFAtTheEnd.php
/usr/share/php/Egulias/EmailValidator2/Exception/CRLFX2.php
/usr/share/php/Egulias/EmailValidator2/Exception/CRNoLF.php
/usr/share/php/Egulias/EmailValidator2/Exception/CharNotAllowed.php
/usr/share/php/Egulias/EmailValidator2/Exception/CommaInDomain.php
/usr/share/php/Egulias/EmailValidator2/Exception/ConsecutiveAt.php
/usr/share/php/Egulias/EmailValidator2/Exception/ConsecutiveDot.php
/usr/share/php/Egulias/EmailValidator2/Exception/DomainHyphened.php
/usr/share/php/Egulias/EmailValidator2/Exception/DotAtEnd.php
/usr/share/php/Egulias/EmailValidator2/Exception/DotAtStart.php
/usr/share/php/Egulias/EmailValidator2/Exception/ExpectingAT.php
/usr/share/php/Egulias/EmailValidator2/Exception/ExpectingATEXT.php
/usr/share/php/Egulias/EmailValidator2/Exception/ExpectingCTEXT.php
/usr/share/php/Egulias/EmailValidator2/Exception/ExpectingDTEXT.php
/usr/share/php/Egulias/EmailValidator2/Exception/ExpectingDomainLiteralClose.php
/usr/share/php/Egulias/EmailValidator2/Exception/ExpectingQPair.php
/usr/share/php/Egulias/EmailValidator2/Exception/InvalidEmail.php
/usr/share/php/Egulias/EmailValidator2/Exception/NoDNSRecord.php
/usr/share/php/Egulias/EmailValidator2/Exception/NoDomainPart.php
/usr/share/php/Egulias/EmailValidator2/Exception/NoLocalPart.php
/usr/share/php/Egulias/EmailValidator2/Exception/UnclosedComment.php
/usr/share/php/Egulias/EmailValidator2/Exception/UnclosedQuotedString.php
/usr/share/php/Egulias/EmailValidator2/Exception/UnopenedComment.php
/usr/share/php/Egulias/EmailValidator2/Parser/DomainPart.php
/usr/share/php/Egulias/EmailValidator2/Parser/LocalPart.php
/usr/share/php/Egulias/EmailValidator2/Parser/Parser.php
/usr/share/php/Egulias/EmailValidator2/Validation/DNSCheckValidation.php
/usr/share/php/Egulias/EmailValidator2/Validation/EmailValidation.php
/usr/share/php/Egulias/EmailValidator2/Validation/MultipleErrors.php
/usr/share/php/Egulias/EmailValidator2/Validation/MultipleValidationWithAnd.php
/usr/share/php/Egulias/EmailValidator2/Validation/NoRFCWarningsValidation.php
/usr/share/php/Egulias/EmailValidator2/Validation/RFCValidation.php
/usr/share/php/Egulias/EmailValidator2/Validation/SpoofCheckValidation.php
/usr/share/php/Egulias/EmailValidator2/Validation/Error/RFCWarnings.php
/usr/share/php/Egulias/EmailValidator2/Validation/Error/SpoofEmail.php
/usr/share/php/Egulias/EmailValidator2/Validation/Exception/EmptyValidationList.php
/usr/share/php/Egulias/EmailValidator2/Warning/AddressLiteral.php
/usr/share/php/Egulias/EmailValidator2/Warning/CFWSNearAt.php
/usr/share/php/Egulias/EmailValidator2/Warning/CFWSWithFWS.php
/usr/share/php/Egulias/EmailValidator2/Warning/Comment.php
/usr/share/php/Egulias/EmailValidator2/Warning/DeprecatedComment.php
/usr/share/php/Egulias/EmailValidator2/Warning/DomainLiteral.php
/usr/share/php/Egulias/EmailValidator2/Warning/DomainTooLong.php
/usr/share/php/Egulias/EmailValidator2/Warning/EmailTooLong.php
/usr/share/php/Egulias/EmailValidator2/Warning/IPV6BadChar.php
/usr/share/php/Egulias/EmailValidator2/Warning/IPV6ColonEnd.php
/usr/share/php/Egulias/EmailValidator2/Warning/IPV6ColonStart.php
/usr/share/php/Egulias/EmailValidator2/Warning/IPV6Deprecated.php
/usr/share/php/Egulias/EmailValidator2/Warning/IPV6DoubleColon.php
/usr/share/php/Egulias/EmailValidator2/Warning/IPV6GroupCount.php
/usr/share/php/Egulias/EmailValidator2/Warning/IPV6MaxGroups.php
/usr/share/php/Egulias/EmailValidator2/Warning/LabelTooLong.php
/usr/share/php/Egulias/EmailValidator2/Warning/LocalTooLong.php
/usr/share/php/Egulias/EmailValidator2/Warning/NoDNSMXRecord.php
/usr/share/php/Egulias/EmailValidator2/Warning/ObsoleteDTEXT.php
/usr/share/php/Egulias/EmailValidator2/Warning/QuotedPart.php
/usr/share/php/Egulias/EmailValidator2/Warning/QuotedString.php
/usr/share/php/Egulias/EmailValidator2/Warning/TLD.php
/usr/share/php/Egulias/EmailValidator2/Warning/Warning.php

Changelog

2018-08-20 - Remi Collet <remi@remirepo.net> - 2.1.5-1
- update to 2.1.5
2018-04-12 - Remi Collet <remi@remirepo.net> - 2.1.4-1
- update to 2.1.4
- use range dependencies
- use phpunit6
2017-11-16 - Remi Collet <remi@remirepo.net> - 2.1.3-1
- Update to 2.1.3
2017-10-04 - Remi Collet <remi@remirepo.net> - 2.1.2-1
- Update to 2.1.2
- rename to php-egulias-email-validator2
- raise dependency on PHP 5.5
2017-05-14 - Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.13-3
- Switch autoloader to php-composer(fedora/autoloader)
- Test with SCLs if available
2016-08-08 - Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.13-1
- Updated to 1.2.13 (RHBZ #1336594)
2016-01-04 - Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.11-1
- Updated to 1.2.10 (RHBZ #1280283)
2015-10-11 - Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.10-1
- Updated to 1.2.10 (RHBZ #1270623)
- Modified autoloader to load dependencies after self-registration
2015-06-27 - Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.9-1
- Updated to 1.2.9 (RHBZ #1215684)
- Added autoloader
2015-01-05 - Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.7-1
- Updated to 1.2.7 (BZ #1178809)

See Also

Package Description
php-embedded-7.1.23-1.fc27.x86_64.rpm PHP library for embedding in applications
php-enchant-7.1.23-1.fc27.x86_64.rpm Enchant spelling extension for PHP applications
php-endroid-qrcode-1.9.3-3.fc27.noarch.rpm Endroid QR Code
php-erusev-parsedown-1.6.4-1.fc27.noarch.rpm Markdown parser in PHP
php-fpm-7.1.23-1.fc27.x86_64.rpm PHP FastCGI Process Manager
php-gd-7.1.23-1.fc27.x86_64.rpm A module for PHP applications for using the gd graphics library
php-gecko-packages-gecko-php-unit3-3.1.1-1.fc27.noarch.rpm Additional PHPUnit asserts and constraints
php-getid3-1.9.16-1.fc27.noarch.rpm The PHP media file parser
php-gmp-7.1.23-1.fc27.x86_64.rpm A module for PHP applications for using the GNU MP library
php-google-apiclient-services-0.60-1.fc27.noarch.rpm Google PHP API Client Services
php-goutte-3.2.2-1.fc27.noarch.rpm A simple PHP web scraper
php-grasmash-expander-1.0.0-1.fc27.noarch.rpm Expands internal property references in PHP arrays file
php-guzzlehttp-guzzle-5.3.2-2.fc27.noarch.rpm PHP HTTP client and webservice framework
php-guzzlehttp-guzzle6-6.3.3-1.fc27.noarch.rpm PHP HTTP client library
php-horde-Horde-Cli-2.3.0-1.fc27.noarch.rpm Horde Command Line Interface API
Advertisement
Advertisement