plv8-2.1.0-5.fc27.x86_64.rpm


Advertisement

Description

plv8 - V8 Engine Javascript Procedural Language add-on for PostgreSQL

Property Value
Distribution Fedora 27
Repository Fedora Updates x86_64
Package name plv8
Package version 2.1.0
Package release 5.fc27
Package architecture x86_64
Package type rpm
Installed size 522.37 KB
Download size 136.00 KB
Official Mirror dl.fedoraproject.org
plv8 is a shared library that provides a PostgreSQL procedural language
powered by V8 JavaScript Engine. With this program you can write in JavaScript
your function that is callable from SQL.

Alternatives

Package Version Architecture Repository
plv8-2.1.0-5.fc27.i686.rpm 2.1.0 i686 Fedora Updates
plv8 - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libv8.so.6()(64bit) -
libv8_libplatform.so.6()(64bit) -
postgresql-server -
rtld(GNU_HASH) -
v8 -

Provides

Name Value
plv8 = 2.1.0-5.fc27
plv8(x86-64) = 2.1.0-5.fc27

Download

Type URL
Binary Package plv8-2.1.0-5.fc27.x86_64.rpm
Source Package plv8-2.1.0-5.fc27.src.rpm

Install Howto

Install the plv8 rpm package:

# dnf install plv8

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/83/cdd4e9cd89bad73f75ed3c65b07fcda4aeaaaa
/usr/lib64/pgsql/plv8.so
/usr/share/doc/plv8/Changes
/usr/share/doc/plv8/README.md
/usr/share/doc/plv8/plv8.md
/usr/share/licenses/plv8/COPYRIGHT
/usr/share/pgsql/extension/plcoffee--2.1.0.sql
/usr/share/pgsql/extension/plcoffee.control
/usr/share/pgsql/extension/plls--2.1.0.sql
/usr/share/pgsql/extension/plls.control
/usr/share/pgsql/extension/plv8--2.1.0.sql
/usr/share/pgsql/extension/plv8.control

Changelog

2017-12-19 - Pavel Raiskup <praiskup@redhat.com> - 2.1.0-5
- review requirement - in-spec docs for patches (rhbz#1036130)
2017-12-19 - Pavel Raiskup <praiskup@redhat.com> - 2.1.0-4
- review fixes - per Robert-André Mauchin notes - better github source url,
drop Group tag, better format of patches (rhbz#1036130)
- ignore test failure on %arm (reported upstream in PR#247)
2017-12-18 - Pavel Raiskup <praiskup@redhat.com> - 2.1.0-3
- enable testsuite
2017-12-16 - Pavel Raiskup <praiskup@redhat.com> - 2.1.0-2
- fixes per pre-review by Robert-André Mauchin (rhbz#1036130)
- require proper postgresql-server version
- hack for missing libv8_libplatform.so in v8-devel (rhbz#1517657)
2017-12-15 - Pavel Raiskup <praiskup@redhat.com> - 2.1.0-1
- rebase to 2.1.0
- cleanup spec, fix {cxx,ld}flags
2015-11-10 - Pavel Kajaba <pkajaba@redhat.com> 1.4.4-1
- Made changes to work under Fedora repos
2014-07-09 - Devrim Gündüz <devrim@gunduz.org> 1.4.2-1
- Update to 1.4.2
2013-12-12 - Devrim Gündüz <devrim@gunduz.org> 1.4.1-1
- Initial spec file, per RH #1036130, after doing modifications
to suit community RPM layout. Original work is by David
Wheeler and Mikko Tiihonen

See Also

Package Description
plymouth-kcm-5.12.6-1.fc27.i686.rpm Plymouth configuration module for systemsettings
plymouth-kcm-5.12.6-1.fc27.x86_64.rpm Plymouth configuration module for systemsettings
plymouth-theme-breeze-5.12.6-1.fc27.x86_64.rpm Breeze theme for Plymouth
pmempool-1.4.2-1.fc27.x86_64.rpm Utilities for Persistent Memory
pngcrush-1.8.13-1.fc27.x86_64.rpm Optimizer for PNG (Portable Network Graphics) files
pngquant-2.11.7-5.fc27.x86_64.rpm PNG quantization tool for reducing image file size
pnmixer-0.7.2-1.fc27.x86_64.rpm Lightweight mixer applet
po-debconf-1.0.20-5.fc27.noarch.rpm Tool for managing templates file translations with gettext
po4a-0.52-2.fc27.noarch.rpm A tool maintaining translations anywhere
pocl-0.15-0.1.20171023git53ef5e8.fc27.i686.rpm Portable Computing Language - an OpenCL implementation
pocl-0.15-0.1.20171023git53ef5e8.fc27.x86_64.rpm Portable Computing Language - an OpenCL implementation
pocl-devel-0.15-0.1.20171023git53ef5e8.fc27.i686.rpm Portable Computing Language development files
pocl-devel-0.15-0.1.20171023git53ef5e8.fc27.x86_64.rpm Portable Computing Language development files
poco-crypto-1.7.8p3-3.fc27.i686.rpm The Crypto POCO component
poco-crypto-1.7.8p3-3.fc27.x86_64.rpm The Crypto POCO component
Advertisement
Advertisement