poppler-devel-0.57.0-10.fc27.x86_64.rpm


Advertisement

Description

poppler-devel - Libraries and headers for poppler

Property Value
Distribution Fedora 27
Repository Fedora Updates x86_64
Package filename poppler-devel-0.57.0-10.fc27.x86_64.rpm
Package name poppler-devel
Package version 0.57.0
Package release 10.fc27
Package architecture x86_64
Package type rpm
Homepage -
License -
Maintainer -
Download size 221.20 KB
Installed size 1.12 MB
You should install the poppler-devel package if you would like to
compile applications based on poppler.

Alternatives

Package Version Architecture Repository
poppler-devel-0.57.0-10.fc27.i686.rpm 0.57.0 i686 Fedora Updates
poppler-devel-0.57.0-10.fc27.i686.rpm 0.57.0 i686 Fedora Updates
poppler-devel-0.57.0-2.fc27.x86_64.rpm 0.57.0 x86_64 Fedora
poppler-devel-0.57.0-2.fc27.i686.rpm 0.57.0 i686 Fedora
poppler-devel-0.57.0-2.fc27.i686.rpm 0.57.0 i686 Fedora
poppler-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libpoppler.so.68()(64bit) -
poppler(x86-64) = 0.57.0-10.fc27

Provides

Name Value
pkgconfig(poppler) = 0.57.0
pkgconfig(poppler-splash) = 0.57.0
poppler-devel = 0.57.0-10.fc27
poppler-devel(x86-64) = 0.57.0-10.fc27

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package poppler-devel-0.57.0-10.fc27.x86_64.rpm
Source Package poppler-0.57.0-10.fc27.src.rpm

Install Howto

Install poppler-devel rpm package:

# dnf install poppler-devel

Files

Path
/usr/include/poppler/Annot.h
/usr/include/poppler/Array.h
/usr/include/poppler/BuiltinFont.h
/usr/include/poppler/BuiltinFontTables.h
/usr/include/poppler/CMap.h
/usr/include/poppler/CachedFile.h
/usr/include/poppler/Catalog.h
/usr/include/poppler/CharCodeToUnicode.h
/usr/include/poppler/CharTypes.h
/usr/include/poppler/CompactFontTables.h
/usr/include/poppler/DateInfo.h
/usr/include/poppler/Decrypt.h
/usr/include/poppler/Dict.h
/usr/include/poppler/Error.h
/usr/include/poppler/ErrorCodes.h
/usr/include/poppler/FileSpec.h
/usr/include/poppler/FontEncodingTables.h
/usr/include/poppler/FontInfo.h
/usr/include/poppler/Form.h
/usr/include/poppler/Function.h
/usr/include/poppler/Gfx.h
/usr/include/poppler/GfxFont.h
/usr/include/poppler/GfxState.h
/usr/include/poppler/GfxState_helpers.h
/usr/include/poppler/GlobalParams.h
/usr/include/poppler/Hints.h
/usr/include/poppler/JArithmeticDecoder.h
/usr/include/poppler/JBIG2Stream.h
/usr/include/poppler/Lexer.h
/usr/include/poppler/Linearization.h
/usr/include/poppler/Link.h
/usr/include/poppler/LocalPDFDocBuilder.h
/usr/include/poppler/MarkedContentOutputDev.h
/usr/include/poppler/Movie.h
/usr/include/poppler/NameToCharCode.h
/usr/include/poppler/NameToUnicodeTable.h
/usr/include/poppler/Object.h
/usr/include/poppler/OptionalContent.h
/usr/include/poppler/Outline.h
/usr/include/poppler/OutputDev.h
/usr/include/poppler/PDFDoc.h
/usr/include/poppler/PDFDocBuilder.h
/usr/include/poppler/PDFDocEncoding.h
/usr/include/poppler/PDFDocFactory.h
/usr/include/poppler/PSOutputDev.h
/usr/include/poppler/PSTokenizer.h
/usr/include/poppler/Page.h
/usr/include/poppler/PageTransition.h
/usr/include/poppler/Parser.h
/usr/include/poppler/PopplerCache.h
/usr/include/poppler/PreScanOutputDev.h
/usr/include/poppler/ProfileData.h
/usr/include/poppler/Rendition.h
/usr/include/poppler/SecurityHandler.h
/usr/include/poppler/SignatureHandler.h
/usr/include/poppler/SignatureInfo.h
/usr/include/poppler/Sound.h
/usr/include/poppler/SplashOutputDev.h
/usr/include/poppler/StdinCachedFile.h
/usr/include/poppler/StdinPDFDocBuilder.h
/usr/include/poppler/Stream-CCITT.h
/usr/include/poppler/Stream.h
/usr/include/poppler/StructElement.h
/usr/include/poppler/StructTreeRoot.h
/usr/include/poppler/TextOutputDev.h
/usr/include/poppler/UTF.h
/usr/include/poppler/UTF8.h
/usr/include/poppler/UnicodeCClassTables.h
/usr/include/poppler/UnicodeCompTables.h
/usr/include/poppler/UnicodeDecompTables.h
/usr/include/poppler/UnicodeMap.h
/usr/include/poppler/UnicodeMapTables.h
/usr/include/poppler/UnicodeTypeTable.h
/usr/include/poppler/ViewerPreferences.h
/usr/include/poppler/XRef.h
/usr/include/poppler/XpdfPluginAPI.h
/usr/include/poppler/poppler-config.h
/usr/include/poppler/fofi/FoFiBase.h
/usr/include/poppler/fofi/FoFiEncodings.h
/usr/include/poppler/fofi/FoFiIdentifier.h
/usr/include/poppler/fofi/FoFiTrueType.h
/usr/include/poppler/fofi/FoFiType1.h
/usr/include/poppler/fofi/FoFiType1C.h
/usr/include/poppler/goo/FixedPoint.h
/usr/include/poppler/goo/GooHash.h
/usr/include/poppler/goo/GooLikely.h
/usr/include/poppler/goo/GooList.h
/usr/include/poppler/goo/GooMutex.h
/usr/include/poppler/goo/GooString.h
/usr/include/poppler/goo/GooTimer.h
/usr/include/poppler/goo/ImgWriter.h
/usr/include/poppler/goo/JpegWriter.h
/usr/include/poppler/goo/NetPBMWriter.h
/usr/include/poppler/goo/PNGWriter.h
/usr/include/poppler/goo/TiffWriter.h
/usr/include/poppler/goo/gfile.h
/usr/include/poppler/goo/gmem.h
/usr/include/poppler/goo/grandom.h
/usr/include/poppler/goo/gstrtod.h
/usr/include/poppler/goo/gtypes.h
/usr/include/poppler/splash/Splash.h
/usr/include/poppler/splash/SplashBitmap.h
/usr/include/poppler/splash/SplashClip.h
/usr/include/poppler/splash/SplashErrorCodes.h
/usr/include/poppler/splash/SplashFTFont.h
/usr/include/poppler/splash/SplashFTFontEngine.h
/usr/include/poppler/splash/SplashFTFontFile.h
/usr/include/poppler/splash/SplashFont.h
/usr/include/poppler/splash/SplashFontEngine.h
/usr/include/poppler/splash/SplashFontFile.h
/usr/include/poppler/splash/SplashFontFileID.h
/usr/include/poppler/splash/SplashGlyphBitmap.h
/usr/include/poppler/splash/SplashMath.h
/usr/include/poppler/splash/SplashPath.h
/usr/include/poppler/splash/SplashPattern.h
/usr/include/poppler/splash/SplashScreen.h
/usr/include/poppler/splash/SplashState.h
/usr/include/poppler/splash/SplashT1Font.h
/usr/include/poppler/splash/SplashT1FontEngine.h
/usr/include/poppler/splash/SplashT1FontFile.h
/usr/include/poppler/splash/SplashTypes.h
/usr/include/poppler/splash/SplashXPath.h
/usr/include/poppler/splash/SplashXPathScanner.h
/usr/lib64/libpoppler.so
/usr/lib64/pkgconfig/poppler-splash.pc
/usr/lib64/pkgconfig/poppler.pc

Changelog

2018-07-26 - Marek Kasik <mkasik@redhat.com> - 0.57.0-10
- Fix crash when Object has negative number (CVE-2018-13988)
- Resolves: #1607461
2018-05-28 - Marek Kasik <mkasik@redhat.com> - 0.57.0-9
- Fix infinite recursion (CVE-2017-18267)
- Resolves: #1578780
2018-01-16 - Caolán McNamara <caolanm@redhat.com> - 0.57.0-8
- Resolves: rhbz#1534706 unable to open some valid pdf files
2018-01-05 - David Tardon <dtardon@redhat.com> - 0.57.0-7
- Resolves: rhbz#1531383 CVE-2017-1000456 Invalid read in TextPool::addWord()
causes crash and can lead to overflow in subsequent calculations
2017-11-09 - David Tardon <dtardon@redhat.com> - 0.57.0-6
- Resolves: rhbz#1510980 CVE-2017-15565
2017-10-11 - David Tardon <dtardon@redhat.com> - 0.57.0-5
- Resolves: rhbz#1500326 CVE-2017-14926 CVE-2017-14927 CVE-2017-14928
2017-10-10 - David Tardon <dtardon@redhat.com> - 0.57.0-4
- Resolves: rhbz#1499906 CVE-2017-14617
2017-10-08 - David Tardon <dtardon@redhat.com> - 0.57.0-3
- Resolves: rhbz#1499168 CVE-2017-14517 CVE-2017-14518 CVE-2017-14519
CVE-2017-14929
2017-09-25 - Caolán McNamara <caolanm@redhat.com> - 0.57.0-2
- Resolves: rhbz#1494583 CVE-2017-14520
2017-08-03 - David Tardon <dtardon@redhat.com> - 0.57.0-1
- new upstream release

See Also

Package Description
poppler-glib-0.57.0-10.fc27.i686.rpm Glib wrapper for poppler
poppler-glib-0.57.0-10.fc27.x86_64.rpm Glib wrapper for poppler
poppler-glib-devel-0.57.0-10.fc27.i686.rpm Development files for glib wrapper
poppler-glib-devel-0.57.0-10.fc27.x86_64.rpm Development files for glib wrapper
poppler-glib-doc-0.57.0-10.fc27.noarch.rpm Documentation for glib wrapper
poppler-qt-0.57.0-10.fc27.i686.rpm Qt4 wrapper for poppler
poppler-qt-0.57.0-10.fc27.x86_64.rpm Qt4 wrapper for poppler
poppler-qt-devel-0.57.0-10.fc27.i686.rpm Development files for Qt4 wrapper
poppler-qt-devel-0.57.0-10.fc27.x86_64.rpm Development files for Qt4 wrapper
poppler-qt5-0.57.0-10.fc27.i686.rpm Qt5 wrapper for poppler
poppler-qt5-0.57.0-10.fc27.x86_64.rpm Qt5 wrapper for poppler
poppler-qt5-devel-0.57.0-10.fc27.i686.rpm Development files for Qt5 wrapper
poppler-qt5-devel-0.57.0-10.fc27.x86_64.rpm Development files for Qt5 wrapper
poppler-utils-0.57.0-10.fc27.x86_64.rpm Command line utilities for converting PDF files
popub-local-0-0.3.20171007git6ffa11c.fc27.x86_64.rpm Publish a service from localhost onto your server - client side
Advertisement
Advertisement