ruby-2.4.5-90.fc27.x86_64.rpm


Advertisement

Description

ruby - An interpreter of object-oriented scripting language

Property Value
Distribution Fedora 27
Repository Fedora Updates x86_64
Package name ruby
Package version 2.4.5
Package release 90.fc27
Package architecture x86_64
Package type rpm
Installed size 72.31 KB
Download size 80.54 KB
Official Mirror dl.fedoraproject.org
Ruby is the interpreted scripting language for quick and easy
object-oriented programming.  It has many features to process text
files and to do system management tasks (as in Perl).  It is simple,
straight-forward, and extensible.

Alternatives

Package Version Architecture Repository
ruby-2.4.5-90.fc27.i686.rpm 2.4.5 i686 Fedora Updates
ruby-2.4.5-90.fc27.i686.rpm 2.4.5 i686 Fedora Updates
ruby-2.4.2-84.fc27.x86_64.rpm 2.4.2 x86_64 Fedora
ruby-2.4.2-84.fc27.i686.rpm 2.4.2 i686 Fedora
ruby-2.4.2-84.fc27.i686.rpm 2.4.2 i686 Fedora
ruby - - -

Requires

Name Value
/usr/bin/ruby -
libc.so.6(GLIBC_2.2.5)(64bit) -
libcrypt.so.1()(64bit) -
libdl.so.2()(64bit) -
libm.so.6()(64bit) -
libpthread.so.0()(64bit) -
libruby.so.2.4()(64bit) -
rtld(GNU_HASH) -
ruby-libs(x86-64) = 2.4.5-90.fc27

Provides

Name Value
ruby = 2.4.5-90.fc27
ruby(runtime_executable) = 2.4.5
ruby(x86-64) = 2.4.5-90.fc27

Download

Type URL
Binary Package ruby-2.4.5-90.fc27.x86_64.rpm
Source Package ruby-2.4.5-90.fc27.src.rpm

Install Howto

Install ruby rpm package:

# dnf install ruby

Files

Path
/usr/bin/erb
/usr/bin/ruby-mri
/usr/lib/.build-id/
/usr/lib/.build-id/12/7d54a3c88d1d883c60c3481f54cbd0e38aaac4
/usr/share/licenses/ruby/BSDL
/usr/share/licenses/ruby/COPYING
/usr/share/licenses/ruby/COPYING.ja
/usr/share/licenses/ruby/GPL
/usr/share/licenses/ruby/LEGAL
/usr/share/man/man1/erb.1.gz
/usr/share/man/man1/ruby.1.gz

Changelog

2018-10-26 - Jun Aruga <jaruga@redhat.com> - 2.4.5-90
- Update to Ruby 2.4.5.
2018-05-10 - Pavel Valena <pvalena@redhat.com> - 2.4.4-89
- Add macros to edit files lists in .gemspec
(gemspec_add_file and gemspec_remove_file).
2018-05-02 - Vít Ondruch <vondruch@redhat.com> - 2.4.4-89
- Make %gemspec_{add,remove}_dep modify .gemspec provided by %setup macro.
2018-04-16 - Pavel Valena <pvalena@redhat.com> - 2.4.4-88
- Update to Ruby 2.4.4.
2018-02-21 - Pavel Valena <pvalena@redhat.com> - 2.4.3-87
- Fix: Multiple vulnerabilities in RubyGems
https://bugzilla.redhat.com/show_bug.cgi?id=1547431
https://www.ruby-lang.org/en/news/2018/02/17/multiple-vulnerabilities-in-rubygems/
2017-12-21 - Pavel Valena <pvalena@redhat.com> - 2.4.3-86
- Update to Ruby 2.4.3.
- Fix: Command injection in lib/resolv.rb:lazy_initialize() (rhbz#1528226)
2017-10-27 - Jun Aruga <jaruga@redhat.com> - 2.4.2-86
- Improve "with" conditional statement as inline.
2017-10-19 - Jun Aruga <jaruga@redhat.com> - 2.4.2-85
- Add macros to remove systemtap, git and cmake dependencies.
2017-09-18 - Pavel Valena <pvalena@redhat.com> - 2.4.2-84
- Update to Ruby 2.4.2.
2017-09-08 - Vít Ondruch <vondruch@redhat.com> - 2.4.1-84
- Drop ruby-devel dependency on rubypick, which is pulled in transtitively.

See Also

Package Description
ruby-SBML-5.16.0-8.fc27.x86_64.rpm Ruby bindings for libSBML
ruby-SEDML-0.4.3-10.fc27.x86_64.rpm Ruby library that fully supports SED-ML for SBML
ruby-devel-2.4.5-90.fc27.i686.rpm A Ruby development environment
ruby-devel-2.4.5-90.fc27.x86_64.rpm A Ruby development environment
ruby-doc-2.4.5-90.fc27.noarch.rpm Documentation for ruby
ruby-irb-2.4.5-90.fc27.noarch.rpm The Interactive Ruby
ruby-libguestfs-1.38.6-1.fc27.x86_64.rpm Ruby bindings for libguestfs
ruby-libs-2.4.5-90.fc27.i686.rpm Libraries necessary to run Ruby
ruby-libs-2.4.5-90.fc27.x86_64.rpm Libraries necessary to run Ruby
ruby-notmuch-0.27-1.fc27.x86_64.rpm Ruby bindings for notmuch
ruby-prelude-4.1.0-2.fc27.x86_64.rpm Ruby bindings for prelude
ruby-solv-0.6.35-1.fc27.x86_64.rpm Ruby bindings for the libsolv library
rubygem-aruba-0.14.3-1.fc27.noarch.rpm CLI Steps for Cucumber, hand-crafted for you in Aruba
rubygem-aruba-doc-0.14.3-1.fc27.noarch.rpm Documentation for rubygem-aruba
rubygem-atk-3.2.1-1.fc27.noarch.rpm Ruby binding of ATK-1.0.x
Advertisement
Advertisement