libpng-1.6.31-1.fc27.x86_64.rpm


Advertisement

Description

libpng - A library of functions for manipulating PNG image format files

Property Value
Distribution Fedora 27
Repository Fedora x86_64
Package filename libpng-1.6.31-1.fc27.x86_64.rpm
Package name libpng
Package version 1.6.31
Package release 1.fc27
Package architecture x86_64
Package type rpm
Homepage -
License -
Maintainer -
Download size 122.87 KB
Installed size 212.58 KB
The libpng package contains a library of functions for creating and
manipulating PNG (Portable Network Graphics) image format files.  PNG
is a bit-mapped graphics format similar to the GIF format.  PNG was
created to replace the GIF format, since GIF uses a patented data
compression algorithm.
Libpng should be installed if you need to manipulate PNG format image
files.

Alternatives

Package Version Architecture Repository
libpng-1.6.31-1.fc27.i686.rpm 1.6.31 i686 Fedora
libpng-1.6.31-1.fc27.i686.rpm 1.6.31 i686 Fedora
libpng - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.14)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libz.so.1()(64bit) -
libz.so.1(ZLIB_1.2.3.4)(64bit) -
libz.so.1(ZLIB_1.2.9)(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
libpng = 1.6.31-1.fc27
libpng(x86-64) = 1.6.31-1.fc27
libpng16.so.16()(64bit) -
libpng16.so.16(PNG16_0)(64bit) -

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package libpng-1.6.31-1.fc27.x86_64.rpm
Source Package libpng-1.6.31-1.fc27.src.rpm

Install Howto

Install libpng rpm package:

# dnf install libpng

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/a8/7537ef3d96f6e8f42d0cc428e9aeba613187fd
/usr/lib64/libpng16.so.16
/usr/lib64/libpng16.so.16.31.0
/usr/share/licenses/libpng/LICENSE
/usr/share/man/man5/png.5.gz

Changelog

2017-08-01 - Nikola Forró <nforro@redhat.com> - 2:1.6.31-1
- New upstream release 1.6.31
2017-07-26 - Fedora Release Engineering <releng@fedoraproject.org> - 2:1.6.29-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-06-06 - Nikola Forró <nforro@redhat.com> - 2:1.6.29-1
- New upstream release 1.6.29
2017-06-06 - Nikola Forró <nforro@redhat.com> - 2:1.6.28-3
- Update source URL (#1458040)
2017-02-10 - Fedora Release Engineering <releng@fedoraproject.org> - 2:1.6.28-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
2017-01-31 - Nikola Forró <nforro@redhat.com> - 2:1.6.28-1
- New upstream release 1.6.28 (#1411176)
2016-12-30 - Kalev Lember <klember@redhat.com> - 2:1.6.27-1
- New upstream release 1.6.27 (#1409159)
2016-10-25 - Nikola Forró <nforro@redhat.com> - 2:1.6.26-1
- New upstream release 1.6.26 (#1387902)
2016-09-05 - Nikola Forró <nforro@redhat.com> - 2:1.6.25-1
- New upstream release 1.6.25 (#1373171)
2016-08-08 - Nikola Forró <nforro@redhat.com> - 2:1.6.24-1
- New upstream release 1.6.24 (#1365115)

See Also

Package Description
libpng-devel-1.6.31-1.fc27.i686.rpm Development tools for programs to manipulate PNG image format files
libpng-devel-1.6.31-1.fc27.x86_64.rpm Development tools for programs to manipulate PNG image format files
libpng-static-1.6.31-1.fc27.i686.rpm Static PNG image format file library
libpng-static-1.6.31-1.fc27.x86_64.rpm Static PNG image format file library
libpng-tools-1.6.31-1.fc27.x86_64.rpm Tools for PNG image format file library
libpng10-1.0.69-1.fc27.i686.rpm Old version of libpng, needed to run old binaries
libpng10-1.0.69-1.fc27.x86_64.rpm Old version of libpng, needed to run old binaries
libpng10-devel-1.0.69-1.fc27.i686.rpm Development tools for version 1.0 of libpng
libpng10-devel-1.0.69-1.fc27.x86_64.rpm Development tools for version 1.0 of libpng
libpng12-1.2.57-4.fc27.i686.rpm Old version of libpng, needed to run old binaries
libpng12-1.2.57-4.fc27.x86_64.rpm Old version of libpng, needed to run old binaries
libpng12-devel-1.2.57-4.fc27.i686.rpm Development files for libpng 1.2
libpng12-devel-1.2.57-4.fc27.x86_64.rpm Development files for libpng 1.2
libpng15-1.5.28-5.fc27.i686.rpm Old version of libpng, needed to run old binaries
libpng15-1.5.28-5.fc27.x86_64.rpm Old version of libpng, needed to run old binaries
Advertisement
Advertisement