php-doctrine-annotations-1.6.0-1.fc27.remi.noarch.rpm


Advertisement

Description

php-doctrine-annotations - PHP docblock annotations parser library

Property Value
Distribution Fedora 27
Repository Les RPM de Remi i386
Package name php-doctrine-annotations
Package version 1.6.0
Package release 1.fc27.remi
Package architecture noarch
Package type rpm
Installed size 127.55 KB
Download size 33.59 KB
Official Mirror rpms.remirepo.net
PHP docblock annotations parser library (extracted from Doctrine Common).
Autoloader: /usr/share/php/Doctrine/Common/Annotations/autoload.php

Alternatives

Package Version Architecture Repository
php-doctrine-annotations-1.6.0-1.fc27.remi.noarch.rpm 1.6.0 noarch Les RPM de Remi
php-doctrine-annotations-1.2.7-5.fc27.noarch.rpm 1.2.7 noarch Fedora
php-doctrine-annotations-1.2.7-5.fc27.noarch.rpm 1.2.7 noarch Fedora
php-doctrine-annotations - - -

Requires

Name Value
(php-composer(doctrine/lexer) >= 1.0.1 with php-composer(doctrine/lexer) < 2.0)
php(language) >= 7.1
php-composer(fedora/autoloader) -
php-ctype -
php-date -
php-json -
php-pcre -
php-reflection -
php-spl -
php-tokenizer -

Provides

Name Value
php-composer(doctrine/annotations) = 1.6.0
php-doctrine-annotations = 1.6.0-1.fc27.remi

Conflicts

Name Value
php-pear(pear.doctrine-project.org/DoctrineCommon) < 2.4

Download

Type URL
Binary Package php-doctrine-annotations-1.6.0-1.fc27.remi.noarch.rpm
Source Package php-doctrine-annotations-1.6.0-1.fc27.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/fedora/27/remi/i386/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-doctrine-annotations rpm package:
    # dnf --enablerepo=remi install php-doctrine-annotations

Files

Path
/usr/share/doc/php-doctrine-annotations/CHANGELOG.md
/usr/share/doc/php-doctrine-annotations/README.md
/usr/share/doc/php-doctrine-annotations/composer.json
/usr/share/licenses/php-doctrine-annotations/LICENSE
/usr/share/php/Doctrine/Common/Annotations/Annotation.php
/usr/share/php/Doctrine/Common/Annotations/AnnotationException.php
/usr/share/php/Doctrine/Common/Annotations/AnnotationReader.php
/usr/share/php/Doctrine/Common/Annotations/AnnotationRegistry.php
/usr/share/php/Doctrine/Common/Annotations/CachedReader.php
/usr/share/php/Doctrine/Common/Annotations/DocLexer.php
/usr/share/php/Doctrine/Common/Annotations/DocParser.php
/usr/share/php/Doctrine/Common/Annotations/FileCacheReader.php
/usr/share/php/Doctrine/Common/Annotations/IndexedReader.php
/usr/share/php/Doctrine/Common/Annotations/PhpParser.php
/usr/share/php/Doctrine/Common/Annotations/Reader.php
/usr/share/php/Doctrine/Common/Annotations/SimpleAnnotationReader.php
/usr/share/php/Doctrine/Common/Annotations/TokenParser.php
/usr/share/php/Doctrine/Common/Annotations/autoload.php
/usr/share/php/Doctrine/Common/Annotations/Annotation/Attribute.php
/usr/share/php/Doctrine/Common/Annotations/Annotation/Attributes.php
/usr/share/php/Doctrine/Common/Annotations/Annotation/Enum.php
/usr/share/php/Doctrine/Common/Annotations/Annotation/IgnoreAnnotation.php
/usr/share/php/Doctrine/Common/Annotations/Annotation/Required.php
/usr/share/php/Doctrine/Common/Annotations/Annotation/Target.php

Changelog

2018-10-17 - Remi Collet <remi@remirepo.net> - 1.6.0-1
- update to 1.6.0
- raise dependency on PHP 7.1
- use phpunit6
- use range dependencies
2017-05-12 - Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.7-4
- Switch autoloader to php-composer(fedora/autoloader)
- Add max versions to build dependencies
- Test with SCLs if available
2015-09-05 - Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.7-1
- Updated to 1.2.7 (RHBZ #1258669 / CVE-2015-5723)
- Updated autoloader to load dependencies after self registration

See Also

Package Description
php-doctrine-cache-1.7.1-1.fc27.remi.noarch.rpm Doctrine Cache
php-doctrine-cache-1.8.0-1.fc27.remi.noarch.rpm Doctrine Cache
php-doctrine-common-2.10.0-1.fc27.remi.noarch.rpm Common library for Doctrine projects
php-doctrine-common-2.9.0-1.fc27.remi.noarch.rpm Common library for Doctrine projects
php-doctrine-datafixtures-1.3.1-1.fc27.remi.noarch.rpm Data Fixtures for all Doctrine Object Managers
php-doctrine-dbal-2.9.0-1.fc27.remi.noarch.rpm Doctrine Database Abstraction Layer (DBAL)
php-doctrine-dbal-2.9.1-1.fc27.remi.noarch.rpm Doctrine Database Abstraction Layer (DBAL)
php-doctrine-doctrine-bundle-1.6.13-1.fc27.remi.noarch.rpm Symfony Bundle for Doctrine
php-doctrine-doctrine-bundle-1.9.1-1.fc27.remi.noarch.rpm Symfony Bundle for Doctrine
php-doctrine-doctrine-cache-bundle-1.3.4-1.fc27.remi.noarch.rpm Symfony2 Bundle for Doctrine Cache
php-doctrine-doctrine-cache-bundle-1.3.5-1.fc27.remi.noarch.rpm Symfony2 Bundle for Doctrine Cache
php-doctrine-event-manager-1.0.0-1.fc27.remi.noarch.rpm Simple PHP event system
php-doctrine-event-manager-1.0.0-2.fc27.remi.noarch.rpm Simple PHP event system
php-doctrine-inflector-1.3.0-1.fc27.remi.noarch.rpm Common string manipulations with regard to casing and singular/plural rules
php-doctrine-instantiator-1.1.0-3.fc27.remi.noarch.rpm Instantiate objects in PHP without invoking their constructors
Advertisement
Advertisement