php-symfony-class-loader-2.8.46-2.fc27.remi.noarch.rpm


Advertisement

Description

php-symfony-class-loader - Symfony ClassLoader Component

Property Value
Distribution Fedora 27
Repository Les RPM de Remi i386
Package name php-symfony-class-loader
Package version 2.8.46
Package release 2.fc27.remi
Package architecture noarch
Package type rpm
Installed size 60.03 KB
Download size 31.57 KB
Official Mirror rpms.remirepo.net
The ClassLoader Component loads your project classes automatically if they
follow some standard PHP conventions.
Whenever you use an undefined class, PHP uses the autoloading mechanism
to delegate the loading of a file defining the class. Symfony provides
a "universal" autoloader, which is able to load classes from files that
implement one of the following conventions:
* The technical interoperability standards [1] for PHP 5.3 namespaces
and class names
* The PEAR naming convention [2] for classes
If your classes and the third-party libraries you use for your project follow
these standards, the Symfony autoloader is the only autoloader you will ever
need.
Optional:
* APC (php-pecl-apcu)
* XCache (php-xcache)
[1] http://symfony.com/PSR0
[2] http://pear.php.net/manual/en/standards.php

Alternatives

Package Version Architecture Repository
php-symfony-class-loader-2.8.47-1.fc27.remi.noarch.rpm 2.8.47 noarch Les RPM de Remi
php-symfony-class-loader-2.8.47-1.fc27.remi.noarch.rpm 2.8.47 noarch Les RPM de Remi
php-symfony-class-loader-2.8.46-2.fc27.remi.noarch.rpm 2.8.46 noarch Les RPM de Remi
php-symfony-class-loader-2.8.46-1.fc27.noarch.rpm 2.8.46 noarch Fedora Updates
php-symfony-class-loader-2.8.46-1.fc27.noarch.rpm 2.8.46 noarch Fedora Updates
php-symfony-class-loader-2.8.28-1.fc27.noarch.rpm 2.8.28 noarch Fedora
php-symfony-class-loader-2.8.28-1.fc27.noarch.rpm 2.8.28 noarch Fedora
php-symfony-class-loader - - -

Requires

Name Value
php-hash -
php-pcre -
php-reflection -
php-spl -
php-symfony-common = 2.8.46-2.fc27.remi
php-tokenizer -

Provides

Name Value
php-composer(symfony/class-loader) = 2.8.46
php-pear(pear.symfony.com/ClassLoader) = 2.8.46
php-symfony-class-loader = 2.8.46-2.fc27.remi
php-symfony-classloader = 2.8.46
php-symfony2-ClassLoader = 2.8.46

Obsoletes

Name Value
php-symfony-classloader < 2.8.46
php-symfony2-ClassLoader < 2.8.46

Download

Type URL
Binary Package php-symfony-class-loader-2.8.46-2.fc27.remi.noarch.rpm
Source Package php-symfony-2.8.46-2.fc27.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/fedora/27/remi/i386/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-symfony-class-loader rpm package:
    # dnf --enablerepo=remi install php-symfony-class-loader

Files

Path
/usr/share/doc/php-symfony-class-loader/CHANGELOG.md
/usr/share/doc/php-symfony-class-loader/README.md
/usr/share/doc/php-symfony-class-loader/composer.json
/usr/share/licenses/php-symfony-class-loader/LICENSE
/usr/share/php/Symfony/Component/ClassLoader/ApcClassLoader.php
/usr/share/php/Symfony/Component/ClassLoader/ApcUniversalClassLoader.php
/usr/share/php/Symfony/Component/ClassLoader/ClassCollectionLoader.php
/usr/share/php/Symfony/Component/ClassLoader/ClassLoader.php
/usr/share/php/Symfony/Component/ClassLoader/ClassMapGenerator.php
/usr/share/php/Symfony/Component/ClassLoader/DebugClassLoader.php
/usr/share/php/Symfony/Component/ClassLoader/DebugUniversalClassLoader.php
/usr/share/php/Symfony/Component/ClassLoader/MapClassLoader.php
/usr/share/php/Symfony/Component/ClassLoader/Psr4ClassLoader.php
/usr/share/php/Symfony/Component/ClassLoader/UniversalClassLoader.php
/usr/share/php/Symfony/Component/ClassLoader/WinCacheClassLoader.php
/usr/share/php/Symfony/Component/ClassLoader/XcacheClassLoader.php
/usr/share/php/Symfony/Component/ClassLoader/autoload.php
/usr/share/php/Symfony/Component/ClassLoader/autoloader.php

Changelog

See php-symfony-2.8.46-2.fc27.remi.noarch.rpm changelog.

See Also

Package Description
php-symfony-common-2.8.46-2.fc27.remi.noarch.rpm Symfony common files
php-symfony-common-2.8.47-1.fc27.remi.noarch.rpm Symfony common files
php-symfony-config-2.8.46-2.fc27.remi.noarch.rpm Symfony Config Component
php-symfony-config-2.8.47-1.fc27.remi.noarch.rpm Symfony Config Component
php-symfony-console-2.8.46-2.fc27.remi.noarch.rpm Symfony Console Component
php-symfony-console-2.8.47-1.fc27.remi.noarch.rpm Symfony Console Component
php-symfony-css-selector-2.8.46-2.fc27.remi.noarch.rpm Symfony CssSelector Component
php-symfony-css-selector-2.8.47-1.fc27.remi.noarch.rpm Symfony CssSelector Component
php-symfony-dependency-injection-2.8.46-2.fc27.remi.noarch.rpm Symfony DependencyInjection Component
php-symfony-dependency-injection-2.8.47-1.fc27.remi.noarch.rpm Symfony DependencyInjection Component
php-symfony-doctrine-bridge-2.8.46-2.fc27.remi.noarch.rpm Symfony Doctrine Bridge
php-symfony-doctrine-bridge-2.8.47-1.fc27.remi.noarch.rpm Symfony Doctrine Bridge
php-symfony-dom-crawler-2.8.46-2.fc27.remi.noarch.rpm Symfony DomCrawler Component
php-symfony-dom-crawler-2.8.47-1.fc27.remi.noarch.rpm Symfony DomCrawler Component
php-symfony-event-dispatcher-2.8.46-2.fc27.remi.noarch.rpm Symfony EventDispatcher Component
Advertisement
Advertisement