php-alcaeus-mongo-php-adapter-1.1.5-1.fc27.remi.noarch.rpm


Advertisement

Description

php-alcaeus-mongo-php-adapter - Mongo PHP Adapter

Property Value
Distribution Fedora 27
Repository Les RPM de Remi x86_64
Package name php-alcaeus-mongo-php-adapter
Package version 1.1.5
Package release 1.fc27.remi
Package architecture noarch
Package type rpm
Installed size 232.23 KB
Download size 52.79 KB
Official Mirror rpms.famillecollet.com
The Mongo PHP Adapter is a userland library designed to act as an
adapter between applications relying on ext-mongo and the new driver
(ext-mongodb).
It provides the API of ext-mongo built on top of mongo-php-library,
thus being compatible with PHP 7.
Autoloader: /usr/share/php/Alcaeus/MongoDbAdapter/autoload.php

Alternatives

Package Version Architecture Repository
php-alcaeus-mongo-php-adapter-1.1.5-2.fc27.remi.noarch.rpm 1.1.5 noarch Les RPM de Remi
php-alcaeus-mongo-php-adapter-1.1.5-2.fc27.remi.noarch.rpm 1.1.5 noarch Les RPM de Remi
php-alcaeus-mongo-php-adapter-1.1.5-1.fc27.remi.noarch.rpm 1.1.5 noarch Les RPM de Remi
php-alcaeus-mongo-php-adapter-1.1.5-1.fc27.noarch.rpm 1.1.5 noarch Fedora Updates
php-alcaeus-mongo-php-adapter-1.1.5-1.fc27.noarch.rpm 1.1.5 noarch Fedora Updates
php-alcaeus-mongo-php-adapter-1.1.3-1.fc27.noarch.rpm 1.1.3 noarch Fedora
php-alcaeus-mongo-php-adapter-1.1.3-1.fc27.noarch.rpm 1.1.3 noarch Fedora
php-alcaeus-mongo-php-adapter - - -

Requires

Name Value
php(language) >= 5.6
php-composer(fedora/autoloader) -
php-composer(mongodb/mongodb) >= 1.0.1
php-date -
php-hash -
php-mbstring -
php-pcre -
php-pecl(mongodb) >= 1.2.0
php-spl -

Provides

Name Value
php-alcaeus-mongo-php-adapter = 1.1.5-1.fc27.remi
php-composer(alcaeus/mongo-php-adapter) = 1.1.5
php-composer(ext-mongo) = 1.6.14

Download

Type URL
Binary Package php-alcaeus-mongo-php-adapter-1.1.5-1.fc27.remi.noarch.rpm
Source Package php-alcaeus-mongo-php-adapter-1.1.5-1.fc27.remi.src.rpm

Install Howto

  1. Download the latest remi-release rpm from
    http://rpms.famillecollet.com/fedora/27/remi/x86_64/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-alcaeus-mongo-php-adapter rpm package:
    # dnf --enablerepo=remi install php-alcaeus-mongo-php-adapter

Files

Path
/usr/share/doc/php-alcaeus-mongo-php-adapter/CHANGELOG-1.0.md
/usr/share/doc/php-alcaeus-mongo-php-adapter/CHANGELOG-1.1.md
/usr/share/doc/php-alcaeus-mongo-php-adapter/README.md
/usr/share/doc/php-alcaeus-mongo-php-adapter/composer.json
/usr/share/licenses/php-alcaeus-mongo-php-adapter/LICENSE
/usr/share/php/Alcaeus/
/usr/share/php/Alcaeus/Mongo/Mongo.php
/usr/share/php/Alcaeus/Mongo/MongoBinData.php
/usr/share/php/Alcaeus/Mongo/MongoClient.php
/usr/share/php/Alcaeus/Mongo/MongoCode.php
/usr/share/php/Alcaeus/Mongo/MongoCollection.php
/usr/share/php/Alcaeus/Mongo/MongoCommandCursor.php
/usr/share/php/Alcaeus/Mongo/MongoConnectionException.php
/usr/share/php/Alcaeus/Mongo/MongoCursor.php
/usr/share/php/Alcaeus/Mongo/MongoCursorException.php
/usr/share/php/Alcaeus/Mongo/MongoCursorInterface.php
/usr/share/php/Alcaeus/Mongo/MongoCursorTimeoutException.php
/usr/share/php/Alcaeus/Mongo/MongoDB.php
/usr/share/php/Alcaeus/Mongo/MongoDBRef.php
/usr/share/php/Alcaeus/Mongo/MongoDate.php
/usr/share/php/Alcaeus/Mongo/MongoDeleteBatch.php
/usr/share/php/Alcaeus/Mongo/MongoDuplicateKeyException.php
/usr/share/php/Alcaeus/Mongo/MongoException.php
/usr/share/php/Alcaeus/Mongo/MongoExecutionTimeoutException.php
/usr/share/php/Alcaeus/Mongo/MongoGridFS.php
/usr/share/php/Alcaeus/Mongo/MongoGridFSCursor.php
/usr/share/php/Alcaeus/Mongo/MongoGridFSException.php
/usr/share/php/Alcaeus/Mongo/MongoGridFSFile.php
/usr/share/php/Alcaeus/Mongo/MongoId.php
/usr/share/php/Alcaeus/Mongo/MongoInsertBatch.php
/usr/share/php/Alcaeus/Mongo/MongoInt32.php
/usr/share/php/Alcaeus/Mongo/MongoInt64.php
/usr/share/php/Alcaeus/Mongo/MongoLog.php
/usr/share/php/Alcaeus/Mongo/MongoMaxKey.php
/usr/share/php/Alcaeus/Mongo/MongoMinKey.php
/usr/share/php/Alcaeus/Mongo/MongoPool.php
/usr/share/php/Alcaeus/Mongo/MongoProtocolException.php
/usr/share/php/Alcaeus/Mongo/MongoRegex.php
/usr/share/php/Alcaeus/Mongo/MongoResultException.php
/usr/share/php/Alcaeus/Mongo/MongoTimestamp.php
/usr/share/php/Alcaeus/Mongo/MongoUpdateBatch.php
/usr/share/php/Alcaeus/Mongo/MongoWriteBatch.php
/usr/share/php/Alcaeus/Mongo/MongoWriteConcernException.php
/usr/share/php/Alcaeus/Mongo/functions.php
/usr/share/php/Alcaeus/MongoDbAdapter/AbstractCursor.php
/usr/share/php/Alcaeus/MongoDbAdapter/ExceptionConverter.php
/usr/share/php/Alcaeus/MongoDbAdapter/TypeConverter.php
/usr/share/php/Alcaeus/MongoDbAdapter/TypeInterface.php
/usr/share/php/Alcaeus/MongoDbAdapter/autoload.php
/usr/share/php/Alcaeus/MongoDbAdapter/Helper/ReadPreference.php
/usr/share/php/Alcaeus/MongoDbAdapter/Helper/SlaveOkay.php
/usr/share/php/Alcaeus/MongoDbAdapter/Helper/WriteConcern.php
/usr/share/php/Alcaeus/MongoDbAdapter/Helper/WriteConcernConverter.php

Changelog

2018-03-06 - Remi Collet <remi@remirepo.net> - 1.1.5-1
- Update to 1.1.5
- switch to phpunit7
2018-01-25 - Remi Collet <remi@remirepo.net> - 1.1.4-1
- Update to 1.1.4
2017-09-24 - Remi Collet <remi@remirepo.net> - 1.1.3-1
- Update to 1.1.3

See Also

Package Description
php-amqplib-2.7.0-2.fc27.remi.noarch.rpm Pure PHP implementation of the AMQP protocol
php-asm89-stack-cors-1.2.0-1.fc27.remi.noarch.rpm Cross-origin resource sharing library and stack middleware
php-ast-0.1.5-1.fc27.remi.7.1.x86_64.rpm Abstract Syntax Tree
php-ast-0.1.6-1.fc27.remi.7.1.x86_64.rpm Abstract Syntax Tree
php-aura-intl-3.0.0-1.fc27.remi.noarch.rpm Internationalization tools
php-aws-php-sns-message-validator-1.3.0-1.fc27.remi.noarch.rpm Amazon SNS message validation
php-aws-sdk3-3.53.0-1.fc27.remi.noarch.rpm Amazon Web Services framework for PHP
php-aws-sdk3-3.62.10-1.fc27.remi.noarch.rpm Amazon Web Services framework for PHP
php-bacon-qr-code-1.0.3-1.fc27.remi.noarch.rpm QR code generator for PHP
php-bartlett-PHP-CompatInfo-5.0.11-1.fc27.remi.noarch.rpm Find out version and the extensions required for a piece of code to run
php-bartlett-PHP-CompatInfo-5.0.12-1.fc27.remi.noarch.rpm Find out version and the extensions required for a piece of code to run
php-bartlett-PHP-Reflect-4.2.2-1.fc27.remi.noarch.rpm Adds the ability to reverse-engineer PHP
php-bartlett-PHP-Reflect-4.2.2-2.fc27.remi.noarch.rpm Adds the ability to reverse-engineer PHP
php-bartlett-php-compatinfo-db-1.34.0-1.fc27.remi.noarch.rpm Reference Database to be used with php-compatinfo library
php-bartlett-php-compatinfo-db-1.35.0-2.fc27.remi.noarch.rpm Reference Database to be used with php-compatinfo library
Advertisement
Advertisement