eclipse-jdt-4.7.3a-5.fc28.noarch.rpm


Advertisement

Description

eclipse-jdt - Eclipse Java Development Tools

Property Value
Distribution Fedora 28
Repository Fedora Updates i386
Package filename eclipse-jdt-4.7.3a-5.fc28.noarch.rpm
Package name eclipse-jdt
Package version 4.7.3a
Package release 5.fc28
Package architecture noarch
Package type rpm
Homepage http://www.eclipse.org/
License EPL
Maintainer -
Download size 31.88 MB
Installed size 34.24 MB
Eclipse Java Development Tools.  This package is required to use Eclipse for
developing software written in the Java programming language.

Alternatives

Package Version Architecture Repository
eclipse-jdt-4.7.3a-6.fc28.noarch.rpm 4.7.3a noarch Fedora Updates Testing
eclipse-jdt-4.7.3a-6.fc28.noarch.rpm 4.7.3a noarch Fedora Updates Testing
eclipse-jdt-4.7.3a-5.fc28.noarch.rpm 4.7.3a noarch Fedora Updates
eclipse-jdt-4.7.3a-4.fc28.noarch.rpm 4.7.3a noarch Fedora
eclipse-jdt-4.7.3a-4.fc28.noarch.rpm 4.7.3a noarch Fedora
eclipse-jdt - - -

Requires

Name Value
eclipse-platform = 4.7.3a-5.fc28
java-headless >= 1.8
javapackages-tools -
osgi(org.apiguardian) -
osgi(org.hamcrest.core) >= 1.3
osgi(org.junit) -
osgi(org.junit) >= 4.12
osgi(org.junit.jupiter.api) -
osgi(org.junit.jupiter.engine) -
osgi(org.junit.jupiter.migrationsupport) -
osgi(org.junit.jupiter.params) -
osgi(org.junit.platform.commons) -
osgi(org.junit.platform.engine) -
osgi(org.junit.platform.launcher) -
osgi(org.junit.platform.runner) -
osgi(org.junit.platform.suite.api) -
osgi(org.junit.vintage.engine) -
osgi(org.opentest4j) -

Provides

Name Value
eclipse = 4.7.3a-5.fc28
eclipse-jdt = 4.7.3a-5.fc28
metainfo() -
metainfo(eclipse-jdt.metainfo.xml) -
mvn(org.eclipse.ant:org.eclipse.ant.launching) = 1.2.1.SNAPSHOT
mvn(org.eclipse.ant:org.eclipse.ant.ui) = 3.7.0.SNAPSHOT
mvn(org.eclipse.jdt.feature:org.eclipse.jdt) = 3.13.4.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt) = 3.13.4.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.annotation) = 1.1.150.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.annotation) = 2.1.150.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.apt.core) = 3.5.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.apt.pluggable.core) = 1.2.50.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.apt.ui) = 3.5.50.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.compiler.apt) = 1.3.110.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.compiler.tool) = 1.2.101.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.core) = 3.13.102.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.core.manipulation) = 1.9.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.debug) = 3.11.50.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.debug.ui) = 3.8.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.doc.user) = 3.13.75.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit) = 3.10.75.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit.core) = 3.9.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit.runtime) = 3.4.651.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit4.runtime) = 1.1.650.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit5.runtime) = 1.0.1.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.launching) = 3.9.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.ui) = 3.13.100.SNAPSHOT
osgi(org.eclipse.ant.launching) = 1.2.1.v20180409.1128
osgi(org.eclipse.ant.ui) = 3.7.0.v20180409.1128
osgi(org.eclipse.jdt) = 3.13.4.v20180409.1128
osgi(org.eclipse.jdt.annotation) = 1.1.150.v20180409.1128
osgi(org.eclipse.jdt.annotation) = 2.1.150.v20180409.1128
osgi(org.eclipse.jdt.apt.core) = 3.5.100.v20180409.1128
osgi(org.eclipse.jdt.apt.pluggable.core) = 1.2.50.v20180409.1128
osgi(org.eclipse.jdt.apt.ui) = 3.5.50.v20180409.1128
osgi(org.eclipse.jdt.compiler.apt) = 1.3.110.v20180409.1128
osgi(org.eclipse.jdt.compiler.tool) = 1.2.101.v20180409.1128
osgi(org.eclipse.jdt.core) = 3.13.102.v20180409.1128
osgi(org.eclipse.jdt.core.manipulation) = 1.9.100.v20180409.1128
osgi(org.eclipse.jdt.debug) = 3.11.50.v20180409.1128
osgi(org.eclipse.jdt.debug.ui) = 3.8.100.v20180409.1128
osgi(org.eclipse.jdt.doc.user) = 3.13.75.v20180409.1128
osgi(org.eclipse.jdt.junit) = 3.10.75.v20180409.1128
osgi(org.eclipse.jdt.junit.core) = 3.9.100.v20180409.1128
osgi(org.eclipse.jdt.junit.runtime) = 3.4.651.v20180409.1128
osgi(org.eclipse.jdt.junit4.runtime) = 1.1.650.v20180409.1128
osgi(org.eclipse.jdt.junit5.runtime) = 1.0.1.v20180409.1128
osgi(org.eclipse.jdt.launching) = 3.9.100.v20180409.1128
osgi(org.eclipse.jdt.ui) = 3.13.100.v20180409.1128

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package eclipse-jdt-4.7.3a-5.fc28.noarch.rpm
Source Package eclipse-4.7.3a-5.fc28.src.rpm

Install Howto

Install eclipse-jdt rpm package:

# dnf install eclipse-jdt

Files

Path
/usr/share/appdata/eclipse-jdt.metainfo.xml
/usr/share/eclipse/droplets/eclipse-jdt/
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/fragment.info
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/features/
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/features/org.eclipse.jdt_3.13.4.v20180409-1128/epl-v10.html
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/features/org.eclipse.jdt_3.13.4.v20180409-1128/feature.properties
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/features/org.eclipse.jdt_3.13.4.v20180409-1128/feature.xml
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/features/org.eclipse.jdt_3.13.4.v20180409-1128/license.html
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/features/org.eclipse.jdt_3.13.4.v20180409-1128/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/features/org.eclipse.jdt_3.13.4.v20180409-1128/META-INF/maven/
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/features/org.eclipse.jdt_3.13.4.v20180409-1128/META-INF/maven/org.eclipse.jdt.feature/
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/features/org.eclipse.jdt_3.13.4.v20180409-1128/META-INF/maven/org.eclipse.jdt.feature/org.eclipse.jdt/pom.properties
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/features/org.eclipse.jdt_3.13.4.v20180409-1128/META-INF/maven/org.eclipse.jdt.feature/org.eclipse.jdt/pom.xml
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/com.univocity.parsers_2.5.5.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/net.sf.cglib.core_3.2.4.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.apiguardian_1.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.easymock_3.5.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.ant.launching_1.2.1.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.ant.ui_3.7.0.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.annotation_1.1.150.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.annotation_2.1.150.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.apt.core_3.5.100.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.apt.pluggable.core_1.2.50.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.apt.ui_3.5.50.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.compiler.apt_1.3.110.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.compiler.tool_1.2.101.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.core.manipulation_1.9.100.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.core_3.13.102.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug.ui_3.8.100.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.doc.user_3.13.75.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.junit.core_3.9.100.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.junit.runtime_3.4.651.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.junit4.runtime_1.1.650.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.junit5.runtime_1.0.1.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.junit_3.10.75.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.launching_3.9.100.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.ui_3.13.100.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt_3.13.4.v20180409-1128.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.hamcrest.core_1.3.0.v201303031735.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.hamcrest.integration_1.3.0.v20090501071000.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.junit.jupiter.api_5.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.junit.jupiter.engine_5.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.junit.jupiter.migrationsupport_5.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.junit.jupiter.params_5.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.junit.platform.commons_1.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.junit.platform.engine_1.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.junit.platform.launcher_1.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.junit.platform.runner_1.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.junit.platform.suite.api_1.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.junit.vintage.engine_4.12.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.junit_4.12.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.objectweb.asm_6.1.1.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.objenesis_2.6.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.opentest4j_1.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/.api_description
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/.options
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/about.html
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/jdi.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/jdimodel.jar
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/plugin.properties
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/plugin.xml
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/META-INF/maven/
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/META-INF/maven/org.eclipse.jdt/
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/META-INF/maven/org.eclipse.jdt/org.eclipse.jdt.debug/pom.properties
/usr/share/eclipse/droplets/eclipse-jdt/eclipse/plugins/org.eclipse.jdt.debug_3.11.50.v20180409-1128/META-INF/maven/org.eclipse.jdt/org.eclipse.jdt.debug/pom.xml
/usr/share/maven-metadata/eclipse-jdt.xml

Changelog

2018-05-21 - Mat Booth <mat.booth@redhat.com> - 1:4.7.3a-5
- Try to fix arm platform launcher build
2018-04-10 - Mat Booth <mat.booth@redhat.com> - 1:4.7.3a-4
- Ensure patches apply cleanly
- Use java API stubs from ecj package
2018-04-09 - Mat Booth <mat.booth@redhat.com> - 1:4.7.3a-3
- Package java 10 API stubs jar
2018-04-09 - Mat Booth <mat.booth@redhat.com> - 1:4.7.3a-2
- Backport patches to fix broken table editing
2018-04-09 - Mat Booth <mat.booth@redhat.com> - 1:4.7.3a-1
- Update to Oxygen.3a release for java 10 support
2018-03-21 - Mat Booth <mat.booth@redhat.com> - 1:4.7.3-2
- Bump jetty dependency
2018-03-15 - Mat Booth <mat.booth@redhat.com> - 1:4.7.3-1
- Update to Oxygen.3 release
2018-02-07 - Fedora Release Engineering <releng@fedoraproject.org> - 1:4.7.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2018-01-09 - Merlin Mathesius <mmathesi@redhat.com> - 1:4.7.2-2
- Cleanup spec file conditionals
2017-11-29 - Mat Booth <mat.booth@redhat.com> - 1:4.7.2-1
- Update to last RC/final release of Oxygen.2
- Fix x11 crash when running on wayland

See Also

Package Description
eclipse-linuxtools-6.2.1-2.fc28.noarch.rpm Linux specific Eclipse plugins
eclipse-linuxtools-changelog-6.2.1-2.fc28.noarch.rpm Eclipse ChangeLog plug-in
eclipse-linuxtools-docker-6.2.1-2.fc28.noarch.rpm Docker Tooling
eclipse-linuxtools-gcov-6.2.1-2.fc28.noarch.rpm GCov Integration
eclipse-linuxtools-gprof-6.2.1-2.fc28.noarch.rpm GProf Integration
eclipse-linuxtools-javadocs-6.2.1-2.fc28.noarch.rpm Javadocs documentaton plugin for Eclipse
eclipse-linuxtools-libhover-6.2.1-2.fc28.noarch.rpm Libhover documentaton plugin for Eclipse
eclipse-linuxtools-manpage-6.2.1-2.fc28.noarch.rpm Man page viewer
eclipse-linuxtools-oprofile-6.2.1-2.fc28.noarch.rpm Eclipse plugin for OProfile integration
eclipse-linuxtools-perf-6.2.1-2.fc28.noarch.rpm Eclipse plugin for Perf integration
eclipse-linuxtools-rpm-editor-6.2.1-2.fc28.noarch.rpm RPM Spec file editor for Eclipse
eclipse-linuxtools-systemtap-6.2.1-2.fc28.noarch.rpm Systemtap Tools Integration for Eclipse
eclipse-linuxtools-tests-6.2.1-2.fc28.noarch.rpm Linux Tools Project Test Bundles
eclipse-linuxtools-vagrant-6.2.1-2.fc28.noarch.rpm Vagrant Tooling
eclipse-linuxtools-valgrind-6.2.1-2.fc28.noarch.rpm Valgrind Tools Integration for Eclipse
Advertisement
Advertisement