gtengine-3.15-1.fc28.i686.rpm


Advertisement

Description

gtengine - Library for computations in mathematics, graphics, image analysis, and physics

Property Value
Distribution Fedora 28
Repository Fedora Updates i386
Package name gtengine
Package version 3.15
Package release 1.fc28
Package architecture i686
Package type rpm
Installed size 1.81 MB
Download size 481.55 KB
Official Mirror download-ib01.fedoraproject.org
A library of source code for computing in the fields of mathematics,
graphics, image analysis, and physics.
The engine is written in C++ 11 and, as such, has portable access
to standard constructs for multithreading programming on cores.
The engine also supports high-performance computing using general
purpose GPU programming (GPGPU).
SIMD code is also available using Intel Streaming SIMD Extensions (SSE).
GTEngine requires OpenGL 4.3 (or later) and GLSL 4.3 (or later)
in order to support compute shaders and GLSL introspection.
This is new version of Wild Magic 5 Engine.

Alternatives

Package Version Architecture Repository
gtengine-3.15-1.fc28.x86_64.rpm 3.15 x86_64 Fedora Updates
gtengine-3.15-1.fc28.i686.rpm 3.15 i686 Fedora Updates
gtengine-3.11-1.fc28.x86_64.rpm 3.11 x86_64 Fedora
gtengine-3.11-1.fc28.i686.rpm 3.11 i686 Fedora
gtengine-3.11-1.fc28.i686.rpm 3.11 i686 Fedora
gtengine - - -

Requires

Name Value
libEGL.so.1 -
libGL.so.1 -
libX11.so.6 -
libc.so.6(GLIBC_2.11) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libglut.so.3 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libpng16.so.16 -
libpng16.so.16(PNG16_0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.14) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.19) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
rtld(GNU_HASH) -

Provides

Name Value
gtengine = 3.15-1.fc28
gtengine(x86-32) = 3.15-1.fc28
libgtengine.so.3 -

Download

Type URL
Binary Package gtengine-3.15-1.fc28.i686.rpm
Source Package gtengine-3.15-1.fc28.src.rpm

Install Howto

Install gtengine rpm package:

# dnf install gtengine

Files

Path
/usr/lib/libgtengine.so.3
/usr/lib/libgtengine.so.3.15
/usr/lib/.build-id/
/usr/lib/.build-id/c1/30b0aef48ed47af8079846e48a68bec46be997
/usr/share/licenses/gtengine/License

Changelog

2018-09-13 - Antonio Trande <sagitter@fedoraproject.org> 3.15-1
- Update to 3.15
2018-07-22 - Antonio Trande <sagitter@fedoraproject.org> 3.14-1
- Update to 3.14
- Include EGL support
2018-07-13 - Fedora Release Engineering <releng@fedoraproject.org> - 3.12-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-05-20 - Antonio Trande <sagitter@fedoraproject.org> 3.12-1
- Update to 3.12
2018-02-17 - Antonio Trande <sagitter@fedoraproject.org> 3.11-1
- Update to 3.11
2018-02-16 - Antonio Trande <sagitter@fedoraproject.org> - 3.10-3
- Use %ldconfig_scriptlets
2018-02-07 - Fedora Release Engineering <releng@fedoraproject.org> - 3.10-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2017-10-14 - Antonio Trande <sagitter@fedoraproject.org> 3.10-1
- Update to 3.10
2017-08-06 - Antonio Trande <sagitter@fedoraproject.org> 3.9-1
- Update to 3.9
2017-08-02 - Fedora Release Engineering <releng@fedoraproject.org> - 3.8-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild

See Also

Package Description
gtengine-devel-3.15-1.fc28.i686.rpm Development files for gtengine
gtengine-samples-3.15-1.fc28.i686.rpm Samples files of gtengine
gthumb-3.6.2-1.fc28.i686.rpm Image viewer, editor, organizer
gthumb-devel-3.6.2-1.fc28.i686.rpm Header files needed for developing gthumb extensions
gtk+extra-2.1.2-23.fc28.i686.rpm A library of gtk+ widgets
gtk+extra-devel-2.1.2-23.fc28.i686.rpm A library of gtk+ widgets
gtk-doc-1.28-2.fc28.i686.rpm API documentation generation tool for GTK+ and GNOME
gtk-gnutella-1.1.13-1.fc28.i686.rpm GUI based Gnutella Client
gtk-vnc-0.7.2-2.fc28.i686.rpm A GTK2 widget for VNC clients
gtk-vnc-devel-0.7.2-2.fc28.i686.rpm Development files to build GTK2 applications with gtk-vnc
gtk-vnc2-0.7.2-2.fc28.i686.rpm A GTK3 widget for VNC clients
gtk-vnc2-devel-0.7.2-2.fc28.i686.rpm Development files to build GTK3 applications with gtk-vnc
gtk2-2.24.32-4.fc28.i686.rpm GTK+ graphical user interface library
gtk2-devel-2.24.32-4.fc28.i686.rpm Development files for GTK+
gtk2-devel-docs-2.24.32-4.fc28.i686.rpm Developer documentation for GTK+
Advertisement
Advertisement