legion-openmpi-18.05.0-1.fc28.i686.rpm


Advertisement

Description

legion-openmpi - Legion Open MPI binaries and libraries

Property Value
Distribution Fedora 28
Repository Fedora Updates i386
Package name legion-openmpi
Package version 18.05.0
Package release 1.fc28
Package architecture i686
Package type rpm
Installed size 18.71 MB
Download size 3.43 MB
Official Mirror download-ib01.fedoraproject.org
Legion is a data-centric parallel programming system for writing portable
high performance programs targeted at distributed heterogeneous architectures.
Legion presents abstractions which allow programmers to describe properties of
program data (e.g. independence, locality). By making the Legion programming
system aware of the structure of program data, it can automate many of the
tedious tasks programmers currently face, including correctly extracting task-
and data-level parallelism and moving data around complex memory hierarchies.
A novel mapping interface provides explicit programmer controlled placement of
data in the memory hierarchy and assignment of tasks to processors in a way that
is orthogonal to correctness, thereby enabling easy porting and tuning of Legion
applications to new architectures.
Legion compiled with Open MPI, package incl. binaries and libraries

Alternatives

Package Version Architecture Repository
legion-openmpi-18.05.0-1.fc28.x86_64.rpm 18.05.0 x86_64 Fedora Updates
legion-openmpi-18.05.0-1.fc28.i686.rpm 18.05.0 i686 Fedora Updates
legion-openmpi-18.02.0-3.fc28.x86_64.rpm 18.02.0 x86_64 Fedora
legion-openmpi-18.02.0-3.fc28.i686.rpm 18.02.0 i686 Fedora
legion-openmpi-18.02.0-3.fc28.i686.rpm 18.02.0 i686 Fedora
legion-openmpi - - -

Requires

Name Value
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
legion(x86-32) = 18.05.0-1.fc28
libc.so.6(GLIBC_2.4) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgasnet-mpi-par-1.30.0.so(openmpi-i386) -
libgasnet_tools-par-1.30.0.so(openmpi-i386) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libhwloc.so.5 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.3.2) -
libpthread.so.0(GLIBC_2.3.4) -
librt.so.1 -
librt.so.1(GLIBC_2.1) -
librt.so.1(GLIBC_2.2) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
openmpi -
rtld(GNU_HASH) -

Provides

Name Value
legion-openmpi = 18.05.0-1.fc28
legion-openmpi(x86-32) = 18.05.0-1.fc28
liblegion.so.1(openmpi-i386) -
librealm.so.1(openmpi-i386) -

Download

Type URL
Binary Package legion-openmpi-18.05.0-1.fc28.i686.rpm
Source Package legion-18.05.0-1.fc28.src.rpm

Install Howto

Install legion-openmpi rpm package:

# dnf install legion-openmpi

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/4f/1cd08d01355f0975495d7ebf1abdf8bca4c055
/usr/lib/.build-id/6a/cedf534ff5fad712470f2ac3da71f7b3084f7c
/usr/lib/openmpi/lib/liblegion.so.1
/usr/lib/openmpi/lib/librealm.so.1

Changelog

See legion-18.05.0-1.fc28.i686.rpm changelog.

See Also

Package Description
lemon-3.22.0-5.fc28.i686.rpm A parser generator
leptonica-1.77.0-1.fc28.i686.rpm C library for efficient image processing and image analysis operations
leptonica-devel-1.77.0-1.fc28.i686.rpm Development files for leptonica
leptonica-tools-1.77.0-1.fc28.i686.rpm Leptonica utility tools
leveldb-1.20-2.fc28.i686.rpm A fast and lightweight key/value database library by Google
leveldb-devel-1.20-2.fc28.i686.rpm Development files for leveldb
lftp-4.8.4-1.fc28.i686.rpm A sophisticated file transfer program
lftp-scripts-4.8.4-1.fc28.noarch.rpm Scripts for lftp
lhapdf-6.2.1-1.fc28.i686.rpm Les Houches Accord PDF Interface
lhapdf-devel-6.2.1-1.fc28.i686.rpm Les Houches Accord PDF Interface - development files
lhapdf-doc-6.2.1-1.fc28.noarch.rpm Les Houches Accord PDF Interface - documentation
libCombine-0.2.2-3.20180426git8902b68.fc28.i686.rpm C++ library for working with the COMBINE Archive format
libCombine-devel-0.2.2-3.20180426git8902b68.fc28.i686.rpm Development files of libCombine
libCombine-static-0.2.2-3.20180426git8902b68.fc28.i686.rpm Static library of libCombine
libNX_X11-3.5.99.17-1.fc28.i686.rpm Core NX protocol client library
Advertisement
Advertisement