libsemanage-2.8-2.fc28.i686.rpm


Advertisement

Description

libsemanage - SELinux binary policy manipulation library

Property Value
Distribution Fedora 28
Repository Fedora Updates i386
Package name libsemanage
Package version 2.8
Package release 2.fc28
Package architecture i686
Package type rpm
Installed size 341.19 KB
Download size 169.95 KB
Official Mirror download-ib01.fedoraproject.org
Security-enhanced Linux is a feature of the Linux® kernel and a number
of utilities with enhanced security functionality designed to add
mandatory access controls to Linux.  The Security-enhanced Linux
kernel contains new architectural components originally developed to
improve the security of the Flask operating system. These
architectural components provide general support for the enforcement
of many kinds of mandatory access control policies, including those
based on the concepts of Type Enforcement®, Role-based Access
Control, and Multi-level Security.
libsemanage provides an API for the manipulation of SELinux binary policies.
It is used by checkpolicy (the policy compiler) and similar tools, as well
as by programs like load_policy that need to perform specific transformations
on binary policies such as customizing policy boolean settings.

Alternatives

Package Version Architecture Repository
libsemanage-2.8-2.fc28.x86_64.rpm 2.8 x86_64 Fedora Updates
libsemanage-2.8-2.fc28.i686.rpm 2.8 i686 Fedora Updates
libsemanage-2.7-12.fc28.x86_64.rpm 2.7 x86_64 Fedora
libsemanage-2.7-12.fc28.i686.rpm 2.7 i686 Fedora
libsemanage-2.7-12.fc28.i686.rpm 2.7 i686 Fedora
libsemanage - - -

Requires

Name Value
audit-libs -
bzip2-libs -
libaudit.so.1 -
libbz2.so.1 -
libc.so.6(GLIBC_2.8) -
libselinux(x86-32) >= 2.8-1
libselinux.so.1 -
libsepol.so.1 -
libsepol.so.1(LIBSEPOL_1.0) -
libsepol.so.1(LIBSEPOL_1.1) -
rtld(GNU_HASH) -

Provides

Name Value
config(libsemanage) = 2.8-2.fc28
libsemanage = 2.8-2.fc28
libsemanage(x86-32) = 2.8-2.fc28
libsemanage.so.1 -
libsemanage.so.1(LIBSEMANAGE_1.0) -
libsemanage.so.1(LIBSEMANAGE_1.1) -

Download

Type URL
Binary Package libsemanage-2.8-2.fc28.i686.rpm
Source Package libsemanage-2.8-2.fc28.src.rpm

Install Howto

Install libsemanage rpm package:

# dnf install libsemanage

Files

Path
/etc/selinux/semanage.conf
/usr/lib/libsemanage.so.1
/usr/lib/.build-id/
/usr/lib/.build-id/28/620e7937233898ddbbdc62c35b8f1d01654225
/usr/libexec/selinux/
/usr/share/licenses/libsemanage/COPYING
/usr/share/man/man5/semanage.conf.5.gz
/var/lib/selinux/
/var/lib/selinux/tmp/

Changelog

2018-06-26 - Vit Mojzis <vmojzis@redhat.com> - 2.8-2
- Disable expand-check
2018-05-25 - Petr Lautrbach <plautrba@redhat.com> - 2.8-1
- SELinux userspace 2.8 release
2018-05-14 - Petr Lautrbach <plautrba@redhat.com> - 2.8-0.rc3.1
- SELinux userspace 2.8-rc3 release candidate
2018-05-04 - Petr Lautrbach <plautrba@redhat.com> - 2.8-0.rc2.1
- SELinux userspace 2.8-rc2 release candidate
2018-04-23 - Petr Lautrbach <plautrba@redhat.com> - 2.8-0.rc1.1
- SELinux userspace 2.8-rc1 release candidate
2018-03-21 - Petr Lautrbach <plautrba@redhat.com> - 2.7-12
- build: Replace PYSITEDIR with PYTHONLIBDIR
- direct_api.c: Fix iterating over array (#1557468)
2018-03-16 - Petr Lautrbach <plautrba@workstation> - 2.7-11
- Revert "remove access() check to make setuid programs work" (#1557468)
2018-03-13 - Petr Lautrbach <plautrba@redhat.com> - 2.7-10
- properly check return value of iterate function
- Use umask(0077) for fopen() write operations
- Return commit number if save-previous false
- Allow tmp files to be kept if a compile fails
- build: follow standard semantics for DESTDIR and PREFIX
- Improve warning for installing disabled module
- silence clang static analyzer report
- remove access() check to make setuid programs work
2018-02-09 - Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.7-9
- Escape macros in %changelog
2018-02-07 - Fedora Release Engineering <releng@fedoraproject.org> - 2.7-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

See Also

Package Description
libsemanage-devel-2.8-2.fc28.i686.rpm Header files and libraries used to build policy manipulation tools
libsemanage-static-2.8-2.fc28.i686.rpm Static library used to build policy manipulation tools
libsepol-2.8-1.fc28.i686.rpm SELinux binary policy manipulation library
libsepol-devel-2.8-1.fc28.i686.rpm Header files and libraries used to build policy manipulation tools
libsepol-static-2.8-1.fc28.i686.rpm static libraries used to build policy manipulation tools
libshaderc-2018.0-1.fc28.i686.rpm A library for compiling shader strings into SPIR-V
libshaderc-devel-2018.0-1.fc28.i686.rpm Development files for libshaderc
libshaderc-static-2018.0-1.fc28.i686.rpm A library for compiling shader strings into SPIR-V (static libraries)
libsigrok-0.5.1-1.fc28.i686.rpm Basic hardware access drivers for logic analyzers
libsigrok-cxx-0.5.1-1.fc28.i686.rpm C++ bindings for libsigrok
libsigrok-cxx-devel-0.5.1-1.fc28.i686.rpm Development files for libsigrok C++ bindings
libsigrok-devel-0.5.1-1.fc28.i686.rpm Development files for libsigrok
libsigrok-doc-0.5.1-1.fc28.noarch.rpm API documentation for libsigrok
libsigrokdecode-0.5.2-1.fc28.i686.rpm Basic API for running protocol decoders
libsigrokdecode-devel-0.5.2-1.fc28.i686.rpm Development files for libsigrokdecode
Advertisement
Advertisement