php-phpunitgoodpractices-polyfill-1.1.0-5.fc28.noarch.rpm


Advertisement

Description

php-phpunitgoodpractices-polyfill - Lacking future-compat polyfills for PHPUnit

Property Value
Distribution Fedora 28
Repository Fedora Updates i386
Package name php-phpunitgoodpractices-polyfill
Package version 1.1.0
Package release 5.fc28
Package architecture noarch
Package type rpm
Installed size 31.88 KB
Download size 15.20 KB
Official Mirror download-ib01.fedoraproject.org
Lacking future-compat polyfills for PHPUnit.
Autoloader: /usr/share/php/PHPUnitGoodPractices/Polyfill/autoload.php

Alternatives

Package Version Architecture Repository
php-phpunitgoodpractices-polyfill-1.1.0-5.fc28.remi.noarch.rpm 1.1.0 noarch Les RPM de Remi
php-phpunitgoodpractices-polyfill-1.1.0-5.fc28.remi.noarch.rpm 1.1.0 noarch Les RPM de Remi
php-phpunitgoodpractices-polyfill-1.1.0-5.fc28.noarch.rpm 1.1.0 noarch Fedora Updates
php-phpunitgoodpractices-polyfill-1.1.0-4.fc28.remi.noarch.rpm 1.1.0 noarch Les RPM de Remi
php-phpunitgoodpractices-polyfill-1.1.0-4.fc28.remi.noarch.rpm 1.1.0 noarch Les RPM de Remi
php-phpunitgoodpractices-polyfill - - -

Requires

Name Value
(phpunit7 or phpunit6 or php-phpunit-PHPUnit)
php composer(fedora/autoloader)
php(language) >= 5.5

Provides

Name Value
php-composer(phpunitgoodpractices/polyfill) = 1.1.0
php-composer(phpunitgoodpractices/traits) = 1.7.0
php-phpunitgoodpractices-polyfill = 1.1.0-5.fc28
php-phpunitgoodpractices-traits = 1.7.0

Download

Type URL
Binary Package php-phpunitgoodpractices-polyfill-1.1.0-5.fc28.noarch.rpm
Source Package php-phpunitgoodpractices-polyfill-1.1.0-5.fc28.src.rpm

Install Howto

Install php-phpunitgoodpractices-polyfill rpm package:

# dnf install php-phpunitgoodpractices-polyfill

Files

Path
/usr/share/doc/php-phpunitgoodpractices-polyfill/composer-polyfill.json
/usr/share/doc/php-phpunitgoodpractices-polyfill/composer-traits.json
/usr/share/licenses/php-phpunitgoodpractices-polyfill/LICENSE-polyfill
/usr/share/licenses/php-phpunitgoodpractices-polyfill/LICENSE-traits
/usr/share/php/PHPUnitGoodPractices/
/usr/share/php/PHPUnitGoodPractices/Polyfill/PolyfillTrait.php
/usr/share/php/PHPUnitGoodPractices/Polyfill/PolyfillTrait7.php
/usr/share/php/PHPUnitGoodPractices/Polyfill/aliases.php
/usr/share/php/PHPUnitGoodPractices/Polyfill/autoload.php
/usr/share/php/PHPUnitGoodPractices/Traits/ExpectOverSetExceptionTrait.php
/usr/share/php/PHPUnitGoodPractices/Traits/ExpectationViaCodeOverAnnotationTrait.php
/usr/share/php/PHPUnitGoodPractices/Traits/ExpectationViaCodeOverAnnotationTrait7.php
/usr/share/php/PHPUnitGoodPractices/Traits/IdentityOverEqualityTrait.php
/usr/share/php/PHPUnitGoodPractices/Traits/IdentityOverEqualityTrait7.php
/usr/share/php/PHPUnitGoodPractices/Traits/PHPUnitVersionRetriever.php
/usr/share/php/PHPUnitGoodPractices/Traits/ProphecyOverMockObjectTrait.php
/usr/share/php/PHPUnitGoodPractices/Traits/ProphecyOverMockObjectTrait7.php
/usr/share/php/PHPUnitGoodPractices/Traits/ProphesizeOnlyInterfaceTrait.php
/usr/share/php/PHPUnitGoodPractices/Traits/ProphesizeOnlyInterfaceTrait7.php
/usr/share/php/PHPUnitGoodPractices/Traits/Reporter.php

Changelog

2018-12-29 - Remi Collet <remi@remirepo.net> - 1.1.0-5
- update phpunitgoodpractices/traits to 1.7.0
2018-09-04 - Remi Collet <remi@remirepo.net> - 1.1.0-4
- update phpunitgoodpractices/traits to 1.6.0
2018-06-25 - Remi Collet <remi@remirepo.net> - 1.1.0-2
- add mandatory dependency on one PHPUnit version
- add phpunitgoodpractices/traits 1.5.1
- fix autoloader #1594663
2018-06-11 - Remi Collet <remi@remirepo.net> - 1.1.0-1
- update to 1.1.0 (no change)
- add LICENSE file
2018-06-04 - Remi Collet <remi@remirepo.net> - 1.0.0-1
- initial package, version 1.0.0
- open https://github.com/PHPUnitGoodPractices/polyfill/issues/1 - LICENSE file

See Also

Package Description
php-pragmarx-google2fa-3.0.1-2.fc28.noarch.rpm Google Two-Factor Authentication for PHP Package
php-process-7.2.16-1.fc28.i686.rpm Modules for PHP script using system process interfaces
php-pspell-7.2.16-1.fc28.i686.rpm A module for PHP applications for using pspell interfaces
php-react-promise-stream-1.1.1-2.fc28.noarch.rpm The missing link between Promise-land and Stream-land for ReactPHP
php-recode-7.2.16-1.fc28.i686.rpm A module for PHP applications for using the recode library
php-ringcentral-psr7-1.2.2-1.fc28.noarch.rpm PSR-7 message implementation
php-sabre-dav-3.2.3-1.fc28.noarch.rpm WebDAV Framework for PHP
php-sabre-event5-5.0.3-1.fc28.noarch.rpm Lightweight library for event-based programming
php-sabre-http-4.2.4-1.fc28.noarch.rpm Library for dealing with http requests and responses
php-sabre-vobject4-4.1.6-1.fc28.noarch.rpm Library to parse and manipulate iCalendar and vCard objects
php-sabre-xml-1.5.1-1.fc28.noarch.rpm XML library that you may not hate
php-samyoul-u2f-php-server-1.1.4-1.fc28.noarch.rpm Server side handling class for FIDO U2F registration and authentication
php-scssphp-0.7.6-1.fc28.noarch.rpm A compiler for SCSS written in PHP
php-sebastian-comparator3-3.0.2-1.fc28.noarch.rpm Compare PHP values for equality
php-sebastian-diff3-3.0.2-1.fc28.noarch.rpm Diff implementation
Advertisement
Advertisement