php-pragmarx-google2fa-3.0.1-2.fc28.noarch.rpm


Advertisement

Description

php-pragmarx-google2fa - Google Two-Factor Authentication for PHP Package

Property Value
Distribution Fedora 28
Repository Fedora Updates i386
Package name php-pragmarx-google2fa
Package version 3.0.1
Package release 2.fc28
Package architecture noarch
Package type rpm
Installed size 31.78 KB
Download size 19.75 KB
Official Mirror download-ib01.fedoraproject.org
Google2FA is a PHP implementation of the Google Two-Factor Authentication
Module, supporting the HMAC-Based One-time Password (HOTP) algorithm
specified in RFC 4226 and the Time-based One-time Password (TOTP) algorithm
specified in RFC 6238.
Autoloader: /usr/share/php/PragmaRX/Google2FA/autoload.php

Alternatives

Package Version Architecture Repository
php-pragmarx-google2fa-3.0.3-1.fc28.remi.noarch.rpm 3.0.3 noarch Les RPM de Remi
php-pragmarx-google2fa-3.0.3-1.fc28.remi.noarch.rpm 3.0.3 noarch Les RPM de Remi
php-pragmarx-google2fa-3.0.2-1.fc28.remi.noarch.rpm 3.0.2 noarch Les RPM de Remi
php-pragmarx-google2fa-3.0.2-1.fc28.remi.noarch.rpm 3.0.2 noarch Les RPM de Remi
php-pragmarx-google2fa-3.0.1-2.fc28.noarch.rpm 3.0.1 noarch Fedora Updates
php-pragmarx-google2fa-3.0.1-1.fc28.noarch.rpm 3.0.1 noarch Fedora Updates Testing
php-pragmarx-google2fa-3.0.1-1.fc28.noarch.rpm 3.0.1 noarch Fedora Updates Testing
php-pragmarx-google2fa-3.0.1-1.fc28.noarch.rpm 3.0.1 noarch Fedora
php-pragmarx-google2fa-3.0.1-1.fc28.noarch.rpm 3.0.1 noarch Fedora
php-pragmarx-google2fa - - -

Requires

Name Value
(php-composer(paragonie/constant_time_encoding) >= 1.0 with php-composer(paragonie/constant_time_encoding) < 3)
(php-composer(paragonie/random_compat) >= 2.0 with php-composer(paragonie/random_compat) < 3)
php(language) >= 5.6
php-composer(fedora/autoloader) -
php-hash -
php-pcre -

Provides

Name Value
php-composer(pragmarx/google2fa) = 3.0.1
php-pragmarx-google2fa = 3.0.1-2.fc28

Download

Type URL
Binary Package php-pragmarx-google2fa-3.0.1-2.fc28.noarch.rpm
Source Package php-pragmarx-google2fa-3.0.1-2.fc28.src.rpm

Install Howto

Install php-pragmarx-google2fa rpm package:

# dnf install php-pragmarx-google2fa

Files

Path
/usr/share/doc/php-pragmarx-google2fa/README.md
/usr/share/doc/php-pragmarx-google2fa/changelog.md
/usr/share/doc/php-pragmarx-google2fa/composer.json
/usr/share/licenses/php-pragmarx-google2fa/LICENSE.md
/usr/share/licenses/php-pragmarx-google2fa/RELICENSED.md
/usr/share/php/PragmaRX/
/usr/share/php/PragmaRX/Google2FA/Google2FA.php
/usr/share/php/PragmaRX/Google2FA/autoload.php
/usr/share/php/PragmaRX/Google2FA/Exceptions/IncompatibleWithGoogleAuthenticatorException.php
/usr/share/php/PragmaRX/Google2FA/Exceptions/InsecureCallException.php
/usr/share/php/PragmaRX/Google2FA/Exceptions/InvalidCharactersException.php
/usr/share/php/PragmaRX/Google2FA/Exceptions/SecretKeyTooShortException.php
/usr/share/php/PragmaRX/Google2FA/Support/Base32.php
/usr/share/php/PragmaRX/Google2FA/Support/Constants.php
/usr/share/php/PragmaRX/Google2FA/Support/QRCode.php
/usr/share/php/PragmaRX/Google2FA/Support/Url.php

Changelog

2018-05-02 - Remi Collet <remi@remirepo.net> - 3.0.1-2
- allow paragonie/constant_time_encoding v2
2018-03-22 - Remi Collet <remi@remirepo.net> - 3.0.1-1
- update to 3.0.1
- license have be changed to MIT
2018-03-07 - Remi Collet <remi@remirepo.net> - 2.0.7-2
- add GPLv3+ to License field and ask upstream for clarification
https://github.com/antonioribeiro/google2fa/issues/95
2018-03-07 - Remi Collet <remi@remirepo.net> - 2.0.7-1
- initial package

See Also

Package Description
php-process-7.2.16-1.fc28.i686.rpm Modules for PHP script using system process interfaces
php-pspell-7.2.16-1.fc28.i686.rpm A module for PHP applications for using pspell interfaces
php-react-promise-stream-1.1.1-2.fc28.noarch.rpm The missing link between Promise-land and Stream-land for ReactPHP
php-recode-7.2.16-1.fc28.i686.rpm A module for PHP applications for using the recode library
php-ringcentral-psr7-1.2.2-1.fc28.noarch.rpm PSR-7 message implementation
php-sabre-dav-3.2.3-1.fc28.noarch.rpm WebDAV Framework for PHP
php-sabre-event5-5.0.3-1.fc28.noarch.rpm Lightweight library for event-based programming
php-sabre-http-4.2.4-1.fc28.noarch.rpm Library for dealing with http requests and responses
php-sabre-vobject4-4.1.6-1.fc28.noarch.rpm Library to parse and manipulate iCalendar and vCard objects
php-sabre-xml-1.5.1-1.fc28.noarch.rpm XML library that you may not hate
php-samyoul-u2f-php-server-1.1.4-1.fc28.noarch.rpm Server side handling class for FIDO U2F registration and authentication
php-scssphp-0.7.6-1.fc28.noarch.rpm A compiler for SCSS written in PHP
php-sebastian-comparator3-3.0.2-1.fc28.noarch.rpm Compare PHP values for equality
php-sebastian-diff3-3.0.2-1.fc28.noarch.rpm Diff implementation
php-sebastian-environment4-4.1.0-1.fc28.noarch.rpm Handle HHVM/PHP environments
Advertisement
Advertisement