python3-abrt-2.10.10-1.fc28.i686.rpm


Advertisement

Description

python3-abrt - ABRT Python 3 API

Property Value
Distribution Fedora 28
Repository Fedora Updates i386
Package filename python3-abrt-2.10.10-1.fc28.i686.rpm
Package name python3-abrt
Package version 2.10.10
Package release 1.fc28
Package architecture i686
Package type rpm
Homepage https://abrt.readthedocs.org/
License GPLv2+
Maintainer -
Download size 58.34 KB
Installed size 52.79 KB
High-level API for querying, creating and manipulating
problems handled by ABRT in Python 3.

Alternatives

Package Version Architecture Repository
python3-abrt-2.10.10-1.fc28.x86_64.rpm 2.10.10 x86_64 Fedora Updates
python3-abrt-2.10.8-2.fc28.i686.rpm 2.10.8 i686 Fedora
python3-abrt-2.10.8-2.fc28.i686.rpm 2.10.8 i686 Fedora Updates Testing
python3-abrt-2.10.8-2.fc28.x86_64.rpm 2.10.8 x86_64 Fedora Updates Testing
python3-abrt-2.10.8-2.fc28.x86_64.rpm 2.10.8 x86_64 Fedora
python3-abrt - - -

Requires

Name Value
abrt = 2.10.10-1.fc28
abrt-dbus = 2.10.10-1.fc28
abrt-libs = 2.10.10-1.fc28
libabrt.so.0 -
libc.so.6(GLIBC_2.4) -
libdl.so.2 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libm.so.6 -
libpthread.so.0 -
libpython3.6m.so.1.0 -
libreport.so.0 -
libsatyr.so.3 -
libutil.so.1 -
python(abi) = 3.6
python3-dbus -
python3-gobject-base -
python3-libreport -
rtld(GNU_HASH) -

Provides

Name Value
abrt-python3 = 2.10.10-1.fc28
abrt-python3(x86-32) = 2.10.10-1.fc28
python3-abrt = 2.10.10-1.fc28
python3-abrt(x86-32) = 2.10.10-1.fc28

Obsoletes

Name Value
abrt-python3 < 2.10.4

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package python3-abrt-2.10.10-1.fc28.i686.rpm
Source Package abrt-2.10.10-1.fc28.src.rpm

Install Howto

Install python3-abrt rpm package:

# dnf install python3-abrt

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/3a/9ee7b91fdedcec105900b82340ea846620f6cf
/usr/lib/python3.6/site-packages/problem/__init__.py
/usr/lib/python3.6/site-packages/problem/_py3abrt.so
/usr/lib/python3.6/site-packages/problem/config.py
/usr/lib/python3.6/site-packages/problem/exception.py
/usr/lib/python3.6/site-packages/problem/proxies.py
/usr/lib/python3.6/site-packages/problem/tools.py
/usr/lib/python3.6/site-packages/problem/watch.py
/usr/lib/python3.6/site-packages/problem/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/problem/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/problem/__pycache__/config.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/problem/__pycache__/config.cpython-36.pyc
/usr/lib/python3.6/site-packages/problem/__pycache__/exception.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/problem/__pycache__/exception.cpython-36.pyc
/usr/lib/python3.6/site-packages/problem/__pycache__/proxies.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/problem/__pycache__/proxies.cpython-36.pyc
/usr/lib/python3.6/site-packages/problem/__pycache__/tools.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/problem/__pycache__/tools.cpython-36.pyc
/usr/lib/python3.6/site-packages/problem/__pycache__/watch.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/problem/__pycache__/watch.cpython-36.pyc
/usr/share/man/man5/abrt-python3.5.gz

Changelog

2018-05-31 - Matej Marusak <mmarusak@redhat.com> 2.10.10-1
- Translation updates
- Changelog: Update changelog
- Remove dependency on deprecated nss-pem
- spec: abrt do not require python2
- spec: abrt-addon-ccpp do not require python2
- spec: drop python2-abrt-addon requires
- spec: fix bugs in python requires
- cores: comment an unclearing statement
- cores: print to stdout
- cores: read all journal files
2018-05-10 - Matej Habrnal <mhabrnal@redhat.com> 2.10.9-5
- abrt do not require python2 if "with python3"
2018-05-09 - Matej Habrnal <mhabrnal@redhat.com> 2.10.9-4
- abrt-addon-ccpp do not require python2 if "with python3"
2018-05-03 - Matej Habrnal <mhabrnal@redhat.com> 2.10.9-3
- drop python2-abrt-addon requires
2018-04-27 - Matej Habrnal <mhabrnal@redhat.com> 2.10.9-2
- fix requires for python in spec file
2018-04-27 - Matej Habrnal <mhabrnal@redhat.com> 2.10.9-1
- build: conditionalize the Python2 and Python3
- cli-ng,hooks,python-problem: Allow python to be optional at build time
- spec: fix ambiguous Python 2 dependency declarations
- plugins: a-a-g-machine-id use dmidecode command
- spec: use dmidecode instead of python3-dmidecode
- hooks: use container-exception-logger tool
- spec: container python hooks require cel
- hooks: do not write any additional logs
- a-a-s-package-data: add python3.7 to known Interpreters
- autogen: ignore abrt's python packages
- correctly parse buildrequires from spec file
2018-03-21 - Matej Habrnal <mhabrnal@redhat.com> 2.10.8-1
- Translation updates
- spec: use Python3 as default in abrt-cli-ng
- cli-ng: use Python3 as default
- Add a new element 'interpreter' for python problems
- retrace-client: Require nss-pem
2018-02-26 - Matej Habrnal <mhabrnal@redhat.com> 2.10.7-1
- Translation updates
- hooks: introduce docker hook for Python2
- hook: add type to Python3 container exception handler
- spec: introduce docker hook for Python2
- Add ABRT hexa stickers
- a-container-logger: workaround permission issue in minishift
2018-02-19 - Matej Habrnal <mhabrnal@redhat.com> 2.10.6-1
- Translation updates
- hooks: introduce docker hook for Python3
- spec: introduce Python3 hook for container
- Remove deprecated is_error macro
- ldconfig is not needed in rawhide
- remove python_sitearch macro
- remove python_site macro
- move BuildRequires to top
- remove systemd-units and replace it with systemd macro
- remove init.d services
- a-h-event: Do not deduplicate different containers
- rpm: include epocho in package element if > 0
2017-11-02 - Julius Milan <jmilan@redhat.com> 2.10.5-1
- Translation updates
- a-action-ureport: add option 'ProcessUnpackaged'
- spec: change dependency on python{2,3}-gobject
- applet: Additional changes to allow optional polkit
- doc: remove obsolete doxygen tags
- dbus: Additional changes to allow optional polkit
- cli-ng: Explicitly state python version in shebangs
- spec: rename python binary packages
- a-d-journal-core: Save mountinfo from journal
- a-d-journal-core: Save container cmdline
- logging: rename omitted log() to log_warning()

See Also

Package Description
python3-abrt-addon-2.10.10-1.fc28.i686.rpm abrt's addon for catching and analyzing Python 3 exceptions
python3-abrt-container-addon-2.10.10-1.fc28.i686.rpm abrt's container addon for catching Python 3 exceptions
python3-abrt-doc-2.10.10-1.fc28.noarch.rpm ABRT Python API Documentation
python3-acme-0.31.0-1.fc28.noarch.rpm Python library for the ACME protocol
python3-aexpect-1.5.1-1.fc28.noarch.rpm A python library to control interactive applications
python3-affine-2.2.2-2.fc28.noarch.rpm Matrices describing affine transformation of the plane
python3-afl-0.7-1.fc28.i686.rpm The python3 module that enables Afl fork server for Python code
python3-aiodns-1.1.1-2.fc28.noarch.rpm Simple DNS resolver for asyncio
python3-aiohttp-3.1.3-1.fc28.i686.rpm Python HTTP client/server for asyncio
python3-aiohttp-cors-0.7.0-1.fc28.noarch.rpm CORS (Cross Origin Resource Sharing) support for aiohttp
python3-alembic-1.0.8-1.fc28.noarch.rpm Database migration tool for SQLAlchemy
python3-animatplot-0.2.2-2.fc28.noarch.rpm Making animating in Matplotlib easy
python3-animatplot-doc-0.2.2-2.fc28.noarch.rpm Documentation for python3-animatplot
python3-ansible-review-0.13.7-3.fc28.noarch.rpm Reviews Ansible playbooks, roles and inventory and suggests improvements
python3-ansible-tower-cli-3.3.0-1.fc28.noarch.rpm A CLI tool for Ansible Tower
Advertisement
Advertisement