mariadb-embedded-devel-10.2.19-1.fc28.i686.rpm


Advertisement

Description

mariadb-embedded-devel - Development files for MariaDB as an embeddable library

Property Value
Distribution Fedora 28
Repository Fedora Updates x86_64
Package name mariadb-embedded-devel
Package version 10.2.19
Package release 1.fc28
Package architecture i686
Package type rpm
Installed size unknown
Download size 40.00 KB
Official Mirror dl.fedoraproject.org
MariaDB is a multi-user, multi-threaded SQL database server.
MariaDB is a community developed branch of MySQL.
This package contains files needed for developing and testing with
the embedded version of the MariaDB server.

Alternatives

Package Version Architecture Repository
mariadb-embedded-devel-10.2.19-2.fc28.i686.rpm 10.2.19 i686 Fedora Updates Testing
mariadb-embedded-devel-10.2.19-2.fc28.i686.rpm 10.2.19 i686 Fedora Updates Testing
mariadb-embedded-devel-10.2.19-2.fc28.x86_64.rpm 10.2.19 x86_64 Fedora Updates Testing
mariadb-embedded-devel-10.2.19-1.fc28.x86_64.rpm 10.2.19 x86_64 Fedora Updates
mariadb-embedded-devel-10.2.19-1.fc28.i686.rpm 10.2.19 i686 Fedora Updates
mariadb-embedded-devel-10.2.14-1.fc28.x86_64.rpm 10.2.14 x86_64 Fedora
mariadb-embedded-devel-10.2.14-1.fc28.i686.rpm 10.2.14 i686 Fedora
mariadb-embedded-devel-10.2.14-1.fc28.i686.rpm 10.2.14 i686 Fedora
mariadb-embedded-devel - - -

Requires

Name Value
libaio devel
libmysqld.so.19 -
mariadb-devel(x86-32) = 10.2.19-1.fc28
mariadb-embedded(x86-32) = 10.2.19-1.fc28

Provides

Name Value
mariadb-embedded-devel = 10.2.19-1.fc28
mariadb-embedded-devel(x86-32) = 10.2.19-1.fc28
mysql-embedded-devel = 10.2.19-1.fc28
mysql-embedded-devel(x86-32) = 10.2.19-1.fc28

Conflicts

Name Value
community-mysql-embedded devel

Obsoletes

Name Value
MySQL-embedded-devel < 5.5.30-5
mysql-embedded-devel < 5.6-0

Download

Type URL
Binary Package mariadb-embedded-devel-10.2.19-1.fc28.i686.rpm
Source Package mariadb-10.2.19-1.fc28.src.rpm

Install Howto

Install mariadb-embedded-devel rpm package:

# dnf install mariadb-embedded-devel

Files

Path
/usr/lib/libmysqld.so

Changelog

2018-11-14 - Michal Schorm <mschorm@redhat.com> - 3:10.2.19-1
- Rebase to 10.2.19
- CVEs fixed:
CVE-2018-3282 CVE-2016-9843 CVE-2018-3174 CVE-2018-3143 CVE-2018-3156
CVE-2018-3251 CVE-2018-3185 CVE-2018-3277 CVE-2018-3162 CVE-2018-3173
CVE-2018-3200 CVE-2018-3284
2018-10-19 - Michal Schorm <mschorm@redhat.com> - 3:10.2.18-2
- Fix parallel installability for x86_64 and i686 devel packages on F<=27
2018-09-26 - Michal Schorm <mschorm@redhat.com> - 3:10.2.18-1
- Rebase to 10.2.18
2018-09-04 - Michal Schorm <mschorm@redhat.com> - 3:10.2.17-2
- Fix parallel installability of x86_64 and i686 devel packages
2018-08-20 - Michal Schorm <mschorm@redhat.com> - 3:10.2.17-1
- Rebase to 10.2.17
- CVEs fixed: #1602428
CVE-2018-3060 CVE-2018-3064 CVE-2018-3063 CVE-2018-3058 CVE-2018-3066
- CVEs fixed: #1564966
CVE-2018-2767
- CVEs fixed: #1616261
CVE-2018-3081
2018-06-30 - Michal Schorm <mschorm@redhat.com> - 3:10.2.16-1
- Rebase to 10.2.16
MyRocks is now Stable (GA)
2018-06-05 - Honza Horak <hhorak@redhat.com> - 3:10.2.15-2
- Use mysqladmin for checking the socket
- Jemalloc dependency moved to the TokuDB subpackage.
CMake jemalloc option removed, not used anymore.
The server doesn't need jemalloc since 10.2: https://jira.mariadb.org/browse/MDEV-11059
- Build MariaDB with TokuDB without Jemalloc.
2018-05-23 - Michal Schorm <mschorm@redhat.com> - 3:10.2.15-1
- Rebase to 10.2.15
- CVEs fixed: #1568962
CVE-2018-2755 CVE-2018-2761 CVE-2018-2766 CVE-2018-2771 CVE-2018-2781
CVE-2018-2782 CVE-2018-2784 CVE-2018-2787 CVE-2018-2813 CVE-2018-2817
CVE-2018-2819 CVE-2018-2786 CVE-2018-2759 CVE-2018-2777 CVE-2018-2810
2018-03-29 - Michal Schorm <mschorm@redhat.com> - 3:10.2.14-1
- Rebase to 10.2.14
- Update testsuite run for SSL self signed certificates
2018-03-06 - Michal Schorm <mschorm@redhat.com> - 3:10.2.13-2
- Further fix of ldconfig scriptlets for F27
- Fix hardcoded paths, move unversioned libraries and symlinks to the devel subpackage

See Also

Package Description
mariadb-errmsg-10.2.19-1.fc28.i686.rpm The error messages files required by server and embedded
mariadb-errmsg-10.2.19-1.fc28.x86_64.rpm The error messages files required by server and embedded
mariadb-gssapi-server-10.2.19-1.fc28.x86_64.rpm GSSAPI authentication plugin for server
mariadb-java-client-2.3.0-1.fc28.noarch.rpm Connects applications developed in Java to MariaDB and MySQL databases
mariadb-java-client-javadoc-2.3.0-1.fc28.noarch.rpm Javadoc for mariadb-java-client
mariadb-java-client-tests-2.3.0-1.fc28.noarch.rpm Tests for mariadb-java-client
mariadb-oqgraph-engine-10.2.19-1.fc28.x86_64.rpm The Open Query GRAPH engine for MariaDB
mariadb-rocksdb-engine-10.2.19-1.fc28.x86_64.rpm The RocksDB storage engine for MariaDB
mariadb-server-10.2.19-1.fc28.x86_64.rpm The MariaDB server and related files
mariadb-server-galera-10.2.19-1.fc28.x86_64.rpm The configuration files and scripts for galera replication
mariadb-server-utils-10.2.19-1.fc28.x86_64.rpm Non-essential server utilities for MariaDB/MySQL applications
mariadb-sphinx-engine-10.2.19-1.fc28.x86_64.rpm The Sphinx storage engine for MariaDB
mariadb-test-10.2.19-1.fc28.x86_64.rpm The test suite distributed with MariaDB
mariadb-tokudb-engine-10.2.19-1.fc28.x86_64.rpm The TokuDB storage engine for MariaDB
mate-applets-1.20.2-1.fc28.x86_64.rpm MATE Desktop panel applets
Advertisement
Advertisement