php-doctrine-datafixtures-1.3.1-1.fc28.remi.noarch.rpm


Advertisement

Description

php-doctrine-datafixtures - Data Fixtures for all Doctrine Object Managers

Property Value
Distribution Fedora 28
Repository Les RPM de Remi x86_64
Package name php-doctrine-datafixtures
Package version 1.3.1
Package release 1.fc28.remi
Package architecture noarch
Package type rpm
Installed size 76.27 KB
Download size 30.30 KB
Official Mirror rpms.remirepo.net
This extension aims to provide a simple way to manage and execute the loading
of data fixtures for the Doctrine ORM or ODM.
Autoloader: /usr/share/php/Doctrine/Common/DataFixtures/autoload.php

Alternatives

Package Version Architecture Repository
php-doctrine-datafixtures-1.3.1-1.fc28.remi.noarch.rpm 1.3.1 noarch Les RPM de Remi
php-doctrine-datafixtures-1.0.2-7.fc28.noarch.rpm 1.0.2 noarch Fedora
php-doctrine-datafixtures-1.0.2-7.fc28.noarch.rpm 1.0.2 noarch Fedora
php-doctrine-datafixtures - - -

Requires

Name Value
(php-composer(doctrine/common) >= 2.5 with php-composer(doctrine/common) < 3.0)
php(language) >= 7.1
php-composer(fedora/autoloader) -
php-json -
php-reflection -
php-spl -

Provides

Name Value
php-composer(doctrine/data-fixtures) = 1.3.1
php-doctrine-data-fixtures = 1.3.1-1.fc28.remi
php-doctrine-datafixtures = 1.3.1-1.fc28.remi

Download

Type URL
Binary Package php-doctrine-datafixtures-1.3.1-1.fc28.remi.noarch.rpm
Source Package php-doctrine-datafixtures-1.3.1-1.fc28.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/fedora/28/remi/x86_64/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-doctrine-datafixtures rpm package:
    # dnf --enablerepo=remi install php-doctrine-datafixtures

Files

Path
/usr/share/doc/php-doctrine-datafixtures/CHANGELOG.md
/usr/share/doc/php-doctrine-datafixtures/README.md
/usr/share/doc/php-doctrine-datafixtures/UPGRADE
/usr/share/doc/php-doctrine-datafixtures/composer.json
/usr/share/licenses/php-doctrine-datafixtures/LICENSE
/usr/share/php/Doctrine/Common/DataFixtures/AbstractFixture.php
/usr/share/php/Doctrine/Common/DataFixtures/DependentFixtureInterface.php
/usr/share/php/Doctrine/Common/DataFixtures/FixtureInterface.php
/usr/share/php/Doctrine/Common/DataFixtures/Loader.php
/usr/share/php/Doctrine/Common/DataFixtures/OrderedFixtureInterface.php
/usr/share/php/Doctrine/Common/DataFixtures/ProxyReferenceRepository.php
/usr/share/php/Doctrine/Common/DataFixtures/ReferenceRepository.php
/usr/share/php/Doctrine/Common/DataFixtures/SharedFixtureInterface.php
/usr/share/php/Doctrine/Common/DataFixtures/autoload.php
/usr/share/php/Doctrine/Common/DataFixtures/Event/
/usr/share/php/Doctrine/Common/DataFixtures/Event/Listener/MongoDBReferenceListener.php
/usr/share/php/Doctrine/Common/DataFixtures/Event/Listener/ORMReferenceListener.php
/usr/share/php/Doctrine/Common/DataFixtures/Exception/CircularReferenceException.php
/usr/share/php/Doctrine/Common/DataFixtures/Executor/AbstractExecutor.php
/usr/share/php/Doctrine/Common/DataFixtures/Executor/MongoDBExecutor.php
/usr/share/php/Doctrine/Common/DataFixtures/Executor/ORMExecutor.php
/usr/share/php/Doctrine/Common/DataFixtures/Executor/PHPCRExecutor.php
/usr/share/php/Doctrine/Common/DataFixtures/Purger/MongoDBPurger.php
/usr/share/php/Doctrine/Common/DataFixtures/Purger/ORMPurger.php
/usr/share/php/Doctrine/Common/DataFixtures/Purger/PHPCRPurger.php
/usr/share/php/Doctrine/Common/DataFixtures/Purger/PurgerInterface.php
/usr/share/php/Doctrine/Common/DataFixtures/Sorter/TopologicalSorter.php
/usr/share/php/Doctrine/Common/DataFixtures/Sorter/Vertex.php

Changelog

2018-10-17 - Remi Collet <remi@remirepo.net> - 1.3.1-1
- update to 1.3.1
- raise dependencies on PHP 7.1
- use range dependencies
- doctrine/orm is optional
- add optional dependency on alcaeus/mongo-php-adapter
2017-05-12 - Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0.2-5
- Switch autoloader to php-composer(fedora/autoloader)
- Add max versions to build dependencies
- Test with SCLs if available
2016-07-31 - Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0.2-1
- Updated/fixed php-composer(doctrine/*) dependencies min version for autoloaders
- Modified autoloader

See Also

Package Description
php-doctrine-dbal-2.9.0-1.fc28.remi.noarch.rpm Doctrine Database Abstraction Layer (DBAL)
php-doctrine-dbal-2.9.1-1.fc28.remi.noarch.rpm Doctrine Database Abstraction Layer (DBAL)
php-doctrine-doctrine-bundle-1.9.1-1.fc28.remi.noarch.rpm Symfony Bundle for Doctrine
php-doctrine-doctrine-cache-bundle-1.3.4-1.fc28.remi.noarch.rpm Symfony2 Bundle for Doctrine Cache
php-doctrine-doctrine-cache-bundle-1.3.5-1.fc28.remi.noarch.rpm Symfony2 Bundle for Doctrine Cache
php-doctrine-event-manager-1.0.0-1.fc28.remi.noarch.rpm Simple PHP event system
php-doctrine-event-manager-1.0.0-2.fc28.remi.noarch.rpm Simple PHP event system
php-doctrine-inflector-1.3.0-1.fc28.remi.noarch.rpm Common string manipulations with regard to casing and singular/plural rules
php-doctrine-instantiator-1.1.0-3.fc28.remi.noarch.rpm Instantiate objects in PHP without invoking their constructors
php-doctrine-orm-2.6.2-1.fc28.remi.noarch.rpm Doctrine Object-Relational-Mapper (ORM)
php-doctrine-orm-2.6.3-1.fc28.remi.noarch.rpm Doctrine Object-Relational-Mapper (ORM)
php-doctrine-persistence-1.0.1-1.fc28.remi.noarch.rpm Doctrine Persistence abstractions
php-doctrine-persistence-1.1.0-1.fc28.remi.noarch.rpm Doctrine Persistence abstractions
php-doctrine-reflection-1.0.0-1.fc28.remi.noarch.rpm Additional reflection functionality
php-doctrine-reflection-1.0.0-2.fc28.remi.noarch.rpm Additional reflection functionality
Advertisement
Advertisement