php-theseer-autoload-1.25.0-3.fc28.remi.noarch.rpm


Advertisement

Description

php-theseer-autoload - A tool and library to generate autoload code

Property Value
Distribution Fedora 28
Repository Les RPM de Remi x86_64
Package name php-theseer-autoload
Package version 1.25.0
Package release 3.fc28.remi
Package architecture noarch
Package type rpm
Installed size 133.29 KB
Download size 36.71 KB
Official Mirror rpms.remirepo.net
The PHP AutoloadBuilder CLI tool phpab is a command line application
to automate the process of generating an autoload require file with
the option of creating static require lists as well as phar archives.

Alternatives

Package Version Architecture Repository
php-theseer-autoload-1.25.1-1.fc28.remi.noarch.rpm 1.25.1 noarch Les RPM de Remi
php-theseer-autoload-1.25.1-1.fc28.remi.noarch.rpm 1.25.1 noarch Les RPM de Remi
php-theseer-autoload-1.25.0-3.fc28.remi.noarch.rpm 1.25.0 noarch Les RPM de Remi
php-theseer-autoload-1.25.0-1.fc28.noarch.rpm 1.25.0 noarch Fedora Updates
php-theseer-autoload-1.25.0-1.fc28.noarch.rpm 1.25.0 noarch Fedora Updates
php-theseer-autoload-1.24.1-3.fc28.noarch.rpm 1.24.1 noarch Fedora
php-theseer-autoload-1.24.1-3.fc28.noarch.rpm 1.24.1 noarch Fedora
php-theseer-autoload - - -

Requires

Name Value
(php-composer(theseer/directoryscanner) >= 1.3 with php-composer(theseer/directoryscanner) < 2)
(php-composer(zetacomponents/console-tools) >= 1.7 with php-composer(zetacomponents/console-tools) < 2)
/usr/bin/env -
php(language) >= 5.3.1
php-cli -
php-date -
php-json -
php-openssl -
php-phar -
php-spl -
php-tokenizer -

Provides

Name Value
php-composer(theseer/autoload) = 1.25.0
php-pear(pear.netpirates.net/Autoload) = 1.25.0
php-theseer-autoload = 1.25.0-3.fc28.remi

Download

Type URL
Binary Package php-theseer-autoload-1.25.0-3.fc28.remi.noarch.rpm
Source Package php-theseer-autoload-1.25.0-3.fc28.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/fedora/28/remi/x86_64/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-theseer-autoload rpm package:
    # dnf --enablerepo=remi install php-theseer-autoload

Files

Path
/usr/bin/phpab
/usr/share/doc/php-theseer-autoload/README.md
/usr/share/doc/php-theseer-autoload/composer.json
/usr/share/licenses/php-theseer-autoload/LICENSE
/usr/share/php/TheSeer/Autoload/Application.php
/usr/share/php/TheSeer/Autoload/AutoloadRenderer.php
/usr/share/php/TheSeer/Autoload/CLI.php
/usr/share/php/TheSeer/Autoload/Cache.php
/usr/share/php/TheSeer/Autoload/CacheEntry.php
/usr/share/php/TheSeer/Autoload/CacheWarmingListRenderer.php
/usr/share/php/TheSeer/Autoload/CachingParser.php
/usr/share/php/TheSeer/Autoload/Collector.php
/usr/share/php/TheSeer/Autoload/CollectorResult.php
/usr/share/php/TheSeer/Autoload/ComposerIterator.php
/usr/share/php/TheSeer/Autoload/Config.php
/usr/share/php/TheSeer/Autoload/DependencySorter.php
/usr/share/php/TheSeer/Autoload/Factory.php
/usr/share/php/TheSeer/Autoload/Logger.php
/usr/share/php/TheSeer/Autoload/ParseResult.php
/usr/share/php/TheSeer/Autoload/Parser.php
/usr/share/php/TheSeer/Autoload/ParserInterface.php
/usr/share/php/TheSeer/Autoload/PathComparator.php
/usr/share/php/TheSeer/Autoload/PharBuilder.php
/usr/share/php/TheSeer/Autoload/SourceFile.php
/usr/share/php/TheSeer/Autoload/StaticListRenderer.php
/usr/share/php/TheSeer/Autoload/StaticRenderer.php
/usr/share/php/TheSeer/Autoload/StaticRequireListRenderer.php
/usr/share/php/TheSeer/Autoload/Version.php
/usr/share/php/TheSeer/Autoload/autoload.php
/usr/share/php/TheSeer/Autoload/templates/static.php.tpl
/usr/share/php/TheSeer/Autoload/templates/staticphar.php.tpl
/usr/share/php/TheSeer/Autoload/templates/ci/default.php.tpl
/usr/share/php/TheSeer/Autoload/templates/ci/phar.php.tpl
/usr/share/php/TheSeer/Autoload/templates/ci/php52.php.tpl
/usr/share/php/TheSeer/Autoload/templates/cs/default.php.tpl
/usr/share/php/TheSeer/Autoload/templates/cs/phar.php.tpl
/usr/share/php/TheSeer/Autoload/templates/cs/php52.php.tpl

Changelog

2018-10-15 - Remi Collet <remi@remirepo.net> - 1.25.0-3
- add upstream patch for PHP 7.3
2018-07-02 - Remi Collet <remi@remirepo.net> - 1.25.0-1
- update to 1.25.0
- use range dependencies
2017-06-26 - Remi Collet <remi@remirepo.net> - 1.24.1-1
- Update to 1.24.1
- drop patch merged upstream

See Also

Package Description
php-tidy-7.2.11-1.fc28.remi.x86_64.rpm Standard PHP module provides tidy library support
php-tidy-7.2.12-1.fc28.remi.x86_64.rpm Standard PHP module provides tidy library support
php-twig-1.35.3-1.fc28.remi.7.2.noarch.rpm The flexible, fast, and secure template engine for PHP
php-twig-1.35.4-1.fc28.remi.7.2.noarch.rpm The flexible, fast, and secure template engine for PHP
php-twig-extensions-1.5.2-1.fc28.remi.noarch.rpm Twig extensions
php-twig2-2.4.8-1.fc28.remi.noarch.rpm The flexible, fast, and secure template engine for PHP
php-twig2-2.5.0-1.fc28.remi.noarch.rpm The flexible, fast, and secure template engine for PHP
php-webmozart-assert-1.3.0-1.fc28.remi.noarch.rpm Assertions to validate method input/output with nice error messages
php-webmozart-assert-1.3.0-3.fc28.remi.noarch.rpm Assertions to validate method input/output with nice error messages
php-wkhtmltox-0.3.2-0.2.20171112.fecc9af.fc28.remi.7.2.x86_64.rpm HTML Converter
php-xml-7.2.11-1.fc28.remi.x86_64.rpm A module for PHP applications which use XML
php-xml-7.2.12-1.fc28.remi.x86_64.rpm A module for PHP applications which use XML
php-xmlrpc-7.2.11-1.fc28.remi.x86_64.rpm A module for PHP applications which use the XML-RPC protocol
php-xmlrpc-7.2.12-1.fc28.remi.x86_64.rpm A module for PHP applications which use the XML-RPC protocol
php-zendframework-zend-authentication-2.6.0-2.fc28.remi.noarch.rpm Zend Framework Authentication component
Advertisement
Advertisement