kodi-devel-17.6-9.fc28.i686.rpm


Advertisement

Description

kodi-devel - Development files needed to compile C programs against kodi

Property Value
Distribution Fedora 28
Repository RPM Fusion Free Updates i386
Package name kodi-devel
Package version 17.6
Package release 9.fc28
Package architecture i686
Package type rpm
Installed size 361.55 KB
Download size 73.56 KB
Official Mirror download1.rpmfusion.org
Kodi is a free cross-platform media-player jukebox and entertainment hub.
If you want to develop programs which use Kodi's libraries, you need to
install this package.

Alternatives

Package Version Architecture Repository
kodi-devel-17.6-9.fc28.x86_64.rpm 17.6 x86_64 RPM Fusion Free Updates
kodi-devel-17.6-9.fc28.i686.rpm 17.6 i686 RPM Fusion Free Updates
kodi-devel-17.6-8.fc28.x86_64.rpm 17.6 x86_64 RPM Fusion Free
kodi-devel-17.6-8.fc28.i686.rpm 17.6 i686 RPM Fusion Free
kodi-devel-17.6-8.fc28.i686.rpm 17.6 i686 RPM Fusion Free
kodi-devel - - -

Requires

Name Value
kodi(x86-32) = 17.6-9.fc28

Provides

Name Value
kodi-devel = 17.6-9.fc28
kodi-devel(x86-32) = 17.6-9.fc28
xbmc-devel = 17.6

Obsoletes

Name Value
xbmc-devel < 14.0

Download

Type URL
Binary Package kodi-devel-17.6-9.fc28.i686.rpm
Source Package kodi-17.6-9.fc28.src.rpm

Install Howto

  1. Download latest rpmfusion-free-release-stable rpm from
    http://download1.rpmfusion.org/free/fedora/
  2. Install rpmfusion-free-release-stable rpm:
    # rpm -Uvh rpmfusion-free-release-stable*rpm
  3. Install kodi-devel rpm package:
    # dnf install kodi-devel

Files

Path
/usr/include/xbmc
/usr/include/kodi/AEChannelData.h
/usr/include/kodi/DVDDemuxPacket.h
/usr/include/kodi/IFileTypes.h
/usr/include/kodi/kodi_adsp_dll.h
/usr/include/kodi/kodi_adsp_types.h
/usr/include/kodi/kodi_audiodec_dll.h
/usr/include/kodi/kodi_audiodec_types.h
/usr/include/kodi/kodi_audioengine_types.h
/usr/include/kodi/kodi_inputstream_dll.h
/usr/include/kodi/kodi_inputstream_types.h
/usr/include/kodi/kodi_peripheral_callbacks.h
/usr/include/kodi/kodi_peripheral_dll.h
/usr/include/kodi/kodi_peripheral_types.h
/usr/include/kodi/kodi_peripheral_utils.hpp
/usr/include/kodi/kodi_vfs_types.h
/usr/include/kodi/kodi_vfs_utils.hpp
/usr/include/kodi/libKODI_adsp.h
/usr/include/kodi/libKODI_audioengine.h
/usr/include/kodi/libKODI_guilib.h
/usr/include/kodi/libKODI_inputstream.h
/usr/include/kodi/libKODI_peripheral.h
/usr/include/kodi/libXBMC_addon.h
/usr/include/kodi/libXBMC_codec.h
/usr/include/kodi/libXBMC_pvr.h
/usr/include/kodi/xbmc_addon_cpp_dll.h
/usr/include/kodi/xbmc_addon_dll.h
/usr/include/kodi/xbmc_addon_types.h
/usr/include/kodi/xbmc_audioenc_dll.h
/usr/include/kodi/xbmc_audioenc_types.h
/usr/include/kodi/xbmc_codec_types.h
/usr/include/kodi/xbmc_epg_types.h
/usr/include/kodi/xbmc_pvr_dll.h
/usr/include/kodi/xbmc_pvr_types.h
/usr/include/kodi/xbmc_scr_dll.h
/usr/include/kodi/xbmc_scr_types.h
/usr/include/kodi/xbmc_vis_dll.h
/usr/include/kodi/xbmc_vis_types.h
/usr/include/kodi/xbmcclient.h

Changelog

See kodi-17.6-9.fc28.i686.rpm changelog.

See Also

Package Description
kodi-eventclients-17.6-9.fc28.i686.rpm Media center event client remotes
kodi-eventclients-devel-17.6-9.fc28.i686.rpm Media center event client remotes development files
kodi-inputstream-adaptive-2.0.20-0.1.20180329gitc51b9a9.fc28.i686.rpm Adaptive file addon for Kodi's InputStream interface
kodi-visualization-spectrum-1.1.4-1.fc28.i686.rpm Spectrum visualizer for Kodi
libavdevice-4.0.3-1.fc28.i686.rpm Special devices muxing/demuxing library
libdca-0.0.6-1.fc28.i686.rpm DTS Coherent Acoustics decoder library
libdca-devel-0.0.6-1.fc28.i686.rpm Development files for libdca
libdca-tools-0.0.6-1.fc28.i686.rpm Various tools for use with libdca
libheif-1.3.2-1.fc28.i686.rpm HEIF file format decoder and encoder
libheif-devel-1.3.2-1.fc28.i686.rpm Development files for libheif
libmpeg2-0.5.1-15.fc28.i686.rpm MPEG-2 decoder libraries
libmpeg2-devel-0.5.1-15.fc28.i686.rpm Development files for libmpeg2
libopenshot-0.2.2-1.fc28.i686.rpm Library for creating and editing videos
libopenshot-audio-0.1.7-2.fc28.i686.rpm Audio library used by OpenShot
libopenshot-audio-devel-0.1.7-2.fc28.i686.rpm Development files for libopenshot-audio
Advertisement
Advertisement