PackageKit-glib-devel-1.1.11-1.fc29.i686.rpm


Advertisement

Description

PackageKit-glib-devel - GLib Libraries and headers for PackageKit

Property Value
Distribution Fedora 29
Repository Fedora i386
Package filename PackageKit-glib-devel-1.1.11-1.fc29.i686.rpm
Package name PackageKit-glib-devel
Package version 1.1.11
Package release 1.fc29
Package architecture i686
Package type rpm
Homepage http://www.freedesktop.org/software/PackageKit/
License GPLv2+ and LGPLv2+
Maintainer -
Download size 450.01 KB
Installed size 3.28 MB
GLib headers and libraries for PackageKit.

Alternatives

Package Version Architecture Repository
PackageKit-glib-devel-1.1.12-2.fc29.i686.rpm 1.1.12 i686 Fedora Updates
PackageKit-glib-devel-1.1.12-2.fc29.i686.rpm 1.1.12 i686 Fedora Updates
PackageKit-glib-devel-1.1.12-2.fc29.x86_64.rpm 1.1.12 x86_64 Fedora Updates
PackageKit-glib-devel-1.1.11-1.fc29.i686.rpm 1.1.11 i686 Fedora
PackageKit-glib-devel-1.1.11-1.fc29.x86_64.rpm 1.1.11 x86_64 Fedora
PackageKit-glib-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
PackageKit-glib(x86-32) = 1.1.11-1.fc29
dbus-devel(x86-32) >= 1.1.1
libpackagekit-glib2.so.18 -
pkgconfig(glib-2.0) -
pkgconfig(gobject-2.0) -
pkgconfig(gthread-2.0) -
pkgconfig(sqlite3) -
sqlite-devel(x86-32) -

Provides

Name Value
PackageKit-devel = 1.1.11-1.fc29
PackageKit-docs = 1.1.11-1.fc29
PackageKit-glib-devel = 1.1.11-1.fc29
PackageKit-glib-devel(x86-32) = 1.1.11-1.fc29
pkgconfig(packagekit-glib2) = 1.1.11

Obsoletes

Name Value
PackageKit-devel < 1.1.11-1.fc29
PackageKit-docs < 1.1.11-1.fc29

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package PackageKit-glib-devel-1.1.11-1.fc29.i686.rpm
Source Package PackageKit-1.1.11-1.fc29.src.rpm

Install Howto

Install PackageKit-glib-devel rpm package:

# dnf install PackageKit-glib-devel

Files

Path
/usr/include/PackageKit/
/usr/include/PackageKit/packagekit-glib2/packagekit.h
/usr/include/PackageKit/packagekit-glib2/pk-bitfield.h
/usr/include/PackageKit/packagekit-glib2/pk-category.h
/usr/include/PackageKit/packagekit-glib2/pk-client-helper.h
/usr/include/PackageKit/packagekit-glib2/pk-client-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-client.h
/usr/include/PackageKit/packagekit-glib2/pk-common.h
/usr/include/PackageKit/packagekit-glib2/pk-control-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-control.h
/usr/include/PackageKit/packagekit-glib2/pk-desktop.h
/usr/include/PackageKit/packagekit-glib2/pk-details.h
/usr/include/PackageKit/packagekit-glib2/pk-distro-upgrade.h
/usr/include/PackageKit/packagekit-glib2/pk-enum-types.h
/usr/include/PackageKit/packagekit-glib2/pk-enum.h
/usr/include/PackageKit/packagekit-glib2/pk-error.h
/usr/include/PackageKit/packagekit-glib2/pk-eula-required.h
/usr/include/PackageKit/packagekit-glib2/pk-files.h
/usr/include/PackageKit/packagekit-glib2/pk-item-progress.h
/usr/include/PackageKit/packagekit-glib2/pk-media-change-required.h
/usr/include/PackageKit/packagekit-glib2/pk-offline.h
/usr/include/PackageKit/packagekit-glib2/pk-package-id.h
/usr/include/PackageKit/packagekit-glib2/pk-package-ids.h
/usr/include/PackageKit/packagekit-glib2/pk-package-sack-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-package-sack.h
/usr/include/PackageKit/packagekit-glib2/pk-package.h
/usr/include/PackageKit/packagekit-glib2/pk-progress.h
/usr/include/PackageKit/packagekit-glib2/pk-repo-detail.h
/usr/include/PackageKit/packagekit-glib2/pk-repo-signature-required.h
/usr/include/PackageKit/packagekit-glib2/pk-require-restart.h
/usr/include/PackageKit/packagekit-glib2/pk-results.h
/usr/include/PackageKit/packagekit-glib2/pk-source.h
/usr/include/PackageKit/packagekit-glib2/pk-task-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-task.h
/usr/include/PackageKit/packagekit-glib2/pk-transaction-list.h
/usr/include/PackageKit/packagekit-glib2/pk-transaction-past.h
/usr/include/PackageKit/packagekit-glib2/pk-update-detail.h
/usr/include/PackageKit/packagekit-glib2/pk-version.h
/usr/lib/libpackagekit-glib2.so
/usr/lib/pkgconfig/packagekit-glib2.pc
/usr/share/gir-1.0/PackageKitGlib-1.0.gir
/usr/share/gtk-doc/html/PackageKit/PackageKit-Common-functions.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-Enumerations.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-Offline-Updates.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PackageIDs.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkBitfield.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkCategory.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkClient.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkClientHelper.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkControl.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkDesktop.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkDetails.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkDistroUpgrade.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkError.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkEulaRequired.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkFiles.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkItemProgress.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkMediaChangeRequired.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkPackage.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkPackageSack.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkProgress.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkRepoDetail.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkRepoSignatureRequired.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkRequireRestart.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkResults.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkSource.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkTask.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkTransactionList.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkTransactionPast.html
/usr/share/gtk-doc/html/PackageKit/PackageKit-PkUpdateDetail.html
/usr/share/gtk-doc/html/PackageKit/PackageKit.devhelp2
/usr/share/gtk-doc/html/PackageKit/PackageKit.html
/usr/share/gtk-doc/html/PackageKit/Transaction.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-5-0.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-5-2.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-5-3.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-5-4.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-5-5.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-6-0.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-6-1.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-6-10.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-6-11.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-6-13.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-6-2.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-6-3.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-6-4.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-6-5.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-7-2.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-7-5.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-8-0.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-8-1.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-8-11.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-8-12.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-8-14.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-8-16.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-8-17.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-8-2.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-8-6.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-8-8.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-9-1.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-9-5.html
/usr/share/gtk-doc/html/PackageKit/api-index-0-9-6.html
/usr/share/gtk-doc/html/PackageKit/api-index-1-0-10.html
/usr/share/gtk-doc/html/PackageKit/api-index-1-0-12.html
/usr/share/gtk-doc/html/PackageKit/api-index-1-0-2.html
/usr/share/gtk-doc/html/PackageKit/api-index-1-1-2.html
/usr/share/gtk-doc/html/PackageKit/api-index-1-1-8.html
/usr/share/gtk-doc/html/PackageKit/api-reference.html
/usr/share/gtk-doc/html/PackageKit/backend-compiled.html
/usr/share/gtk-doc/html/PackageKit/backend-spawn.html
/usr/share/gtk-doc/html/PackageKit/concepts.html
/usr/share/gtk-doc/html/PackageKit/home.png
/usr/share/gtk-doc/html/PackageKit/index.html
/usr/share/gtk-doc/html/PackageKit/introduction-backends.html
/usr/share/gtk-doc/html/PackageKit/introduction-cancellation.html
/usr/share/gtk-doc/html/PackageKit/introduction-errors.html
/usr/share/gtk-doc/html/PackageKit/introduction-group-type.html
/usr/share/gtk-doc/html/PackageKit/introduction-ideas-filters.html
/usr/share/gtk-doc/html/PackageKit/introduction-ideas-status.html
/usr/share/gtk-doc/html/PackageKit/introduction-ideas-transactionid.html
/usr/share/gtk-doc/html/PackageKit/introduction-ideas-transactions.html
/usr/share/gtk-doc/html/PackageKit/introduction.html
/usr/share/gtk-doc/html/PackageKit/left-insensitive.png
/usr/share/gtk-doc/html/PackageKit/left.png
/usr/share/gtk-doc/html/PackageKit/lpackagekit-glib2.html
/usr/share/gtk-doc/html/PackageKit/pk-structure.png
/usr/share/gtk-doc/html/PackageKit/pk-structure.svg
/usr/share/gtk-doc/html/PackageKit/pk-transactions-auto-untrusted.png
/usr/share/gtk-doc/html/PackageKit/pk-transactions-download.png
/usr/share/gtk-doc/html/PackageKit/pk-transactions-failure.png
/usr/share/gtk-doc/html/PackageKit/pk-transactions-repair-required.png
/usr/share/gtk-doc/html/PackageKit/pk-transactions-set-locale.png
/usr/share/gtk-doc/html/PackageKit/pk-transactions-sig-install.png
/usr/share/gtk-doc/html/PackageKit/pk-transactions-success.png
/usr/share/gtk-doc/html/PackageKit/pk-transactions-trusted.png
/usr/share/gtk-doc/html/PackageKit/pk-transactions.svg
/usr/share/gtk-doc/html/PackageKit/right-insensitive.png
/usr/share/gtk-doc/html/PackageKit/right.png
/usr/share/gtk-doc/html/PackageKit/specification.html
/usr/share/gtk-doc/html/PackageKit/style.css
/usr/share/gtk-doc/html/PackageKit/up-insensitive.png
/usr/share/gtk-doc/html/PackageKit/up.png
/usr/share/vala/vapi/packagekit-glib2.vapi

Changelog

2018-09-25 - Richard Hughes <rhughes@redhat.com> - 1.1.11-1
- New upstream release
- Add --autoremove option to pkcon
- De-register callbacks on PkClientHelper finalize
- Don't complain if command-not-found get uninstalled while running
- Never assert when an interactive TTY is not available
- Shut down services cleanly before rebooting after offline updates
- Shutdown the daemon on idle by default
2018-09-22 - Adam Williamson <awilliam@redhat.com> - 1.1.10-5
- Backport several more fixes from master for libdnf compat
2018-07-24 - Stephen Gallagher <sgallagh@redhat.com> - 1.1.10-4
- Add patch to support modularity
2018-07-12 - Fedora Release Engineering <releng@fedoraproject.org> - 1.1.10-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-06-26 - Adam Williamson <awilliam@redhat.com> - 1.1.10-2
- Rebuild for new libdnf
2018-04-23 - Richard Hughes <rhughes@redhat.com> - 1.1.10-1
- New upstream release
- This release fixes CVE-2018-1106 which is a moderate security issue.
2018-03-27 - Kalev Lember <klember@redhat.com> - 1.1.9-4
- Remove ldconfig scriptlets
2018-03-22 - Kalev Lember <klember@redhat.com> - 1.1.9-3
- Create /var/cache/app-info/{icons,xmls} directories
2018-03-12 - Kalev Lember <klember@redhat.com> - 1.1.9-2
- Don't abort on daemon startup for invalid .repo files
2018-03-05 - Kalev Lember <klember@redhat.com> - 1.1.9-1
- Update to 1.1.9

See Also

Package Description
PackageKit-gstreamer-plugin-1.1.11-1.fc29.i686.rpm Install GStreamer codecs using PackageKit
PackageKit-gtk3-module-1.1.11-1.fc29.i686.rpm Install fonts automatically using PackageKit
Panini-0.72.0-2.fc29.i686.rpm A tool for creating perspective views from panoramic and wide angle images
PerceptualDiff-1.1.1-22.fc29.i686.rpm An image comparison utility
Perlbal-1.80-33.fc29.noarch.rpm Reverse-proxy load balance and web-server
PersonalCopy-Lite-soundfont-4.1-18.fc29.noarch.rpm Lite version of the PersonalCopy General Midi soundfont
PolicyKit-olpc-1.7-10.fc29.noarch.rpm OLPC-specific PolicyKit overrides
Pound-2.7-3.fc24.i686.rpm Reverse proxy and load balancer
PyMca-4.7.3-8.fc26.i686.rpm PyMca X-ray Fluorescence Toolkit
PyMca-data-4.7.3-8.fc26.noarch.rpm Data files for PyMca
PyMunin-0.9.27-11.fc29.noarch.rpm Python Module for developing Munin Multigraph Monitoring Plugins
PyPE-2.9.4-11.fc28.noarch.rpm Lightweight but powerful graphical editor for developers
PyQt4-4.12.1-10.fc29.i686.rpm Python bindings for Qt4
PyQt4-assistant-4.12.1-10.fc29.i686.rpm Python bindings for QtAssistant
PyQt4-devel-4.12.1-10.fc29.i686.rpm Files needed to build other bindings based on Qt4
Advertisement
Advertisement