compat-libf2c-34-3.4.6-46.fc28.i686.rpm


Advertisement

Description

compat-libf2c-34 - Fortran 77 compatibility runtime

Property Value
Distribution Fedora 29
Repository Fedora i386
Package filename compat-libf2c-34-3.4.6-46.fc28.i686.rpm
Package name compat-libf2c-34
Package version 3.4.6
Package release 46.fc28
Package architecture i686
Package type rpm
Category System Environment/Libraries
Homepage http://gcc.gnu.org
License GPLv2+ and GPLv2+ with exceptions
Maintainer -
Download size 61.17 KB
Installed size 110.97 KB
This package contains Fortran 77 shared library which is needed to run
Fortran 77 dynamically linked programs.

Alternatives

Package Version Architecture Repository
compat-libf2c-34-3.4.6-46.fc28.i686.rpm 3.4.6 i686 Fedora
compat-libf2c-34-3.4.6-46.fc28.x86_64.rpm 3.4.6 x86_64 Fedora
compat-libf2c-34 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.3) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -

Provides

Name Value
compat-libf2c-34 = 3.4.6-46.fc28
compat-libf2c-34(x86-32) = 3.4.6-46.fc28
libg2c.so.0 -

Obsoletes

Name Value
compat-libf2c-32 -
libf2c -

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package compat-libf2c-34-3.4.6-46.fc28.i686.rpm
Source Package compat-gcc-34-3.4.6-46.fc28.src.rpm

Install Howto

Install compat-libf2c-34 rpm package:

# dnf --refresh install compat-libf2c-34

Files

Path
/usr/lib/libg2c.so.0
/usr/lib/libg2c.so.0.0.0
/usr/lib/.build-id/
/usr/lib/.build-id/e7/3fe38be2ec0f8575cb1449e1db52832a5e8e1a

Changelog

2018-02-08 - Jakub Jelinek  <jakub@redhat.com> 3.4.6-46
- don't conflict with libstdc++ [78].x, it is still backwards ABI compatible
- strip -mcet and -fcf-protection from OPT_FLAGS
2018-02-08 - Rafal Luzynski  <digitalfreak@lingonborough.com>
- add a patch to fix build of the info docs (#1423303)
- use ucontext_t instead of struct ucontext (#1423303)
- also strip more combinations of -march=... and -mtune=... from OPT_FLAGS
on s390, s390x, actually there was a problem with -march=zEC12 and -mtune=z13
(#519507, #1423303)
- disable the annotated build feature and strip -fstack-clash-protection
from OPT_FLAGS (#1423303)
2018-02-07 - Fedora Release Engineering <releng@fedoraproject.org> - 3.4.6-45
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2017-08-02 - Fedora Release Engineering <releng@fedoraproject.org> - 3.4.6-44
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
2017-07-26 - Fedora Release Engineering <releng@fedoraproject.org> - 3.4.6-43
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-02-10 - Fedora Release Engineering <releng@fedoraproject.org> - 3.4.6-42
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
2016-08-12 - Peter Robinson <pbrobinson@fedoraproject.org> 3.4.6-41
- excludearch aarch64, unsupported in older gcc
2016-05-05 - Jakub Jelinek  <jakub@redhat.com> 3.4.6-40
- buildrequire data files for localedef
- use -std=gnu89 in the host compiler
2016-03-18 - Jakub Jelinek  <jakub@redhat.com> 3.4.6-39
- don't conflict with libstdc++ 6.x, it is still backwards ABI compatible
2016-02-03 - Fedora Release Engineering <releng@fedoraproject.org> - 3.4.6-38
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

See Also

Package Description
compat-libgcc-296-2.96-146.1.i686.rpm Compatibility 2.96-RH libgcc library
compat-libgfortran-41-4.1.2-54.fc29.i686.rpm Compatibility Fortran 95 runtime library version 4.1.2
compat-libicu60-60.2-2.fc29.i686.rpm Compat package with icu libraries
compat-libmpc-1.1.0-2.fc29.i686.rpm compat/bootstrap mpc-0.9 library
compat-libstdc++-296-2.96-146.1.i686.rpm Compatibility 2.96-RH standard C++ libraries
compat-libstdc++-33-3.2.3-68.16.fc26.1.i686.rpm Compatibility standard C++ libraries
compat-lua-5.1.5-11.fc29.i686.rpm Powerful light-weight programming language (compat version)
compat-lua-devel-5.1.5-11.fc29.i686.rpm Development files for compat-lua
compat-lua-libs-5.1.5-11.fc29.i686.rpm Powerful light-weight programming language (compat version)
compat-openssl10-1.0.2o-3.fc29.i686.rpm Compatibility version of the OpenSSL library
compat-openssl10-devel-1.0.2o-3.fc29.i686.rpm Files for development of applications which have to use OpenSSL-1.0.2
compat-openssl10-pkcs11-helper-1.22-6.fc29.i686.rpm A library for using PKCS#11 providers
compat-openssl10-pkcs11-helper-devel-1.22-6.fc29.i686.rpm Development files for pkcs11-helper
compat-readline5-5.2-32.fc29.i686.rpm A library for editing typed command lines
compat-readline5-devel-5.2-32.fc29.i686.rpm Files needed to develop programs which use the readline library
Advertisement
Advertisement