eclipse-subclipse-4.2.3-5.fc29.noarch.rpm


Advertisement

Description

eclipse-subclipse - Subversion Eclipse plugin

Property Value
Distribution Fedora 29
Repository Fedora i386
Package filename eclipse-subclipse-4.2.3-5.fc29.noarch.rpm
Package name eclipse-subclipse
Package version 4.2.3
Package release 5.fc29
Package architecture noarch
Package type rpm
Homepage http://subclipse.tigris.org/
License EPL and ASL 2.0 and CC-BY
Maintainer -
Download size 2.88 MB
Installed size 3.38 MB
Subclipse is an Eclipse plugin that adds Subversion integration to the Eclipse
IDE.

Alternatives

Package Version Architecture Repository
eclipse-subclipse-4.3.0-0.1.git43b895a.fc29.noarch.rpm 4.3.0 noarch Fedora Updates
eclipse-subclipse-4.3.0-0.1.git43b895a.fc29.noarch.rpm 4.3.0 noarch Fedora Updates
eclipse-subclipse-4.2.3-5.fc29.noarch.rpm 4.2.3 noarch Fedora
eclipse-subclipse - - -

Requires

Name Value
java-headless >= 1.6
javapackages-tools -
osgi(org.eclipse.draw2d) -
osgi(org.eclipse.gef) -
osgi(org.eclipse.mylyn.tasks.core) -
osgi(org.eclipse.mylyn.tasks.ui) -
osgi(org.eclipse.mylyn.team.ui) -
subversion-javahl >= 1.9.4

Provides

Name Value
eclipse-collabnet-merge = 4.2.3-5.fc29
eclipse-subclipse = 4.2.3-5.fc29
eclipse-subclipse-graph = 4.2.3-5.fc29
metainfo() -
metainfo(eclipse-subclipse.metainfo.xml) -
mvn(org.tigris.subclipse:com.collabnet.subversion.merge) = 4.2.0.1
mvn(org.tigris.subclipse:org.tigris.subversion.clientadapter) = 1.9.4.2
mvn(org.tigris.subclipse:org.tigris.subversion.clientadapter.javahl) = 1.9.4.1
mvn(org.tigris.subclipse:org.tigris.subversion.subclipse) = 4.2.3.SNAPSHOT
mvn(org.tigris.subclipse:org.tigris.subversion.subclipse.core) = 4.2.3.SNAPSHOT
mvn(org.tigris.subclipse:org.tigris.subversion.subclipse.graph) = 4.2.0.1
mvn(org.tigris.subclipse:org.tigris.subversion.subclipse.graph.feature) = 4.2.0.1
mvn(org.tigris.subclipse:org.tigris.subversion.subclipse.mylyn) = 4.2.0.1
mvn(org.tigris.subclipse:org.tigris.subversion.subclipse.mylyn.feature) = 4.2.0.1
mvn(org.tigris.subclipse:org.tigris.subversion.subclipse.ui) = 4.2.3.SNAPSHOT
osgi(com.collabnet.subversion.merge) = 4.2.0.1
osgi(org.tigris.subversion.clientadapter) = 1.9.4.2
osgi(org.tigris.subversion.clientadapter.javahl) = 1.9.4.1
osgi(org.tigris.subversion.subclipse) = 4.2.3.201807130251
osgi(org.tigris.subversion.subclipse.core) = 4.2.3.201807130251
osgi(org.tigris.subversion.subclipse.graph) = 4.2.0.1
osgi(org.tigris.subversion.subclipse.graph.feature) = 4.2.0.1
osgi(org.tigris.subversion.subclipse.mylyn) = 4.2.0.1
osgi(org.tigris.subversion.subclipse.mylyn.feature) = 4.2.0.1
osgi(org.tigris.subversion.subclipse.ui) = 4.2.3.201807130251

Obsoletes

Name Value
eclipse-collabnet-merge < 4.2.3-5.fc29
eclipse-subclipse-graph < 4.2.3-5.fc29

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package eclipse-subclipse-4.2.3-5.fc29.noarch.rpm
Source Package eclipse-subclipse-4.2.3-5.fc29.src.rpm

Install Howto

Install eclipse-subclipse rpm package:

# dnf install eclipse-subclipse

Files

Path
/usr/share/appdata/eclipse-subclipse.metainfo.xml
/usr/share/doc/eclipse-subclipse/CHANGELOG.md
/usr/share/eclipse/droplets/subclipse/fragment.info
/usr/share/eclipse/droplets/subclipse/features/
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse.graph.feature_4.2.0.1/feature.properties
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse.graph.feature_4.2.0.1/feature.xml
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse.graph.feature_4.2.0.1/license.html
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse.graph.feature_4.2.0.1/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse.mylyn.feature_4.2.0.1/feature.properties
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse.mylyn.feature_4.2.0.1/feature.xml
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse.mylyn.feature_4.2.0.1/license.html
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse.mylyn.feature_4.2.0.1/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse_4.2.3.201807130251/feature.properties
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse_4.2.3.201807130251/feature.xml
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse_4.2.3.201807130251/license.html
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse_4.2.3.201807130251/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse_4.2.3.201807130251/licenses/Apache2.txt
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse_4.2.3.201807130251/licenses/Ganymed.txt
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse_4.2.3.201807130251/licenses/JavaHL.txt
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse_4.2.3.201807130251/licenses/SVNKit.txt
/usr/share/eclipse/droplets/subclipse/features/org.tigris.subversion.subclipse_4.2.3.201807130251/licenses/epl-v10.html
/usr/share/eclipse/droplets/subclipse/plugins/com.collabnet.subversion.merge_4.2.0.1.jar
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.subclipse.core_4.2.3.201807130251.jar
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.subclipse.graph_4.2.0.1.jar
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.subclipse.mylyn_4.2.0.1.jar
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.subclipse.ui_4.2.3.201807130251.jar
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/about.html
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/about.ini
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/about.properties
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/epl-v10.html
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/plugin.xml
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/svn.gif
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/META-INF/maven/
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/META-INF/maven/org.tigris.subclipse/
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/META-INF/maven/org.tigris.subclipse/org.tigris.subversion.clientadapter.javahl/pom.properties
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/META-INF/maven/org.tigris.subclipse/org.tigris.subversion.clientadapter.javahl/pom.xml
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/lib/adapter-javahl.jar
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/lib/javahl.jar
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/org/
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/org/tigris/
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/org/tigris/subversion/
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/org/tigris/subversion/clientadapter/
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter.javahl_1.9.4.1/org/tigris/subversion/clientadapter/javahl/Activator.class
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/about.html
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/about.ini
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/about.properties
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/epl-v10.html
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/plugin.xml
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/svn.gif
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/META-INF/maven/
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/META-INF/maven/org.tigris.subclipse/
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/META-INF/maven/org.tigris.subclipse/org.tigris.subversion.clientadapter/pom.properties
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/META-INF/maven/org.tigris.subclipse/org.tigris.subversion.clientadapter/pom.xml
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/lib/adapter-base.jar
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/org/
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/org/tigris/
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/org/tigris/subversion/
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/org/tigris/subversion/clientadapter/Activator.class
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/org/tigris/subversion/clientadapter/AdapterManager.class
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/org/tigris/subversion/clientadapter/ILoadErrorHandler.class
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/org/tigris/subversion/clientadapter/ISVNClientWrapper.class
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/schema/loadErrorHandlers.exsd
/usr/share/eclipse/droplets/subclipse/plugins/org.tigris.subversion.clientadapter_1.9.4.2/schema/wrapper.exsd
/usr/share/licenses/eclipse-subclipse/LICENSE.md
/usr/share/maven-metadata/eclipse-subclipse.xml

Changelog

2018-07-12 - Fedora Release Engineering <releng@fedoraproject.org> - 4.2.3-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-05-09 - Mat Booth <mat.booth@redhat.com> - 4.2.3-4
- Fix reference to droplets directory tree
2018-03-21 - Mat Booth <mat.booth@redhat.com> - 4.2.3-3
- Enable conditional build support for svn backends
2018-02-07 - Fedora Release Engineering <releng@fedoraproject.org> - 4.2.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2017-11-24 - Mat Booth <mat.booth@redhat.com> - 4.2.3-1
- Update to latest upstream release
- Add patch to fix "unable to auto-share" error, rhbz#1380666
2017-07-26 - Fedora Release Engineering <releng@fedoraproject.org> - 4.2.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-05-30 - Mikolaj Izdebski <mizdebsk@redhat.com> - 4.2.2-3
- Add missing build-requires on maven-install-plugin
- Run xmvn in batch mode
2017-02-10 - Fedora Release Engineering <releng@fedoraproject.org> - 4.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
2017-01-21 - Mat Booth <mat.booth@redhat.com> - 4.2.2-1
- Update to latest upstream release
- Project moved to github and absorbed the merge client plugin
- Obsolete/Provide the collabnet-merge package

See Also

Package Description
eclipse-swt-4.9.0-2.fc29.i686.rpm SWT Library for GTK+
eclipse-swtbot-2.8.0-1.fc29.noarch.rpm UI and functional testing tool for SWT and Eclipse based applications
eclipse-testng-6.14.0-5.fc29.noarch.rpm TestNG plug-in for Eclipse
eclipse-tests-4.9.0-2.fc29.i686.rpm Eclipse Tests
eclipse-tm-terminal-4.4.0-4.fc29.noarch.rpm Terminal plug-in for Eclipse
eclipse-tm-terminal-connectors-4.4.0-4.fc29.noarch.rpm Additional connectors for Terminal plug-in for Eclipse
eclipse-tm-terminal-sdk-4.4.0-4.fc29.noarch.rpm Terminal SDK plug-in for Eclipse
eclipse-usage-4.9.0-1.fc29.noarch.rpm Usage reporting plug-ins for Eclipse
eclipse-webtools-common-3.11.0-1.fc29.noarch.rpm WST Common UI and Faceted Project Framework
eclipse-webtools-dali-3.11.0-1.fc29.noarch.rpm Eclipse Dali Java Persistence (JPA) Tools
eclipse-webtools-javaee-3.11.0-1.fc29.noarch.rpm Eclipse Java EE Developer Tools
eclipse-webtools-servertools-3.11.0-1.fc29.noarch.rpm Eclipse Server Tools Framework
eclipse-webtools-sourceediting-3.11.0-1.fc29.noarch.rpm Eclipse Web Developer, XML, XPath, and XSL Tools
eclipse-xpand-2.2.0-5.fc29.noarch.rpm Xpand is a statically-typed template language
eclipse-xtext-2.9.2-6.fc28.noarch.rpm Xtext is a framework for development of programming languages
Advertisement
Advertisement