python2-rpkg-1.56-1.fc29.noarch.rpm


Advertisement

Description

python2-rpkg - Python library for interacting with rpm+git

Property Value
Distribution Fedora 29
Repository Fedora i386
Package filename python2-rpkg-1.56-1.fc29.noarch.rpm
Package name python2-rpkg
Package version 1.56
Package release 1.fc29
Package architecture noarch
Package type rpm
Homepage https://pagure.io/rpkg
License GPLv2+ and LGPLv2
Maintainer -
Download size 147.37 KB
Installed size 596.93 KB
A python library for managing RPM package sources in a git repository.

Alternatives

Package Version Architecture Repository
python2-rpkg-1.57-6.fc29.noarch.rpm 1.57 noarch Fedora Updates
python2-rpkg-1.57-6.fc29.noarch.rpm 1.57 noarch Fedora Updates
python2-rpkg-1.56-1.fc29.noarch.rpm 1.56 noarch Fedora
python2-rpkg - - -

Requires

Name Value
mock -
python(abi) = 2.7
python2-GitPython -
python2-cccolutils -
python2-koji >= 1.15
python2-pycurl -
python2-rpm -
python2-six >= 1.9.0
redhat-rpm-config -
rpkg-common = 1.56-1.fc29
rpm-build -
rpmlint -

Provides

Name Value
pyrpkg = 1.56-1.fc29
python-rpkg = 1.56-1.fc29
python2-rpkg = 1.56-1.fc29
python2.7dist(rpkg) = 1.56
python2dist(rpkg) = 1.56

Conflicts

Name Value
fedpkg < 1.26

Obsoletes

Name Value
pyrpkg < 1.49-2
python-rpkg < 1.56-1.fc29

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package python2-rpkg-1.56-1.fc29.noarch.rpm
Source Package rpkg-1.56-1.fc29.src.rpm

Install Howto

Install python2-rpkg rpm package:

# dnf install python2-rpkg

Files

Path
/usr/lib/python2.7/site-packages/pyrpkg/__init__.py
/usr/lib/python2.7/site-packages/pyrpkg/__init__.pyc
/usr/lib/python2.7/site-packages/pyrpkg/__init__.pyo
/usr/lib/python2.7/site-packages/pyrpkg/cli.py
/usr/lib/python2.7/site-packages/pyrpkg/cli.pyc
/usr/lib/python2.7/site-packages/pyrpkg/cli.pyo
/usr/lib/python2.7/site-packages/pyrpkg/errors.py
/usr/lib/python2.7/site-packages/pyrpkg/errors.pyc
/usr/lib/python2.7/site-packages/pyrpkg/errors.pyo
/usr/lib/python2.7/site-packages/pyrpkg/gitignore.py
/usr/lib/python2.7/site-packages/pyrpkg/gitignore.pyc
/usr/lib/python2.7/site-packages/pyrpkg/gitignore.pyo
/usr/lib/python2.7/site-packages/pyrpkg/lookaside.py
/usr/lib/python2.7/site-packages/pyrpkg/lookaside.pyc
/usr/lib/python2.7/site-packages/pyrpkg/lookaside.pyo
/usr/lib/python2.7/site-packages/pyrpkg/man_gen.py
/usr/lib/python2.7/site-packages/pyrpkg/man_gen.pyc
/usr/lib/python2.7/site-packages/pyrpkg/man_gen.pyo
/usr/lib/python2.7/site-packages/pyrpkg/sources.py
/usr/lib/python2.7/site-packages/pyrpkg/sources.pyc
/usr/lib/python2.7/site-packages/pyrpkg/sources.pyo
/usr/lib/python2.7/site-packages/pyrpkg/utils.py
/usr/lib/python2.7/site-packages/pyrpkg/utils.pyc
/usr/lib/python2.7/site-packages/pyrpkg/utils.pyo
/usr/lib/python2.7/site-packages/rpkg-1.56-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/rpkg-1.56-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/rpkg-1.56-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/rpkg-1.56-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/rpkg-1.56-py2.7.egg-info/top_level.txt
/usr/share/doc/python2-rpkg/CHANGELOG.rst
/usr/share/doc/python2-rpkg/README.rst
/usr/share/licenses/python2-rpkg/COPYING
/usr/share/licenses/python2-rpkg/COPYING-koji
/usr/share/licenses/python2-rpkg/LGPL

Changelog

2018-08-21 - Chenxiong Qi <cqi@redhat.com> - 1.56-1
- Validate greenwave policy early in Commands.build (cqi)
- Refine error message for failure gating.yaml validation (cqi)
- explain mbs-manager exception handling (nils)
- test for missing mbs-manager with errno set (nils)
- catch errno == ENOENT if mbs-manager is missing (nils)
- add missing method docstring (nils)
- Show full error from MBS (lsedlar)
- Fix tests for greenwave policy validation (cqi)
- Add testenv for building docs (cqi)
- New option --buildrootdir - rhbz#1583822 (cqi)
- Add --shell option to mockbuild - rhbz#1438685 (cqi)
- Validate gating.yaml file for Greenwave gating (gnaponie)
- Update README (cqi)
- Reduce the number of repo creation for tests (cqi)
- Fix flake8 error (cqi)
- Drop rpm-py-installer from requires - #357 (cqi)
- Allow _run_command to capture and return output to stdout or stderr (cqi)
- Claim Python 3.7 in README and package classifiers (cqi)
- Fix a bad test teardown (otaylor)
- Refactor build command (cqi)
- Remove rpmfluff package (cqi)
- Set PYCURL_SSL_LIBRARY directly for installing pycurl (cqi)
- Add py37 testenv (cqi)
2018-07-26 - Chenxiong Qi <cqi@redhat.com> - 1.55-2
- Remove dependency python-rpmfluff
2018-07-23 - Chenxiong Qi <cqi@redhat.com> - 1.55-1
- Fix installing pycurl for running tests (cqi)
- Replace extra module_name with repo_name (cqi)
- Replace name module with repo in tests/fixtures/rpkg*.conf (cqi)
- Add --fail-fast functionality - #331 (tibbs)
- Fix fake spec for build in rawhide (cqi)
- Avoid to upload a file with different checksum - #204 (cqi)
- Give more information when sources has invalid content - #227 (cqi)
- Reserve README.md while import srpm - #149 (cqi)
- Set to repo_name property when --name is specified (cqi)
- Do not restrict argparse version (cqi)
- Check old format args only if there is clone config (cqi)
- Fix typo and reword option help and deprecation message (cqi)
- Massive replacement of module (cqi)
- Deprecate module_name inside rpkg internal (cqi)
- Add new option --name and --namespace - #301 (cqi)
- Man generator indent workaround (onosek)
- Fixing imports in unittests (onosek)
- Minor fixes to doc build (cqi)
- Fix mistakes during rebase (cqi)
- Run document generator script in Py3 explictly (cqi)
- Remove warning of nonexisting source/_static/ during doc build (cqi)
- Do not generate document for sample rpkg app (cqi)
- Exclude subcommand which does not have help (cqi)
- Ensure to clean files for generating HTML documents (cqi)
- Fix rebase error: add module_build_watch back (cqi)
- Fix MANIFEST.in to list files for building doc (cqi)
- Rename generate_man_pages.py (cqi)
- Generate HTML document and manpage for sample rpkg (cqi)
- Simplify doc Makefile (cqi)
- Generate commands HTML and man pages (cqi)
- Update existing docstrings (cqi)
- Generate documents by sphinx - #50 (cqi)
- README: new code should be py3 compatible (ktdreyer)
- Provide base_module to clone_config templates - #326 (tmz)
- Refactor man generator to be reusable (puiterwijk)
- Make sure gitcred doesn't land in man (puiterwijk)
- Don't inject the credential helper to push if OIDC is unconfigured
(puiterwijk)
- Add docblocks to gitcred methods and don't quit if OpenIDC is unconfigured
(puiterwijk)
- Also inject the credential helper with rpkg push (puiterwijk)
- Create a "gitcred" command that functions as an OIDC git-credential helper
(puiterwijk)
2018-07-14 - Fedora Release Engineering <releng@fedoraproject.org> - 1.54-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-06-19 - Miro HronĨok <mhroncok@redhat.com> - 1.54-3
- Rebuilt for Python 3.7
2018-05-21 - Chenxiong Qi <cqi@redhat.com> - 1.54-2
- Remove koji and rpm-py-installer Python package requires
- Fix argparse version for el6

See Also

Package Description
python2-rpm-4.14.2-1.fc29.i686.rpm Python 2 bindings for apps which will manipulate RPM packages
python2-rpm-macros-3-37.fc29.noarch.rpm RPM macros for building Python 2 packages
python2-rpmdeplint-1.4-3.fc29.noarch.rpm Tool to find errors in RPM packages in the context of their dependency graph
python2-rpmfluff-0.5.5-1.fc29.noarch.rpm Lightweight way of building RPMs, and sabotaging them
python2-rpyc-4.0.1-2.fc29.noarch.rpm A Transparent, Symmetrical Python Library for Distributed-Computing
python2-rra-0.14-19.fc28.i686.rpm Python bindings to librra (part of SynCE)
python2-rrdtool-1.7.0-17.fc29.i686.rpm Python RRDtool bindings
python2-rsa-3.4.2-8.fc29.noarch.rpm Pure-Python RSA implementation
python2-rsd-lib-0.1.1-6.fc29.noarch.rpm Python library for interfacing with Intel Rack Scale Design enabled hardware
python2-rsd-lib-tests-0.1.1-6.fc29.noarch.rpm rsd-lib tests
python2-rsdclient-0.1.1-5.fc29.noarch.rpm OpenStack client plugin for Rack Scale Design
python2-rsdclient-tests-0.1.1-5.fc29.noarch.rpm python-rsdclient tests
python2-rsslib-0-13.20130310.fc29.noarch.rpm Create RSS feeds in Python
python2-rstcheck-3.1-7.fc29.noarch.rpm Checks syntax of reStructuredText and code blocks nested within it
python2-rtkit-0.6.0-11.fc29.noarch.rpm A python interface to the Request Tracker API
Advertisement
Advertisement