mariadb-connector-c-3.0.10-1.fc29.i686.rpm


Advertisement

Description

mariadb-connector-c - The MariaDB Native Client library (C driver)

Property Value
Distribution Fedora 29
Repository Fedora Updates i386
Package filename mariadb-connector-c-3.0.10-1.fc29.i686.rpm
Package name mariadb-connector-c
Package version 3.0.10
Package release 1.fc29
Package architecture i686
Package type rpm
Homepage http://mariadb.org/
License LGPLv2+
Maintainer -
Download size 142.62 KB
Installed size 417.04 KB
The MariaDB Native Client library (C driver) is used to connect applications
developed in C/C++ to MariaDB and MySQL databases.

Alternatives

Package Version Architecture Repository
mariadb-connector-c-3.0.10-1.fc29.i686.rpm 3.0.10 i686 Fedora Updates
mariadb-connector-c-3.0.10-1.fc29.x86_64.rpm 3.0.10 x86_64 Fedora Updates
mariadb-connector-c-3.0.6-2.fc29.i686.rpm 3.0.6 i686 Fedora
mariadb-connector-c-3.0.6-2.fc29.i686.rpm 3.0.6 i686 Fedora
mariadb-connector-c-3.0.6-2.fc29.x86_64.rpm 3.0.6 x86_64 Fedora
mariadb-connector-c - - -

Requires

Name Value
/etc/my.cnf -
libc.so.6(GLIBC_2.28) -
libcom_err.so.2 -
libcrypto.so.1.1 -
libcrypto.so.1.1(OPENSSL_1_1_0) -
libcurl.so.4 -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgssapi_krb5.so.2 -
libgssapi_krb5.so.2(gssapi_krb5_2_MIT) -
libk5crypto.so.3 -
libkrb5.so.3 -
libm.so.6 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libssl.so.1.1 -
libssl.so.1.1(OPENSSL_1_1_0) -
libz.so.1 -
rtld(GNU_HASH) -

Provides

Name Value
libmariadb.so.3 -
libmariadb.so.3(libmariadb_3) -
libmariadb.so.3(libmariadbclient_18) -
libmariadb.so.3(libmysqlclient_18) -
mariadb-connector-c = 3.0.10-1.fc29
mariadb-connector-c(x86-32) = 3.0.10-1.fc29

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package mariadb-connector-c-3.0.10-1.fc29.i686.rpm
Source Package mariadb-connector-c-3.0.10-1.fc29.src.rpm

Install Howto

Install mariadb-connector-c rpm package:

# dnf --refresh install mariadb-connector-c

Files

Path
/usr/lib/libmariadb.so.3
/usr/lib/.build-id/
/usr/lib/.build-id/0d/79b28dacaa62530fd4e2f8c911ef8ce39ae7f4
/usr/lib/.build-id/24/77619213c835b9d8bcb3cb3ae2f3de2cf69a47
/usr/lib/.build-id/27/ee65e7122f8c05c99d4061e7a767d06c5f25a6
/usr/lib/.build-id/45/4a52013d27baa7d3f3540cc9fbe50740680834
/usr/lib/.build-id/5d/fca5a43218f8f63c443d77ced83eb504b8c5f2
/usr/lib/.build-id/e0/eed7ae076074c8ac4b73e7b0af7eddc9e19eb7
/usr/lib/.build-id/e4/d1debb0727ffb9a588d8cf2e3400395f19446e
/usr/lib/mariadb/
/usr/lib/mariadb/plugin/auth_gssapi_client.so
/usr/lib/mariadb/plugin/caching_sha2_password.so
/usr/lib/mariadb/plugin/dialog.so
/usr/lib/mariadb/plugin/mysql_clear_password.so
/usr/lib/mariadb/plugin/remote_io.so
/usr/lib/mariadb/plugin/sha256_password.so
/usr/share/doc/mariadb-connector-c/README
/usr/share/licenses/mariadb-connector-c/COPYING.LIB

Changelog

2019-05-15 - Michal Schorm <mschorm@redhat.com> - 3.0.10-1
- Rebase to 3.0.10
2019-03-29 - Michal Schorm <mschorm@redhat.com> - 3.0.9-3
- Add "zlib-devel" requirement in "-devel" subpackage. MariaDB requires
linking with "-lz", which will fail without the zlib library
- Related: #1693966
2019-02-18 - Michal Schorm <mschorm@redhat.com> - 3.0.9-2
- Fix plugindir issues
Resolves: #1624533
2019-02-18 - Michal Schorm <mschorm@redhat.com> - 3.0.9-1
- Rebase to 3.0.9
2019-02-01 - Fedora Release Engineering <releng@fedoraproject.org> - 3.0.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
2019-01-02 - Michal Schorm <mschorm@redhat.com> - 3.0.8-1
- Rebase to 3.0.8
2018-11-19 - Michal Schorm <mschorm@redhat.com> - 3.0.7-1
- Rebase to 3.0.7
2018-09-04 - Michal Schorm <mschorm@redhat.com> - 3.0.6-2
- Fix parallel installability of x86_64 and i686 devel package
2018-08-03 - Michal Schorm <mschorm@redhat.com> - 3.0.6-1
- Rebase to 3.0.6
2018-07-17 - Honza Horak <hhorak@redhat.com> - 3.0.5-3
- Add -config sub-package that delivers system-wide /etc/my.cnf and
/etc/my.cnf.d directory, that other packages should use
This package also obsoletes mariadb-config

See Also

Package Description
mariadb-connector-c-config-3.0.10-1.fc29.noarch.rpm Configuration files for packages that use /etc/my.cnf as a configuration file
mariadb-connector-c-devel-3.0.10-1.fc29.i686.rpm Development files for mariadb-connector-c
mariadb-connector-odbc-3.0.8-1.fc29.i686.rpm The MariaDB Native Client library (ODBC driver)
mariadb-cracklib-password-check-10.3.12-10.fc29.i686.rpm The password strength checking plugin
mariadb-devel-10.3.12-10.fc29.i686.rpm Files for development of MariaDB/MySQL applications
mariadb-embedded-10.3.12-10.fc29.i686.rpm MariaDB as an embeddable library
mariadb-embedded-devel-10.3.12-10.fc29.i686.rpm Development files for MariaDB as an embeddable library
mariadb-errmsg-10.3.12-10.fc29.i686.rpm The error messages files required by server and embedded
mariadb-gssapi-server-10.3.12-10.fc29.i686.rpm GSSAPI authentication plugin for server
mariadb-java-client-2.4.1-1.fc29.noarch.rpm Connects applications developed in Java to MariaDB and MySQL databases
mariadb-java-client-javadoc-2.4.1-1.fc29.noarch.rpm Javadoc for mariadb-java-client
mariadb-java-client-tests-2.4.1-1.fc29.noarch.rpm Tests for mariadb-java-client
mariadb-oqgraph-engine-10.3.12-10.fc29.i686.rpm The Open Query GRAPH engine for MariaDB
mariadb-server-10.3.12-10.fc29.i686.rpm The MariaDB server and related files
mariadb-server-galera-10.3.12-10.fc29.i686.rpm The configuration files and scripts for galera replication
Advertisement
Advertisement