opam-2.0.1-1.fc29.i686.rpm


Advertisement

Description

opam - Source-based package manager for OCaml

Property Value
Distribution Fedora 29
Repository Fedora Updates i386
Package filename opam-2.0.1-1.fc29.i686.rpm
Package name opam
Package version 2.0.1
Package release 1.fc29
Package architecture i686
Package type rpm
Homepage https://github.com/ocaml/opam
License LGPLv2 with exceptions
Maintainer -
Download size 2.14 MB
Installed size 6.14 MB
Opam is a source-based package manager for OCaml. It supports multiple
simultaneous compiler installations, flexible package constraints, and
a Git-friendly development workflow.

Alternatives

Package Version Architecture Repository
opam-2.0.1-1.fc29.x86_64.rpm 2.0.1 x86_64 Fedora Updates
opam-2.0.0-0.9.rc.fc29.x86_64.rpm 2.0.0 x86_64 Fedora
opam-2.0.0-0.9.rc.fc29.i686.rpm 2.0.0 i686 Fedora
opam - - -

Requires

Name Value
bubblewrap -
bzip2 -
gcc -
libc.so.6(GLIBC_2.28) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libz.so.1 -
m4 -
make -
opam-installer(x86-32) = 2.0.1-1.fc29
patch -
rtld(GNU_HASH) -
tar -
unzip -

Provides

Name Value
opam = 2.0.1-1.fc29
opam(x86-32) = 2.0.1-1.fc29

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package opam-2.0.1-1.fc29.i686.rpm
Source Package opam-2.0.1-1.fc29.src.rpm

Install Howto

Install opam rpm package:

# dnf install opam

Files

Path
/usr/bin/opam
/usr/lib/.build-id/
/usr/lib/.build-id/1c/82d09a550a210afe0c82312f4f4437154c3e04
/usr/share/licenses/opam/LICENSE
/usr/share/man/man1/opam-admin-cache.1.gz
/usr/share/man/man1/opam-admin-filter.1.gz
/usr/share/man/man1/opam-admin-index.1.gz
/usr/share/man/man1/opam-admin-lint.1.gz
/usr/share/man/man1/opam-admin-list.1.gz
/usr/share/man/man1/opam-admin-upgrade.1.gz
/usr/share/man/man1/opam-admin.1.gz
/usr/share/man/man1/opam-clean.1.gz
/usr/share/man/man1/opam-config.1.gz
/usr/share/man/man1/opam-env.1.gz
/usr/share/man/man1/opam-exec.1.gz
/usr/share/man/man1/opam-help.1.gz
/usr/share/man/man1/opam-info.1.gz
/usr/share/man/man1/opam-init.1.gz
/usr/share/man/man1/opam-install.1.gz
/usr/share/man/man1/opam-lint.1.gz
/usr/share/man/man1/opam-list.1.gz
/usr/share/man/man1/opam-pin.1.gz
/usr/share/man/man1/opam-reinstall.1.gz
/usr/share/man/man1/opam-remote.1.gz
/usr/share/man/man1/opam-remove.1.gz
/usr/share/man/man1/opam-repository.1.gz
/usr/share/man/man1/opam-search.1.gz
/usr/share/man/man1/opam-show.1.gz
/usr/share/man/man1/opam-source.1.gz
/usr/share/man/man1/opam-switch.1.gz
/usr/share/man/man1/opam-uninstall.1.gz
/usr/share/man/man1/opam-unpin.1.gz
/usr/share/man/man1/opam-update.1.gz
/usr/share/man/man1/opam-upgrade.1.gz
/usr/share/man/man1/opam-var.1.gz
/usr/share/man/man1/opam.1.gz

Changelog

2018-11-01 - Ben Rosser <rosser.bjr@gmail.com> - 2.0.1-1
- Updated to latest upstream release (rhbz#1643738).
2018-10-24 - Ben Rosser <rosser.bjr@gmail.com> - 2.0.0-0.12.rc
- Add requires on make and m4 for opam init setup.
2018-10-02 - Ben Rosser <rosser.bjr@gmail.com> - 2.0.0-0.11.rc
- Add Requires on gcc so that opam init works properly (rhbz#1631969).
2018-09-22 - Ben Rosser <rosser.bjr@gmail.com> - 2.0.0-0.10.rc
- Add missing Requires on patch, unzip (rhbz#1631969).
2018-08-21 - Ben Rosser <rosser.bjr@gmail.com> - 2.0.0-0.9.rc
- Updated to opam 2.0 rc1.
- Fix FTBFS on Fedora 29/Rawhide.
2018-07-13 - Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-0.8.beta6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-04-30 - Ben Rosser <rosser.bjr@gmail.com> - 2.0.0-0.7.beta6
- Add missing dependency on bzip2 (#1572862).
2018-02-08 - Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-0.6.beta6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2017-12-13 - Ben Rosser <rosser.bjr@gmail.com> - 2.0.0-0.5.beta6
- Update to beta6, with a few fixes from beta5.
2017-12-04 - Ben Rosser <rosser.bjr@gmail.com> - 2.0.0-0.4.beta5
- Add upstream patch correctly indicating LGPLv2 license of a few files.

See Also

Package Description
opam-installer-2.0.1-1.fc29.i686.rpm Standalone script for opam install files
open-amp-2018.04-1.fc29.i686.rpm Open Asymmetric Multi Processing (OpenAMP) framework project
open-amp-devel-2018.04-1.fc29.i686.rpm Development files for OpenAMP
open-vm-tools-10.3.10-1.fc29.i686.rpm Open Virtual Machine Tools for virtual machines hosted on VMware
open-vm-tools-desktop-10.3.10-1.fc29.i686.rpm User experience components for Open Virtual Machine Tools
open-vm-tools-devel-10.3.10-1.fc29.i686.rpm Development libraries for Open Virtual Machine Tools
open-vm-tools-test-10.3.10-1.fc29.i686.rpm Test utilities for Open Virtual Machine Tools
open62541-0.3.1-1.fc29.i686.rpm OPC UA implementation
open62541-devel-0.3.1-1.fc29.i686.rpm Development files for open62541
openarena-0.8.8-12.fc29.noarch.rpm Open source first person shooter
openbabel-2.4.1-16.fc29.i686.rpm Chemistry software file format converter
openbabel-devel-2.4.1-16.fc29.i686.rpm Development tools for programs which will use the Open Babel library
openbabel-doc-2.4.1-16.fc29.noarch.rpm Additional documentation for the Open Babel library
openbabel-gui-2.4.1-16.fc29.i686.rpm Chemistry software file format converter - GUI version
openbabel-libs-2.4.1-16.fc29.i686.rpm Chemistry software file format converter - libraries
Advertisement
Advertisement