rubygem-spy-1.0.0-1.fc29.noarch.rpm


Advertisement

Description

rubygem-spy - Simple modern mocking library that uses the spy pattern

Property Value
Distribution Fedora 29
Repository Fedora Updates i386
Package filename rubygem-spy-1.0.0-1.fc29.noarch.rpm
Package name rubygem-spy
Package version 1.0.0
Package release 1.fc29
Package architecture noarch
Package type rpm
Homepage https://github.com/ryanong/spy
License MIT
Maintainer -
Download size 18.57 KB
Installed size 37.89 KB
Spy is a mocking library that was made for the modern age. It supports only
1.9.3+. Spy by default will raise an error if you attempt to stub a method
that doesn't exist or call the stubbed method with the wrong arity.

Alternatives

Package Version Architecture Repository
rubygem-spy-1.0.0-1.fc29.noarch.rpm 1.0.0 noarch Fedora Updates
rubygem-spy-0.4.5-2.fc29.noarch.rpm 0.4.5 noarch Fedora
rubygem-spy-0.4.5-2.fc29.noarch.rpm 0.4.5 noarch Fedora
rubygem-spy - - -

Requires

Name Value
ruby(rubygems) -

Provides

Name Value
rubygem(spy) = 1.0.0-1
rubygem-spy = 1.0.0-1.fc29

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package rubygem-spy-1.0.0-1.fc29.noarch.rpm
Source Package rubygem-spy-1.0.0-1.fc29.src.rpm

Install Howto

Install rubygem-spy rpm package:

# dnf install rubygem-spy

Files

Path
/usr/share/gems/gems/spy-1.0.0/LICENSE.txt
/usr/share/gems/gems/spy-1.0.0/lib/spy.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/agency.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/api.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/base.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/call_log.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/constant.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/exceptions.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/integration.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/mock.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/nest.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/subroutine.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/version.rb
/usr/share/gems/gems/spy-1.0.0/lib/spy/core_ext/marshal.rb
/usr/share/gems/specifications/spy-1.0.0.gemspec

Changelog

2018-10-15 - Fabio Valentini <decathorpe@gmail.com> - 1.0.0-1
- Update to version 1.0.0.
2018-07-14 - Fedora Release Engineering <releng@fedoraproject.org> - 0.4.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-04-23 - Fabio Valentini <decathorpe@gmail.com> - 0.4.5-1
- Initial package

See Also

Package Description
rubygem-spy-doc-1.0.0-1.fc29.noarch.rpm Documentation for rubygem-spy
rubygem-test-unit-3.3.3-200.fc29.noarch.rpm Improved version of Test::Unit bundled in Ruby 1.8.x
rubygem-test-unit-doc-3.3.3-200.fc29.noarch.rpm Documentation for rubygem-test-unit
rubygem-thread_order-1.1.1-1.fc29.noarch.rpm Test helper for ordering threaded code
rubygem-thread_order-doc-1.1.1-1.fc29.noarch.rpm Documentation for rubygem-thread_order
rubygem-tomlrb-1.2.8-3.fc29.noarch.rpm TOML parser based on racc
rubygem-tomlrb-doc-1.2.8-3.fc29.noarch.rpm Documentation for rubygem-tomlrb
rubygem-unf_ext-0.0.7.6-1.fc29.i686.rpm Unicode Normalization Form support library for CRuby
rubygem-unf_ext-doc-0.0.7.6-1.fc29.noarch.rpm Documentation for rubygem-unf_ext
rubygem-vault-0.12.0-1.fc29.noarch.rpm A Ruby API client for interacting with a Vault server
rubygem-vault-doc-0.12.0-1.fc29.noarch.rpm Documentation for rubygem-vault
rubygem-vte-3.3.6-1.fc29.i686.rpm Ruby binding of vte
rubygem-vte-devel-3.3.6-1.fc29.i686.rpm Ruby/VTE development environment
rubygem-vte-doc-3.3.6-1.fc29.i686.rpm Documentation for rubygem-vte
rubygem-vte3-3.3.6-1.fc29.noarch.rpm Ruby binding of VTE
Advertisement
Advertisement