strongswan-libipsec-5.7.2-1.fc29.i686.rpm


Advertisement

Description

strongswan-libipsec - Strongswan's libipsec backend

Property Value
Distribution Fedora 29
Repository Fedora Updates i386
Package filename strongswan-libipsec-5.7.2-1.fc29.i686.rpm
Package name strongswan-libipsec
Package version 5.7.2
Package release 1.fc29
Package architecture i686
Package type rpm
Homepage http://www.strongswan.org/
License GPLv2+
Maintainer -
Download size 34.18 KB
Installed size 76.06 KB
The kernel-libipsec plugin provides an IPsec backend that works entirely
in userland, using TUN devices and its own IPsec implementation libipsec.

Alternatives

Package Version Architecture Repository
strongswan-libipsec-5.7.2-1.fc29.x86_64.rpm 5.7.2 x86_64 Fedora Updates
strongswan-libipsec-5.6.3-3.fc29.x86_64.rpm 5.6.3 x86_64 Fedora
strongswan-libipsec-5.6.3-3.fc29.i686.rpm 5.6.3 i686 Fedora
strongswan-libipsec - - -

Requires

Name Value
libc.so.6(GLIBC_2.28) -
libstrongswan.so.0 -
rtld(GNU_HASH) -

Provides

Name Value
libipsec.so.0 -
libstrongswan-kernel-libipsec.so -
strongswan-libipsec = 5.7.2-1.fc29
strongswan-libipsec(x86-32) = 5.7.2-1.fc29

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package strongswan-libipsec-5.7.2-1.fc29.i686.rpm
Source Package strongswan-5.7.2-1.fc29.src.rpm

Install Howto

Install strongswan-libipsec rpm package:

# dnf install strongswan-libipsec

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/05/8195b2fb1345515dd2509ec7aae067397eff25
/usr/lib/.build-id/fd/ba40196e251a814dc69dc00491d25af1fbbdbc
/usr/lib/strongswan/libipsec.so.0
/usr/lib/strongswan/libipsec.so.0.0.0
/usr/lib/strongswan/plugins/libstrongswan-kernel-libipsec.so

Changelog

2019-01-09 - Paul Wouters <pwouters@redhat.com> - 5.7.2-1
- Updated to 5.7.2
2018-10-04 - Mikhail Zabaluev <mikhail.zabaluev@gmail.com> - 5.7.1-1
- Updated to 5.7.1
- Resolves rhbz#1635872 CVE-2018-16152
- Resolves rhbz#1635875 CVE-2018-16151
2018-08-23 - Mikhail Zabaluev <mikhail.zabaluev@gmail.com> - 5.6.3-3
- Add plugin bypass-lan, disabled by default
- Resolves rhbz#1554479 Update to strongswan-charon-nm fails
2018-07-14 - Fedora Release Engineering <releng@fedoraproject.org> - 5.6.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-05-29 - Mikhail Zabaluev <mikhail.zabaluev@gmail.com> - 5.6.3-1
- New version 5.6.3
2018-05-24 - Paul Wouters <pwouters@redhat.com> - 5.6.2-6
- Resolves rhbz#1581868 CVE-2018-5388 strongswan: buffer underflow in stroke_socket.c
2018-05-24 - Paul Wouters <pwouters@redhat.com> - 5.6.2-5
- Resolves rhbz#1574939 IKEv2 VPN connections fail to use DNS servers provided by the server
- Resolves rhbz#1449875 Strongswan on epel built without the sql plugin but with the sqlite plugin
2018-05-20 - Mikhail Zabaluev <mikhail.zabaluev@gmail.com> - 5.6.2-3
- Move eap-radius, sqlite, and pkcs7 plugins out of tnc-imcvs, added package
sqlite (#1579945)
2018-03-06 - Björn Esser <besser82@fedoraproject.org> - 5.6.2-2
- Rebuilt for libjson-c.so.4 (json-c v0.13.1)
2018-02-21 - Lubomir Rintel <lkundrak@v3.sk> - 5.6.2-1
- Updated to 5.6.2 (Dropped libnm-glib use in charon-nm)

See Also

Package Description
strongswan-sqlite-5.7.2-1.fc29.i686.rpm SQLite support for strongSwan
strongswan-tnc-imcvs-5.7.2-1.fc29.i686.rpm Trusted network connect (TNC)'s IMC/IMV functionality
stunnel-5.50-1.fc29.i686.rpm A TLS-encrypting socket wrapper
subdownloader-2.0.19-8.fc29.noarch.rpm Program for download/upload subtitles for video files and DVDs
subscription-manager-1.25.9-1.fc29.i686.rpm Tools and libraries for subscription and repository management
subscription-manager-cockpit-1.25.9-1.fc29.noarch.rpm Subscription Manager Cockpit UI
subscription-manager-initial-setup-addon-1.25.9-1.fc29.i686.rpm initial-setup screens for subscription-manager
subscription-manager-migration-1.25.9-1.fc29.i686.rpm Migration scripts for moving to certificate based subscriptions
subscription-manager-plugin-container-1.25.9-1.fc29.i686.rpm A plugin for handling container content
subscription-manager-plugin-ostree-1.25.9-1.fc29.i686.rpm A plugin for handling OSTree content
subscription-manager-rhsm-certificates-1.25.9-1.fc29.i686.rpm Certificates required to communicate with a Red Hat Unified Entitlement Platform
subunit-1.3.0-4.fc29.i686.rpm C bindings for subunit
subunit-cppunit-1.3.0-4.fc29.i686.rpm Subunit integration into cppunit
subunit-cppunit-devel-1.3.0-4.fc29.i686.rpm Header files for applications that use cppunit and subunit
subunit-devel-1.3.0-4.fc29.i686.rpm Header files for developing C applications that use subunit
Advertisement
Advertisement