libipa_hbac-2.2.0-3.fc29.x86_64.rpm


Advertisement

Description

libipa_hbac - FreeIPA HBAC Evaluator library

Property Value
Distribution Fedora 29
Repository Fedora Updates x86_64
Package filename libipa_hbac-2.2.0-3.fc29.x86_64.rpm
Package name libipa_hbac
Package version 2.2.0
Package release 3.fc29
Package architecture x86_64
Package type rpm
Category Development/Libraries
Homepage https://pagure.io/SSSD/sssd/
License LGPLv3+
Maintainer -
Download size 40.52 KB
Installed size 60.81 KB
Utility library to validate FreeIPA HBAC rules for authorization requests

Alternatives

Package Version Architecture Repository
libipa_hbac-2.2.2-1.fc29.i686.rpm 2.2.2 i686 Fedora Updates Testing
libipa_hbac-2.2.2-1.fc29.i686.rpm 2.2.2 i686 Fedora Updates Testing
libipa_hbac-2.2.2-1.fc29.x86_64.rpm 2.2.2 x86_64 Fedora Updates Testing
libipa_hbac-2.2.0-3.fc29.i686.rpm 2.2.0 i686 Fedora Updates
libipa_hbac-2.2.0-3.fc29.i686.rpm 2.2.0 i686 Fedora Updates
libipa_hbac-2.0.0-3.fc29.x86_64.rpm 2.0.0 x86_64 Fedora
libipa_hbac-2.0.0-3.fc29.i686.rpm 2.0.0 i686 Fedora
libipa_hbac-2.0.0-3.fc29.i686.rpm 2.0.0 i686 Fedora
libipa_hbac - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.14)(64bit) -
libglib-2.0.so.0()(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
libipa_hbac = 2.2.0-3.fc29
libipa_hbac(x86-64) = 2.2.0-3.fc29
libipa_hbac.so.0()(64bit) -
libipa_hbac.so.0(IPA_HBAC_0.0.1)(64bit) -
libipa_hbac.so.0(IPA_HBAC_0.1.0)(64bit) -

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package libipa_hbac-2.2.0-3.fc29.x86_64.rpm
Source Package sssd-2.2.0-3.fc29.src.rpm

Install Howto

Install libipa_hbac rpm package:

# dnf install libipa_hbac

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/9c/2e9594c63c01466132c9e5496755b0139908a0
/usr/lib64/libipa_hbac.so.0
/usr/lib64/libipa_hbac.so.0.1.0
/usr/share/licenses/libipa_hbac/COPYING
/usr/share/licenses/libipa_hbac/COPYING.LESSER

Changelog

2019-07-05 - Jakub Hrozek <jhrozek@redhat.com> - 2.2.0-3
- Resolves: rhbz#1721636 - sssd-kcm calls sssd-genconf which triggers
nscd warning
2019-07-05 - Jakub Hrozek <jhrozek@redhat.com> - 2.2.0-2
- Resolves: rhbz#1724717 - sssd-proxy crashes resolving groups with
no members
2019-06-17 - Michal Židek <mzidek@redhat.com> - 2.2.0-1
- Update to latest released upstream version
- https://docs.pagure.org/SSSD.sssd/users/relnotes/notes_2_2_0.html
2019-03-27 - Michal Židek <mzidek@redhat.com> - 2.1.0-2
- Resolves: upstream#3867 - [RFE] Need an option in SSSD so that it will skip
GPOs that have groupPolicyContainers unreadable
by SSSD.
- CVE-2018-16838
2019-03-27 - Michal Židek <mzidek@redhat.com> - 2.1.0-1
- Update to latest released upstream version
- https://docs.pagure.org/SSSD.sssd/users/relnotes/notes_2_1_0.html
2018-12-12 - Adam Williamson <awilliam@redhat.com> - 2.0.0-5
- Resolves: rhbz#1654537 - sbus: use 120 second default timeout
2018-08-29 - Michal Židek <mzidek@redhat.com> - 2.0.0-4
- Resolves: upstream#3821 - crash related to sbus_router_destructor()
- Resolves: upstream#3810 - sbus2: fix memory leak in sbus_message_bound_ref
- Resolves: upstream#3819 - sssd only sets the SELinux login context if it
differs from the default
- Resolves: upstream#3807 - The sbus codegen script relies on "python" which
might not be available on all distributions
- Resolves: upstream#3820 - sudo: search with lower cased name for case
insensitive domains
- Resolves: upstream#3701 - [RFE] Allow changing default behavior of SSSD from
an allow-any default to a deny-any default when it
can't find any GPOs to apply to a user login.
- Resolves: upstream#3828 - Invalid domain provider causes SSSD to abort
startup
- Resolves: upstream#3500 - Make sure sssd is a replacement for pam_pkcs11
also for local account authentication
- Resolves: upstream#3812 - sssd 2.0.0 segfaults on startup
- Resolves: upstream#3826 - Remove references of sss_user/group/add/del
commands in man pages since local provider is
deprecated
- Resolves: upstream#3827 - SSSD should log to syslog if a domain is not
started due to a misconfiguration
- Resolves: upstream#3830 - Printing incorrect information about domain with
sssctl utility
- Resolves: upstream#3489 - p11_child should work wit openssl1.0+
- Resolves: upstream#3750 - [RFE] man 5 sssd-files should mention necessary
changes in nsswitch.conf
- Resovles: upstream#3650 - RFE: Require smartcard authentication
- Resolves: upstream#3334 - sssctl config-check does not check any special
characters in domain name of domain section
- Resolves: upstream#3849 - Files: The files provider always enumerates
which causes duplicate when running getent passwd
- Related: upstream#3855 - session not recording for local user when groups
defined
- Resolves: upstream#3802 - Reuse sysdb_error_to_errno() outside sysdb
- Related: upstream#3493 - Remove the pysss.local interface
2018-08-29 - Michal Židek <mzidek@redhat.com> - 2.0.0-3
- Resolves: rhbz#1622760 - Console login as FreeIPA domain user fails in
current Fedora Rawhide / 29
2018-08-29 - Michal Židek <mzidek@redhat.com> - 2.0.0-2
- Fix linking issues
2018-08-14 - Michal Židek <mzidek@redhat.com> - 2.0.0-1
- New upstream release 2.0.0

See Also

Package Description
libipa_hbac-devel-2.2.0-3.fc29.i686.rpm FreeIPA HBAC Evaluator library
libipa_hbac-devel-2.2.0-3.fc29.x86_64.rpm FreeIPA HBAC Evaluator library
libipmctl-01.00.00.3469-1.fc29.x86_64.rpm Library for Intel DCPMM management
libipmctl-devel-01.00.00.3469-1.fc29.x86_64.rpm Development packages for libipmctl
libiptcdata-1.0.5-1.fc29.i686.rpm IPTC tag library
libiptcdata-1.0.5-1.fc29.x86_64.rpm IPTC tag library
libiptcdata-devel-1.0.5-1.fc29.i686.rpm Headers and libraries for libiptcdata application development
libiptcdata-devel-1.0.5-1.fc29.x86_64.rpm Headers and libraries for libiptcdata application development
libisds-0.11-1.fc29.i686.rpm Library for accessing the Czech Data Boxes
libisds-0.11-1.fc29.x86_64.rpm Library for accessing the Czech Data Boxes
libisds-devel-0.11-1.fc29.i686.rpm Development files for libisds
libisds-devel-0.11-1.fc29.x86_64.rpm Development files for libisds
libisoburn-1.5.0-1.fc29.i686.rpm Library to enable creation and expansion of ISO-9660 filesystems
libisoburn-1.5.0-1.fc29.x86_64.rpm Library to enable creation and expansion of ISO-9660 filesystems
libisoburn-devel-1.5.0-1.fc29.i686.rpm Development files for libisoburn
Advertisement
Advertisement