eclipse-jdt-4.9.0-2.fc29.noarch.rpm


Advertisement

Description

eclipse-jdt - Eclipse Java Development Tools

Property Value
Distribution Fedora 29
Repository Fedora x86_64
Package filename eclipse-jdt-4.9.0-2.fc29.noarch.rpm
Package name eclipse-jdt
Package version 4.9.0
Package release 2.fc29
Package architecture noarch
Package type rpm
Homepage http://www.eclipse.org/
License EPL-2.0
Maintainer -
Download size 30.66 MB
Installed size 33.00 MB
Eclipse Java Development Tools.  This package is required to use Eclipse for
developing software written in the Java programming language.

Alternatives

Package Version Architecture Repository
eclipse-jdt-4.10.0-2.fc29.noarch.rpm 4.10.0 noarch Fedora Updates
eclipse-jdt-4.10.0-2.fc29.noarch.rpm 4.10.0 noarch Fedora Updates
eclipse-jdt-4.9.0-2.fc29.noarch.rpm 4.9.0 noarch Fedora
eclipse-jdt - - -

Requires

Name Value
eclipse-platform = 4.9.0-2.fc29
java-headless >= 1.8
javapackages-filesystem -
osgi(org.apiguardian) -
osgi(org.hamcrest.core) -
osgi(org.junit) -
osgi(org.junit) >= 4.12
osgi(org.junit.jupiter.api) -
osgi(org.junit.jupiter.engine) -
osgi(org.junit.jupiter.migrationsupport) -
osgi(org.junit.jupiter.params) -
osgi(org.junit.platform.commons) -
osgi(org.junit.platform.engine) -
osgi(org.junit.platform.launcher) -
osgi(org.junit.platform.runner) -
osgi(org.junit.platform.suite.api) -
osgi(org.junit.vintage.engine) -
osgi(org.opentest4j) -

Provides

Name Value
eclipse = 4.9.0-2.fc29
eclipse-jdt = 4.9.0-2.fc29
metainfo() -
metainfo(eclipse-jdt.metainfo.xml) -
mvn(org.eclipse.ant:org.eclipse.ant.launching) = 1.2.200.SNAPSHOT
mvn(org.eclipse.ant:org.eclipse.ant.ui) = 3.7.200.SNAPSHOT
mvn(org.eclipse.jdt.feature:org.eclipse.jdt) = 3.15.0.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt) = 3.15.0.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.annotation) = 2.2.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.apt.core) = 3.6.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.apt.pluggable.core) = 1.2.200.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.apt.ui) = 3.6.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.compiler.apt) = 1.3.300.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.compiler.tool) = 1.2.300.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.core) = 3.15.0.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.core.manipulation) = 1.10.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.debug) = 3.12.0.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.debug.ui) = 3.10.0.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.doc.user) = 3.15.0.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit) = 3.11.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit.core) = 3.10.100.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit.runtime) = 3.4.800.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit4.runtime) = 1.1.800.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.junit5.runtime) = 1.0.200.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.launching) = 3.11.0.SNAPSHOT
mvn(org.eclipse.jdt:org.eclipse.jdt.ui) = 3.15.0.SNAPSHOT
osgi(org.eclipse.ant.launching) = 1.2.200.v20180912.1831
osgi(org.eclipse.ant.ui) = 3.7.200.v20180912.1831
osgi(org.eclipse.jdt) = 3.15.0.v20180912.1831
osgi(org.eclipse.jdt.annotation) = 2.2.100.v20180912.1831
osgi(org.eclipse.jdt.apt.core) = 3.6.100.v20180912.1831
osgi(org.eclipse.jdt.apt.pluggable.core) = 1.2.200.v20180912.1831
osgi(org.eclipse.jdt.apt.ui) = 3.6.100.v20180912.1831
osgi(org.eclipse.jdt.compiler.apt) = 1.3.300.v20180912.1831
osgi(org.eclipse.jdt.compiler.tool) = 1.2.300.v20180912.1831
osgi(org.eclipse.jdt.core) = 3.15.0.v20180912.1831
osgi(org.eclipse.jdt.core.manipulation) = 1.10.100.v20180912.1831
osgi(org.eclipse.jdt.debug) = 3.12.0.v20180912.1831
osgi(org.eclipse.jdt.debug.ui) = 3.10.0.v20180912.1831
osgi(org.eclipse.jdt.doc.user) = 3.15.0.v20180912.1831
osgi(org.eclipse.jdt.junit) = 3.11.100.v20180912.1831
osgi(org.eclipse.jdt.junit.core) = 3.10.100.v20180912.1831
osgi(org.eclipse.jdt.junit.runtime) = 3.4.800.v20180912.1831
osgi(org.eclipse.jdt.junit4.runtime) = 1.1.800.v20180912.1831
osgi(org.eclipse.jdt.junit5.runtime) = 1.0.200.v20180912.1831
osgi(org.eclipse.jdt.launching) = 3.11.0.v20180912.1831
osgi(org.eclipse.jdt.ui) = 3.15.0.v20180912.1831

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package eclipse-jdt-4.9.0-2.fc29.noarch.rpm
Source Package eclipse-4.9.0-2.fc29.src.rpm

Install Howto

Install eclipse-jdt rpm package:

# dnf install eclipse-jdt

Files

Path
/usr/share/appdata/eclipse-jdt.metainfo.xml
/usr/share/eclipse/droplets/eclipse-jdt/fragment.info
/usr/share/eclipse/droplets/eclipse-jdt/features/
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.15.0.v20180912-1831/epl-2.0.html
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.15.0.v20180912-1831/feature.properties
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.15.0.v20180912-1831/feature.xml
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.15.0.v20180912-1831/license.html
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.15.0.v20180912-1831/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.15.0.v20180912-1831/META-INF/maven/
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.15.0.v20180912-1831/META-INF/maven/org.eclipse.jdt.feature/
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.15.0.v20180912-1831/META-INF/maven/org.eclipse.jdt.feature/org.eclipse.jdt/pom.properties
/usr/share/eclipse/droplets/eclipse-jdt/features/org.eclipse.jdt_3.15.0.v20180912-1831/META-INF/maven/org.eclipse.jdt.feature/org.eclipse.jdt/pom.xml
/usr/share/eclipse/droplets/eclipse-jdt/plugins/com.univocity.parsers_2.5.5.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.apiguardian_1.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.ant.launching_1.2.200.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.ant.ui_3.7.200.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.annotation_2.2.100.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.apt.core_3.6.100.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.apt.pluggable.core_1.2.200.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.apt.ui_3.6.100.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.compiler.apt_1.3.300.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.compiler.tool_1.2.300.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.core.manipulation_1.10.100.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.core_3.15.0.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug.ui_3.10.0.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.doc.user_3.15.0.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.junit.core_3.10.100.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.junit.runtime_3.4.800.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.junit4.runtime_1.1.800.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.junit5.runtime_1.0.200.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.junit_3.11.100.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.launching_3.11.0.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.ui_3.15.0.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt_3.15.0.v20180912-1831.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.hamcrest.core_1.3.0.v201303031735.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.junit.jupiter.api_5.3.1.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.junit.jupiter.engine_5.3.1.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.junit.jupiter.migrationsupport_5.3.1.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.junit.jupiter.params_5.3.1.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.junit.platform.commons_1.3.1.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.junit.platform.engine_1.3.1.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.junit.platform.launcher_1.3.1.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.junit.platform.runner_1.3.1.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.junit.platform.suite.api_1.3.1.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.junit.vintage.engine_5.3.1.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.junit_4.12.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.opentest4j_1.0.0.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/.api_description
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/.options
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/about.html
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/jdi.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/jdimodel.jar
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/plugin.properties
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/plugin.xml
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/META-INF/maven/
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/META-INF/maven/org.eclipse.jdt/
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/META-INF/maven/org.eclipse.jdt/org.eclipse.jdt.debug/pom.properties
/usr/share/eclipse/droplets/eclipse-jdt/plugins/org.eclipse.jdt.debug_3.12.0.v20180912-1831/META-INF/maven/org.eclipse.jdt/org.eclipse.jdt.debug/pom.xml
/usr/share/maven-metadata/eclipse-jdt.xml

Changelog

2018-09-28 - Jeff Johnston <jjohnstn@redhat.com> - 1:4.9.0-2
- Add org.eclipse.equinox.executable for building RCP apps
2018-09-12 - Mat Booth <mat.booth@redhat.com> - 1:4.9.0-1
- Update to final bits for 4.9
- Fix NPE due to missing agent jar
2018-08-23 - Mat Booth <mat.booth@redhat.com> - 1:4.9.0-0.4
- Update to latest I-build
- Full non-bootstrap build
2018-08-22 - Mat Booth <mat.booth@redhat.com> - 1:4.9.0-0.3
- Fix prefer x11 patch used on RHEL
2018-08-20 - Mat Booth <mat.booth@redhat.com> - 1:4.9.0-0.2
- Fix secondary arch build
2018-08-19 - Mat Booth <mat.booth@redhat.com> - 1:4.9.0-0.1
- Update to latest I-build
- Update license
2018-07-12 - Fedora Release Engineering <releng@fedoraproject.org> - 1:4.8.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-06-25 - Mat Booth <mat.booth@redhat.com> - 1:4.8.0-3
- Add patch to use gsettings instead of gconf
2018-06-13 - Mat Booth <mat.booth@redhat.com> - 1:4.8.0-2
- Backport patches for ebz#533655 and ebz#535392
2018-06-12 - Mat Booth <mat.booth@redhat.com> - 1:4.8.0-1
- Update to Photon release

See Also

Package Description
eclipse-jgit-5.1.1-2.fc29.noarch.rpm Eclipse JGit
eclipse-launchbar-2.2.1-1.fc29.noarch.rpm Eclipse Launchbar plug-in
eclipse-license1-1.0.1-5.fc29.noarch.rpm Shared EPL v1.0 license feature for Eclipse
eclipse-license2-2.0.1-5.fc29.noarch.rpm Shared EPL v2.0 license feature for Eclipse
eclipse-linuxtools-7.1.0-0.3.fc29.noarch.rpm Linux specific Eclipse plugins
eclipse-linuxtools-changelog-7.1.0-0.3.fc29.noarch.rpm Eclipse ChangeLog plug-in
eclipse-linuxtools-docker-7.1.0-0.3.fc29.noarch.rpm Docker Tooling
eclipse-linuxtools-gcov-7.1.0-0.3.fc29.noarch.rpm GCov Integration
eclipse-linuxtools-gprof-7.1.0-0.3.fc29.noarch.rpm GProf Integration
eclipse-linuxtools-javadocs-7.1.0-0.3.fc29.noarch.rpm Javadocs documentation plugin for Eclipse
eclipse-linuxtools-libhover-7.1.0-0.3.fc29.noarch.rpm Libhover documentation plugin for Eclipse
eclipse-linuxtools-manpage-7.1.0-0.3.fc29.noarch.rpm Man page viewer
eclipse-linuxtools-oprofile-7.1.0-0.3.fc29.noarch.rpm Eclipse plugin for OProfile integration
eclipse-linuxtools-perf-7.1.0-0.3.fc29.noarch.rpm Eclipse plugin for Perf integration
eclipse-linuxtools-rpm-editor-7.1.0-0.3.fc29.noarch.rpm RPM Spec file editor for Eclipse
Advertisement
Advertisement