libvma-8.0.1-5.fc28.i686.rpm


Advertisement

Description

libvma - A library for boosting TCP and UDP traffic (over RDMA hardware)

Property Value
Distribution Fedora 29
Repository Fedora x86_64
Package name libvma
Package version 8.0.1
Package release 5.fc28
Package architecture i686
Package type rpm
Installed size 1.51 MB
Download size 515.43 KB
Official Mirror download-ib01.fedoraproject.org
libvma is a LD_PRELOAD-able library that boosts performance
of TCP and UDP traffic.
It allows application written over standard socket API to handle
fast path data traffic from user space over Ethernet and/or
Infiniband with full network stack bypass and get better throughput,
latency and packets/sec rate.
No application binary change is required for that.
libvma is supported by RDMA capable devices that support
"verbs" IBV_QPT_RAW_PACKET QP for Ethernet and/or IBV_QPT_UD QP for IPoIB.

Alternatives

Package Version Architecture Repository
libvma-8.0.1-5.fc28.x86_64.rpm 8.0.1 x86_64 Fedora
libvma-8.0.1-5.fc28.i686.rpm 8.0.1 i686 Fedora
libvma - - -

Requires

Name Value
/sbin/ldconfig -
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libc.so.6(GLIBC_2.22) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libibverbs.so.1 -
libibverbs.so.1(IBVERBS_1.0) -
libibverbs.so.1(IBVERBS_1.1) -
libm.so.6 -
libnl-3.so.200 -
libnl-3.so.200(libnl_3) -
libnl-route-3.so.200 -
libnl-route-3.so.200(libnl_3) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.3.4) -
librdmacm.so.1 -
librdmacm.so.1(RDMACM_1.0) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.10) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
pam -
rtld(GNU_HASH) -

Provides

Name Value
config(libvma) = 8.0.1-5.fc28
libvma = 8.0.1-5.fc28
libvma(x86-32) = 8.0.1-5.fc28
libvma.so.8 -

Download

Type URL
Binary Package libvma-8.0.1-5.fc28.i686.rpm
Source Package libvma-8.0.1-5.fc28.src.rpm

Install Howto

Install libvma rpm package:

# dnf install libvma

Files

Path
/etc/libvma.conf
/etc/security/limits.d/30-libvma-limits.conf
/usr/lib/libvma.so
/usr/lib/libvma.so.8
/usr/lib/libvma.so.8.0.1
/usr/lib/.build-id/
/usr/lib/.build-id/fc/6b4d0b073bbfdfd4c42e8c3e85fc98ed78e9aa
/usr/share/doc/libvma/README.txt
/usr/share/doc/libvma/VMA_VERSION
/usr/share/doc/libvma/journal.txt
/usr/share/licenses/libvma/COPYING
/usr/share/licenses/libvma/LICENSE

Changelog

2018-02-05 - Than Ngo <than@redhat.com> - 8.0.1-5
- fixed FTBS with gcc7/gcc8
2017-08-03 - Fedora Release Engineering <releng@fedoraproject.org> - 8.0.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
2017-07-26 - Fedora Release Engineering <releng@fedoraproject.org> - 8.0.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-02-10 - Fedora Release Engineering <releng@fedoraproject.org> - 8.0.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
2016-03-13 - Alex Vainman <alexv@mellanox.com> - 8.0.1-1
- New upstream release
- Move to dual license: GPLv2 or BSD
- ExcludeArch update
- Removal of extra space in:
config(noreplace) {_sysconfdir}/security/limits.d/30-libvma-limits.conf
- Add V=1 to make
2016-03-02 - Alex Vainman <alexv@mellanox.com> - 7.0.14-2
- Added reasoning for archs exclusion
- Package description improvement
- Removal of the pre scriplet
- Added COPYING and LICENSE files to the package
2016-02-21 - Alex Vainman <alexv@mellanox.com> - 7.0.14-1
- New upstream release
- Removal of redundant macros and obsolete/unneeded tags
- Added ExcludeArch, BuildRequires and Require sections
- Fixes and cleanups in the build and installation sections
- Install 30-libvma-limits.conf file under 
/etc/security/limits.d/
- Fixes related to files/directories ownerships
- Removal of vma_perf_envelope.sh from the utility package
- Update Source tag URL
- Fix most of the rpmlint warnings
2016-01-04 - Avner BenHanoch <avnerb@mellanox.com> - 7.0.12-1
- Initial Packaging

See Also

Package Description
libvma-devel-8.0.1-5.fc28.i686.rpm Header files required to develop with libvma
libvma-devel-8.0.1-5.fc28.x86_64.rpm Header files required to develop with libvma
libvma-utils-8.0.1-5.fc28.x86_64.rpm Libvma utilities
libvmem-1.4.2-1.fc29.x86_64.rpm Volatile Memory allocation library
libvmem-devel-1.4.2-1.fc29.x86_64.rpm Development files for the Volatile Memory allocation library
libvmi-0.11.0-14.20170706gite919365.fc29.x86_64.rpm A library for performing virtual-machine introspection
libvmi-devel-0.11.0-14.20170706gite919365.fc29.x86_64.rpm Development files for libvmi
libvmi-utils-0.11.0-14.20170706gite919365.fc29.x86_64.rpm Utilities which make use of libvmi
libvmmalloc-1.4.2-1.fc29.x86_64.rpm Dynamic to Persistent Memory allocation translation library
libvmmalloc-devel-1.4.2-1.fc29.x86_64.rpm Development files for the Dynamic-to-Persistent allocation library
libvncserver-0.9.11-8.fc29.i686.rpm Library to make writing a VNC server easy
libvncserver-0.9.11-8.fc29.x86_64.rpm Library to make writing a VNC server easy
libvncserver-devel-0.9.11-8.fc29.i686.rpm Development files for libvncserver
libvncserver-devel-0.9.11-8.fc29.x86_64.rpm Development files for libvncserver
libvoikko-4.1.1-1.fc29.i686.rpm Voikko is a library for spellcheckers and hyphenators
Advertisement
Advertisement