libyui-3.3.3-4.fc29.i686.rpm


Advertisement

Description

libyui - GUI-abstraction library

Property Value
Distribution Fedora 29
Repository Fedora x86_64
Package name libyui
Package version 3.3.3
Package release 4.fc29
Package architecture i686
Package type rpm
Installed size 860.13 KB
Download size 258.77 KB
Official Mirror download-ib01.fedoraproject.org
This is the user interface engine that provides the abstraction
from graphical user interfaces (Qt, Gtk) and text based user
interfaces (ncurses).
Originally developed for YaST, libyui can now be used
independently of YaST for generic (C++) applications.
libyui has very few dependencies.

Alternatives

Package Version Architecture Repository
libyui-3.3.3-4.fc29.x86_64.rpm 3.3.3 x86_64 Fedora
libyui-3.3.3-4.fc29.i686.rpm 3.3.3 i686 Fedora
libyui - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.28) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
rtld(GNU_HASH) -

Provides

Name Value
libyui = 3.3.3-4.fc29
libyui(x86-32) = 3.3.3-4.fc29
libyui.so.8 -

Download

Type URL
Binary Package libyui-3.3.3-4.fc29.i686.rpm
Source Package libyui-3.3.3-4.fc29.src.rpm

Install Howto

Install libyui rpm package:

# dnf install libyui

Files

Path
/usr/lib/libyui.so.8
/usr/lib/libyui.so.8.0.0
/usr/lib/.build-id/
/usr/lib/.build-id/cb/cb23f5e5b9760d7ed8c8cd62611d124182b7cb
/usr/lib/yui/
/usr/share/doc/libyui/README.md
/usr/share/libyui/
/usr/share/libyui/theme/
/usr/share/licenses/libyui/COPYING.gpl-3
/usr/share/licenses/libyui/COPYING.lgpl-2.1
/usr/share/licenses/libyui/COPYING.lgpl-3

Changelog

2018-08-13 - Leigh Scott <leigh123linux@googlemail.com> - 3.3.3-4
- Fix gcc-8 build issue
2018-07-13 - Fedora Release Engineering <releng@fedoraproject.org> - 3.3.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-02-07 - Fedora Release Engineering <releng@fedoraproject.org> - 3.3.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2017-08-03 - Björn Esser <besser82@fedoraproject.org> - 3.3.3-1
- New upstream release
- Dependency on cmake-filesystem is autogenerated now
- Skip building of LaTeX-docs
2017-08-03 - Fedora Release Engineering <releng@fedoraproject.org> - 3.3.2-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
2017-07-30 - Björn Esser <besser82@fedoraproject.org> - 3.3.2-6
- Require cmake-filesystem
2017-07-26 - Fedora Release Engineering <releng@fedoraproject.org> - 3.3.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-07-03 - Jonathan Wakely <jwakely@redhat.com> - 3.3.2-4
- Rebuilt for Boost 1.64
2017-04-29 - Björn Esser <besser82@fedoraproject.org> - 3.3.2-3
- Rebuilt for bootstrapping new arch: s390x
2017-04-23 - Björn Esser <besser82@fedoraproject.org> - 3.3.2-2
- Fix macros-file

See Also

Package Description
libyui-devel-3.3.3-4.fc29.i686.rpm Files needed for developing with libyui
libyui-devel-3.3.3-4.fc29.x86_64.rpm Files needed for developing with libyui
libyui-doc-3.3.3-4.fc29.noarch.rpm Documentation files for libyui
libyui-gtk-2.44.9-11.fc29.i686.rpm Gtk3 User Interface for libyui
libyui-gtk-2.44.9-11.fc29.x86_64.rpm Gtk3 User Interface for libyui
libyui-gtk-devel-2.44.9-11.fc29.i686.rpm Files needed for developing with libyui-gtk
libyui-gtk-devel-2.44.9-11.fc29.x86_64.rpm Files needed for developing with libyui-gtk
libyui-gtk-doc-2.44.9-11.fc29.noarch.rpm Documentation files for libyui-gtk
libyui-mga-1.0.8-0.15.gita6a160e.20160313.fc29.i686.rpm Libyui extensions for Mageia tools
libyui-mga-1.0.8-0.15.gita6a160e.20160313.fc29.x86_64.rpm Libyui extensions for Mageia tools
libyui-mga-devel-1.0.8-0.15.gita6a160e.20160313.fc29.i686.rpm Files needed for developing with libyui-mga
libyui-mga-devel-1.0.8-0.15.gita6a160e.20160313.fc29.x86_64.rpm Files needed for developing with libyui-mga
libyui-mga-doc-1.0.8-0.15.gita6a160e.20160313.fc29.noarch.rpm Documentation files for libyui-mga
libyui-mga-gtk-1.0.2-0.16.git22f2cf6.20131215.fc29.i686.rpm Libyui-Gtk extensions for Mageia tools
libyui-mga-gtk-1.0.2-0.16.git22f2cf6.20131215.fc29.x86_64.rpm Libyui-Gtk extensions for Mageia tools
Advertisement
Advertisement