libyui-devel-3.3.3-4.fc29.x86_64.rpm


Advertisement

Description

libyui-devel - Files needed for developing with libyui

Property Value
Distribution Fedora 29
Repository Fedora x86_64
Package name libyui-devel
Package version 3.3.3
Package release 4.fc29
Package architecture x86_64
Package type rpm
Installed size 562.29 KB
Download size 122.81 KB
Official Mirror download-ib01.fedoraproject.org
libyui can be used independently of YaST for generic (C++)
applications and has very few dependencies.

Alternatives

Package Version Architecture Repository
libyui-devel-3.3.3-4.fc29.i686.rpm 3.3.3 i686 Fedora
libyui-devel-3.3.3-4.fc29.i686.rpm 3.3.3 i686 Fedora
libyui-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
boost-devel(x86-64) -
cmake-filesystem(x86-64) -
libyui(x86-64) = 3.3.3-4.fc29
libyui.so.8()(64bit) -

Provides

Name Value
cmake(Libyui) = 3.3.3
libyui-devel = 3.3.3-4.fc29
libyui-devel(x86-64) = 3.3.3-4.fc29
pkgconfig(libyui) = 3.3.3

Download

Type URL
Binary Package libyui-devel-3.3.3-4.fc29.x86_64.rpm
Source Package libyui-3.3.3-4.fc29.src.rpm

Install Howto

Install libyui-devel rpm package:

# dnf install libyui-devel

Files

Path
/usr/include/yui/FSize.h
/usr/include/yui/ImplPtr.h
/usr/include/yui/Libyui_config.h
/usr/include/yui/TreeItem.h
/usr/include/yui/YAlignment.h
/usr/include/yui/YApplication.h
/usr/include/yui/YBarGraph.h
/usr/include/yui/YBothDim.h
/usr/include/yui/YBuiltinCaller.h
/usr/include/yui/YBusyIndicator.h
/usr/include/yui/YButtonBox.h
/usr/include/yui/YCheckBox.h
/usr/include/yui/YCheckBoxFrame.h
/usr/include/yui/YChildrenManager.h
/usr/include/yui/YColor.h
/usr/include/yui/YComboBox.h
/usr/include/yui/YCommandLine.h
/usr/include/yui/YContextMenu.h
/usr/include/yui/YDateField.h
/usr/include/yui/YDialog.h
/usr/include/yui/YDialogSpy.h
/usr/include/yui/YDownloadProgress.h
/usr/include/yui/YDumbTab.h
/usr/include/yui/YEmpty.h
/usr/include/yui/YEnvVar.h
/usr/include/yui/YEvent.h
/usr/include/yui/YEventFilter.h
/usr/include/yui/YExternalWidgetFactory.h
/usr/include/yui/YExternalWidgets.h
/usr/include/yui/YFrame.h
/usr/include/yui/YGraph.h
/usr/include/yui/YGraphPlugin.h
/usr/include/yui/YIconLoader.h
/usr/include/yui/YImage.h
/usr/include/yui/YInputField.h
/usr/include/yui/YIntField.h
/usr/include/yui/YItem.h
/usr/include/yui/YLabel.h
/usr/include/yui/YLayoutBox.h
/usr/include/yui/YLogView.h
/usr/include/yui/YMacro.h
/usr/include/yui/YMacroPlayer.h
/usr/include/yui/YMacroRecorder.h
/usr/include/yui/YMenuButton.h
/usr/include/yui/YMenuItem.h
/usr/include/yui/YMultiLineEdit.h
/usr/include/yui/YMultiProgressMeter.h
/usr/include/yui/YMultiSelectionBox.h
/usr/include/yui/YOptionalWidgetFactory.h
/usr/include/yui/YPackageSelector.h
/usr/include/yui/YPackageSelectorPlugin.h
/usr/include/yui/YPartitionSplitter.h
/usr/include/yui/YPath.h
/usr/include/yui/YProgressBar.h
/usr/include/yui/YProperty.h
/usr/include/yui/YPushButton.h
/usr/include/yui/YRadioButton.h
/usr/include/yui/YRadioButtonGroup.h
/usr/include/yui/YReplacePoint.h
/usr/include/yui/YRichText.h
/usr/include/yui/YRpmGroupsTree.h
/usr/include/yui/YSelectionBox.h
/usr/include/yui/YSelectionWidget.h
/usr/include/yui/YSettings.h
/usr/include/yui/YShortcut.h
/usr/include/yui/YShortcutManager.h
/usr/include/yui/YSimpleEventHandler.h
/usr/include/yui/YSimpleInputField.h
/usr/include/yui/YSingleChildContainerWidget.h
/usr/include/yui/YSlider.h
/usr/include/yui/YSpacing.h
/usr/include/yui/YSquash.h
/usr/include/yui/YStringTree.h
/usr/include/yui/YTable.h
/usr/include/yui/YTableHeader.h
/usr/include/yui/YTableItem.h
/usr/include/yui/YTimeField.h
/usr/include/yui/YTimezoneSelector.h
/usr/include/yui/YTransText.h
/usr/include/yui/YTree.h
/usr/include/yui/YTreeItem.h
/usr/include/yui/YTypes.h
/usr/include/yui/YUI.h
/usr/include/yui/YUIException.h
/usr/include/yui/YUILoader.h
/usr/include/yui/YUILog.h
/usr/include/yui/YUIPlugin.h
/usr/include/yui/YUISymbols.h
/usr/include/yui/YWidget.h
/usr/include/yui/YWidgetFactory.h
/usr/include/yui/YWidgetID.h
/usr/include/yui/YWidget_OptimizeChanges.h
/usr/include/yui/YWizard.h
/usr/lib/rpm/macros.d/macros.libyui
/usr/lib64/libyui.so
/usr/lib64/cmake/libyui/LibyuiConfig.cmake
/usr/lib64/cmake/libyui/LibyuiConfigVersion.cmake
/usr/lib64/cmake/libyui/LibyuiLibraryDepends-release.cmake
/usr/lib64/cmake/libyui/LibyuiLibraryDepends.cmake
/usr/lib64/pkgconfig/libyui.pc
/usr/share/doc/libyui/libyui.changes
/usr/share/libyui/buildtools/BuildTreeSettings.cmake.in
/usr/share/libyui/buildtools/CMakeLists.common
/usr/share/libyui/buildtools/Config.cmake.in
/usr/share/libyui/buildtools/ConfigVersion.cmake.in
/usr/share/libyui/buildtools/Doxyfile.in
/usr/share/libyui/buildtools/FindGTK3.cmake
/usr/share/libyui/buildtools/LibyuiCommon.cmake
/usr/share/libyui/buildtools/config.h.in
/usr/share/libyui/buildtools/template-doc.spec.in
/usr/share/libyui/buildtools/template.pc.in

Changelog

See libyui-3.3.3-4.fc29.x86_64.rpm changelog.

See Also

Package Description
libyui-doc-3.3.3-4.fc29.noarch.rpm Documentation files for libyui
libyui-gtk-2.44.9-11.fc29.i686.rpm Gtk3 User Interface for libyui
libyui-gtk-2.44.9-11.fc29.x86_64.rpm Gtk3 User Interface for libyui
libyui-gtk-devel-2.44.9-11.fc29.i686.rpm Files needed for developing with libyui-gtk
libyui-gtk-devel-2.44.9-11.fc29.x86_64.rpm Files needed for developing with libyui-gtk
libyui-gtk-doc-2.44.9-11.fc29.noarch.rpm Documentation files for libyui-gtk
libyui-mga-1.0.8-0.15.gita6a160e.20160313.fc29.i686.rpm Libyui extensions for Mageia tools
libyui-mga-1.0.8-0.15.gita6a160e.20160313.fc29.x86_64.rpm Libyui extensions for Mageia tools
libyui-mga-devel-1.0.8-0.15.gita6a160e.20160313.fc29.i686.rpm Files needed for developing with libyui-mga
libyui-mga-devel-1.0.8-0.15.gita6a160e.20160313.fc29.x86_64.rpm Files needed for developing with libyui-mga
libyui-mga-doc-1.0.8-0.15.gita6a160e.20160313.fc29.noarch.rpm Documentation files for libyui-mga
libyui-mga-gtk-1.0.2-0.16.git22f2cf6.20131215.fc29.i686.rpm Libyui-Gtk extensions for Mageia tools
libyui-mga-gtk-1.0.2-0.16.git22f2cf6.20131215.fc29.x86_64.rpm Libyui-Gtk extensions for Mageia tools
libyui-mga-gtk-devel-1.0.2-0.16.git22f2cf6.20131215.fc29.i686.rpm Files needed for developing with libyui-mga-gtk
libyui-mga-gtk-devel-1.0.2-0.16.git22f2cf6.20131215.fc29.x86_64.rpm Files needed for developing with libyui-mga-gtk
Advertisement
Advertisement