libyui-gtk-devel-2.44.9-11.fc29.x86_64.rpm


Advertisement

Description

libyui-gtk-devel - Files needed for developing with libyui-gtk

Property Value
Distribution Fedora 29
Repository Fedora x86_64
Package name libyui-gtk-devel
Package version 2.44.9
Package release 11.fc29
Package architecture x86_64
Package type rpm
Installed size 121.85 KB
Download size 40.76 KB
Official Mirror download-ib01.fedoraproject.org
libyui can be used independently of YaST for generic (C++)
applications and has very few dependencies.
You do NOT need this package for developing with libyui.
Usinglibyui-devel is sufficient for such purpose. This
package is only needed when you want to develop an extension
for libyui-gtk which is not covered within the UI-plugin.

Alternatives

Package Version Architecture Repository
libyui-gtk-devel-2.44.9-11.fc29.i686.rpm 2.44.9 i686 Fedora
libyui-gtk-devel-2.44.9-11.fc29.i686.rpm 2.44.9 i686 Fedora
libyui-gtk-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
cmake-filesystem(x86-64) -
gtk3-devel(x86-64) -
libyui-devel(x86-64) -
libyui-gtk(x86-64) = 2.44.9-11.fc29
libyui-gtk.so.8()(64bit) -

Provides

Name Value
cmake(Libyui-gtk) = 2.44.9
libyui-gtk-devel = 2.44.9-11.fc29
libyui-gtk-devel(x86-64) = 2.44.9-11.fc29
pkgconfig(libyui-gtk) = 2.44.9

Download

Type URL
Binary Package libyui-gtk-devel-2.44.9-11.fc29.x86_64.rpm
Source Package libyui-gtk-2.44.9-11.fc29.src.rpm

Install Howto

Install libyui-gtk-devel rpm package:

# dnf install libyui-gtk-devel

Files

Path
/usr/include/yui/gtk/YGDialog.h
/usr/include/yui/gtk/YGPackageSelectorPluginIf.h
/usr/include/yui/gtk/YGSelectionStore.h
/usr/include/yui/gtk/YGUI.h
/usr/include/yui/gtk/YGUtils.h
/usr/include/yui/gtk/YGWidget.h
/usr/include/yui/gtk/YGi18n.h
/usr/include/yui/gtk/ygdkmngloader.h
/usr/include/yui/gtk/ygtkbargraph.h
/usr/include/yui/gtk/ygtkfieldentry.h
/usr/include/yui/gtk/ygtkfixed.h
/usr/include/yui/gtk/ygtkhtmlwrap.h
/usr/include/yui/gtk/ygtkimage.h
/usr/include/yui/gtk/ygtklinklabel.h
/usr/include/yui/gtk/ygtkmenubutton.h
/usr/include/yui/gtk/ygtkratiobox.h
/usr/include/yui/gtk/ygtkrichtext.h
/usr/include/yui/gtk/ygtksteps.h
/usr/include/yui/gtk/ygtktextview.h
/usr/include/yui/gtk/ygtktimezonepicker.h
/usr/include/yui/gtk/ygtktreeview.h
/usr/include/yui/gtk/ygtkwindow.h
/usr/include/yui/gtk/ygtkwizard.h
/usr/lib64/cmake/libyui-gtk/Libyui-gtkConfig.cmake
/usr/lib64/cmake/libyui-gtk/Libyui-gtkConfigVersion.cmake
/usr/lib64/cmake/libyui-gtk/Libyui-gtkLibraryDepends-release.cmake
/usr/lib64/cmake/libyui-gtk/Libyui-gtkLibraryDepends.cmake
/usr/lib64/pkgconfig/libyui-gtk.pc
/usr/lib64/yui/libyui-gtk.so
/usr/share/doc/libyui-gtk/libyui-gtk.changes

Changelog

See libyui-gtk-2.44.9-11.fc29.x86_64.rpm changelog.

See Also

Package Description
libyui-gtk-doc-2.44.9-11.fc29.noarch.rpm Documentation files for libyui-gtk
libyui-mga-1.0.8-0.15.gita6a160e.20160313.fc29.i686.rpm Libyui extensions for Mageia tools
libyui-mga-1.0.8-0.15.gita6a160e.20160313.fc29.x86_64.rpm Libyui extensions for Mageia tools
libyui-mga-devel-1.0.8-0.15.gita6a160e.20160313.fc29.i686.rpm Files needed for developing with libyui-mga
libyui-mga-devel-1.0.8-0.15.gita6a160e.20160313.fc29.x86_64.rpm Files needed for developing with libyui-mga
libyui-mga-doc-1.0.8-0.15.gita6a160e.20160313.fc29.noarch.rpm Documentation files for libyui-mga
libyui-mga-gtk-1.0.2-0.16.git22f2cf6.20131215.fc29.i686.rpm Libyui-Gtk extensions for Mageia tools
libyui-mga-gtk-1.0.2-0.16.git22f2cf6.20131215.fc29.x86_64.rpm Libyui-Gtk extensions for Mageia tools
libyui-mga-gtk-devel-1.0.2-0.16.git22f2cf6.20131215.fc29.i686.rpm Files needed for developing with libyui-mga-gtk
libyui-mga-gtk-devel-1.0.2-0.16.git22f2cf6.20131215.fc29.x86_64.rpm Files needed for developing with libyui-mga-gtk
libyui-mga-gtk-doc-1.0.2-0.16.git22f2cf6.20131215.fc29.noarch.rpm Documentation files for libyui-mga-gtk
libyui-mga-ncurses-1.0.2-0.16.git026f2e6.20131215.fc29.i686.rpm Libyui-Ncurses extensions for Mageia tools
libyui-mga-ncurses-1.0.2-0.16.git026f2e6.20131215.fc29.x86_64.rpm Libyui-Ncurses extensions for Mageia tools
libyui-mga-ncurses-devel-1.0.2-0.16.git026f2e6.20131215.fc29.i686.rpm Files needed for developing with libyui-mga-ncurses
libyui-mga-ncurses-devel-1.0.2-0.16.git026f2e6.20131215.fc29.x86_64.rpm Files needed for developing with libyui-mga-ncurses
Advertisement
Advertisement