libyui-ncurses-devel-2.48.3-5.fc29.i686.rpm


Advertisement

Description

libyui-ncurses-devel - Files needed for developing with libyui-ncurses

Property Value
Distribution Fedora 29
Repository Fedora x86_64
Package name libyui-ncurses-devel
Package version 2.48.3
Package release 5.fc29
Package architecture i686
Package type rpm
Installed size 473.18 KB
Download size 90.67 KB
Official Mirror download-ib01.fedoraproject.org
libyui can be used independently of YaST for generic (C++)
applications and has very few dependencies.
You do NOT need this package for developing with libyui.
Using libyui-devel is sufficient for such purpose.  This
package is only needed when you want to develop an extension
for libyui-ncurses which is not covered within the UI-plugin.

Alternatives

Package Version Architecture Repository
libyui-ncurses-devel-2.48.3-5.fc29.x86_64.rpm 2.48.3 x86_64 Fedora
libyui-ncurses-devel-2.48.3-5.fc29.i686.rpm 2.48.3 i686 Fedora
libyui-ncurses-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
cmake-filesystem(x86-32) -
libyui-devel(x86-32) -
libyui-ncurses(x86-32) = 2.48.3-5.fc29
libyui-ncurses.so.8 -
ncurses-devel(x86-32) -

Provides

Name Value
cmake(Libyui-ncurses) = 2.48.3
libyui-ncurses-devel = 2.48.3-5.fc29
libyui-ncurses-devel(x86-32) = 2.48.3-5.fc29
pkgconfig(libyui-ncurses) = 2.48.3

Download

Type URL
Binary Package libyui-ncurses-devel-2.48.3-5.fc29.i686.rpm
Source Package libyui-ncurses-2.48.3-5.fc29.src.rpm

Install Howto

Install libyui-ncurses-devel rpm package:

# dnf install libyui-ncurses-devel

Files

Path
/usr/include/yui/ncurses/NCAlignment.h
/usr/include/yui/ncurses/NCApplication.h
/usr/include/yui/ncurses/NCAskForDirectory.h
/usr/include/yui/ncurses/NCAskForFile.h
/usr/include/yui/ncurses/NCBusyIndicator.h
/usr/include/yui/ncurses/NCButtonBox.h
/usr/include/yui/ncurses/NCCheckBox.h
/usr/include/yui/ncurses/NCCheckBoxFrame.h
/usr/include/yui/ncurses/NCComboBox.h
/usr/include/yui/ncurses/NCDateField.h
/usr/include/yui/ncurses/NCDialog.h
/usr/include/yui/ncurses/NCDumbTab.h
/usr/include/yui/ncurses/NCEmpty.h
/usr/include/yui/ncurses/NCFileSelection.h
/usr/include/yui/ncurses/NCFrame.h
/usr/include/yui/ncurses/NCImage.h
/usr/include/yui/ncurses/NCInputField.h
/usr/include/yui/ncurses/NCInputTextBase.h
/usr/include/yui/ncurses/NCIntField.h
/usr/include/yui/ncurses/NCLabel.h
/usr/include/yui/ncurses/NCLayoutBox.h
/usr/include/yui/ncurses/NCLogView.h
/usr/include/yui/ncurses/NCMenuButton.h
/usr/include/yui/ncurses/NCMultiLineEdit.h
/usr/include/yui/ncurses/NCMultiSelectionBox.h
/usr/include/yui/ncurses/NCOptionalWidgetFactory.h
/usr/include/yui/ncurses/NCPackageSelectorPluginIf.h
/usr/include/yui/ncurses/NCPackageSelectorPluginStub.h
/usr/include/yui/ncurses/NCPad.h
/usr/include/yui/ncurses/NCPadWidget.h
/usr/include/yui/ncurses/NCPopup.h
/usr/include/yui/ncurses/NCPopupInfo.h
/usr/include/yui/ncurses/NCPopupList.h
/usr/include/yui/ncurses/NCPopupMenu.h
/usr/include/yui/ncurses/NCPopupTable.h
/usr/include/yui/ncurses/NCPopupTextEntry.h
/usr/include/yui/ncurses/NCProgressBar.h
/usr/include/yui/ncurses/NCPushButton.h
/usr/include/yui/ncurses/NCRadioButton.h
/usr/include/yui/ncurses/NCRadioButtonGroup.h
/usr/include/yui/ncurses/NCReplacePoint.h
/usr/include/yui/ncurses/NCRichText.h
/usr/include/yui/ncurses/NCSelectionBox.h
/usr/include/yui/ncurses/NCSpacing.h
/usr/include/yui/ncurses/NCSquash.h
/usr/include/yui/ncurses/NCStyleDef.h
/usr/include/yui/ncurses/NCTable.h
/usr/include/yui/ncurses/NCTableItem.h
/usr/include/yui/ncurses/NCTablePad.h
/usr/include/yui/ncurses/NCTextPad.h
/usr/include/yui/ncurses/NCTimeField.h
/usr/include/yui/ncurses/NCTree.h
/usr/include/yui/ncurses/NCTreePad.h
/usr/include/yui/ncurses/NCWidget.h
/usr/include/yui/ncurses/NCWidgetFactory.h
/usr/include/yui/ncurses/NCi18n.h
/usr/include/yui/ncurses/NCstring.h
/usr/include/yui/ncurses/NCstyle.braille.h
/usr/include/yui/ncurses/NCstyle.h
/usr/include/yui/ncurses/NCstyle.highcontrast.h
/usr/include/yui/ncurses/NCstyle.inverted.h
/usr/include/yui/ncurses/NCstyle.linux.h
/usr/include/yui/ncurses/NCstyle.mono.h
/usr/include/yui/ncurses/NCstyle.rxvt.h
/usr/include/yui/ncurses/NCstyle.xterm.h
/usr/include/yui/ncurses/NCtext.h
/usr/include/yui/ncurses/NCtoY2Event.h
/usr/include/yui/ncurses/NCtypes.h
/usr/include/yui/ncurses/NCurses.h
/usr/include/yui/ncurses/YNCursesUI.h
/usr/include/yui/ncurses/ncursesp.h
/usr/include/yui/ncurses/ncursesw.h
/usr/include/yui/ncurses/position.h
/usr/include/yui/ncurses/stdutil.h
/usr/include/yui/ncurses/stringutil.h
/usr/include/yui/ncurses/tnode.h
/usr/lib/cmake/libyui-ncurses/Libyui-ncursesConfig.cmake
/usr/lib/cmake/libyui-ncurses/Libyui-ncursesConfigVersion.cmake
/usr/lib/cmake/libyui-ncurses/Libyui-ncursesLibraryDepends-release.cmake
/usr/lib/cmake/libyui-ncurses/Libyui-ncursesLibraryDepends.cmake
/usr/lib/pkgconfig/libyui-ncurses.pc
/usr/lib/yui/libyui-ncurses.so
/usr/share/doc/libyui-ncurses/libyui-ncurses.changes
/usr/share/libyui/buildtools/FindCurses6.cmake

Changelog

See libyui-ncurses-2.48.3-5.fc29.i686.rpm changelog.

See Also

Package Description
libyui-ncurses-doc-2.48.3-5.fc29.noarch.rpm Documentation files for libyui-ncurses
libyui-qt-2.47.1-13.fc29.i686.rpm Qt User Interface for libyui
libyui-qt-2.47.1-13.fc29.x86_64.rpm Qt User Interface for libyui
libyui-qt-devel-2.47.1-13.fc29.i686.rpm Files needed for developing with libyui-qt
libyui-qt-devel-2.47.1-13.fc29.x86_64.rpm Files needed for developing with libyui-qt
libyui-qt-doc-2.47.1-13.fc29.noarch.rpm Documentation files for libyui-qt
libyui-qt-graph-2.44.6-3.fc29.i686.rpm Qt Graph Widget for libyui
libyui-qt-graph-2.44.6-3.fc29.x86_64.rpm Qt Graph Widget for libyui
libyui-qt-graph-devel-2.44.6-3.fc29.i686.rpm Files needed for developing with libyui-qt-graph
libyui-qt-graph-devel-2.44.6-3.fc29.x86_64.rpm Files needed for developing with libyui-qt-graph
libyui-qt-graph-doc-2.44.6-3.fc29.noarch.rpm Documentation files for libyui-qt-graph
libyuv-0-0.31.20180904git9a07219.fc29.i686.rpm YUV conversion and scaling functionality library
libyuv-0-0.31.20180904git9a07219.fc29.x86_64.rpm YUV conversion and scaling functionality library
libyuv-devel-0-0.31.20180904git9a07219.fc29.i686.rpm The development files for libyuv
libyuv-devel-0-0.31.20180904git9a07219.fc29.x86_64.rpm The development files for libyuv
Advertisement
Advertisement