lua-dbi-compat-0.5-20.fc29.x86_64.rpm


Advertisement

Description

lua-dbi-compat - Database interface library for Lua 5.1

Property Value
Distribution Fedora 29
Repository Fedora x86_64
Package name lua-dbi-compat
Package version 0.5
Package release 20.fc29
Package architecture x86_64
Package type rpm
Installed size 78.68 KB
Download size 29.68 KB
Official Mirror download-ib01.fedoraproject.org
LuaDBI is a database interface library for Lua 5.1. It is designed to provide a
RDBMS agnostic API for handling database operations. LuaDBI also provides
support for prepared statement handles, placeholders and bind parameters for all
database operations.
Currently LuaDBI supports DB2, Oracle, MySQL, PostgreSQL and SQLite databases
with native database drivers.

Alternatives

Package Version Architecture Repository
lua-dbi-compat-0.5-20.fc29.i686.rpm 0.5 i686 Fedora
lua-dbi-compat - - -

Requires

Name Value
/usr/bin/lua -
libc.so.6(GLIBC_2.4)(64bit) -
libmariadb.so.3()(64bit) -
libmariadb.so.3(libmysqlclient_18)(64bit) -
libpq.so.5()(64bit) -
libsqlite3.so.0()(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
lua-dbi-compat = 0.5-20.fc29
lua-dbi-compat(x86-64) = 0.5-20.fc29

Download

Type URL
Binary Package lua-dbi-compat-0.5-20.fc29.x86_64.rpm
Source Package lua-dbi-0.5-20.fc29.src.rpm

Install Howto

Install lua-dbi-compat rpm package:

# dnf install lua-dbi-compat

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/85/1352675d55a993d1e8a587b5ab22d9f18953cb
/usr/lib/.build-id/af/83e9976777fe613d38163c151fd8e630cd8a3b
/usr/lib/.build-id/d7/f324ace1a50f487c03c04b4da53b8498f20318
/usr/lib64/lua/5.1/dbdmysql.so
/usr/lib64/lua/5.1/dbdpostgresql.so
/usr/lib64/lua/5.1/dbdsqlite3.so
/usr/share/doc/lua-dbi-compat/README
/usr/share/licenses/lua-dbi-compat/COPYING
/usr/share/lua/5.1/DBI.lua

Changelog

See lua-dbi-0.5-20.fc29.x86_64.rpm changelog.

See Also

Package Description
lua-devel-5.3.5-2.fc29.i686.rpm Development files for lua
lua-devel-5.3.5-2.fc29.x86_64.rpm Development files for lua
lua-event-0.4.3-16.fc29.x86_64.rpm This is a binding of libevent to Lua
lua-event-doc-0.4.3-16.fc29.x86_64.rpm Documentation for lua-event
lua-expat-1.3.0-13.fc29.x86_64.rpm SAX XML parser based on the Expat library
lua-expat-compat-1.3.0-13.fc29.x86_64.rpm SAX XML parser based on the Expat library for Lua 5.1
lua-filesystem-1.6.3-9.fc29.x86_64.rpm File System Library for the Lua Programming Language
lua-filesystem-compat-1.6.3-9.fc29.x86_64.rpm File System Library for the Lua Programming Language 5.1
lua-fun-0.1.3-9.fc29.noarch.rpm Functional programming library for Lua
lua-guestfs-1.39.8-1.fc29.x86_64.rpm Lua bindings for libguestfs
lua-inotify-1.0-0.16.20130510git98822877a9d42.fc29.x86_64.rpm Inotify bindings for Lua
lua-json-1.3.2-10.fc29.noarch.rpm JSON Parser/Constructor for Lua
lua-ldap-1.1.0-12.fc29.x86_64.rpm LDAP client library for Lua, using OpenLDAP
lua-ldap-compat-1.1.0-12.fc29.x86_64.rpm LDAP client library for Lua 5.1, using OpenLDAP
lua-ldoc-1.4.6-5.fc29.noarch.rpm Lua documentation generator
Advertisement
Advertisement