lua-socket-compat-3.0-0.18.rc1.fc29.x86_64.rpm


Advertisement

Description

lua-socket-compat - Network support for the Lua language 5.1

Property Value
Distribution Fedora 29
Repository Fedora x86_64
Package name lua-socket-compat
Package version 3.0
Package release 0.18.rc1.fc29
Package architecture x86_64
Package type rpm
Installed size 686.20 KB
Download size 179.82 KB
Official Mirror download-ib01.fedoraproject.org
LuaSocket is a Lua extension library that is composed by two parts: a C core
that provides support for the TCP and UDP transport layers, and a set of Lua
modules that add support for functionality commonly needed by applications
that deal with the Internet.
Among the support modules, the most commonly used implement the SMTP, HTTP
and FTP. In addition there are modules for MIME, URL handling and LTN12.

Alternatives

Package Version Architecture Repository
lua-socket-compat-3.0-0.18.rc1.fc29.i686.rpm 3.0 i686 Fedora
lua-socket-compat - - -

Requires

Name Value
libc.so.6(GLIBC_2.15)(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
lua-socket-compat = 3.0-0.18.rc1.fc29
lua-socket-compat(x86-64) = 3.0-0.18.rc1.fc29

Download

Type URL
Binary Package lua-socket-compat-3.0-0.18.rc1.fc29.x86_64.rpm
Source Package lua-socket-3.0-0.18.rc1.fc29.src.rpm

Install Howto

Install lua-socket-compat rpm package:

# dnf install lua-socket-compat

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/5d/3ab1472e8aa3f00c7b4353e16002fb2784d295
/usr/lib/.build-id/79/5227016b2b02fbf7dbdad41475af344ecddf51
/usr/lib/.build-id/84/b0628cc802e4cd6f8a81c7c82dda26b845427e
/usr/lib/.build-id/a3/fbb9d19c1f79daabf3f45a6e8818909abe8dc4
/usr/lib64/lua/5.1/mime/core.so
/usr/lib64/lua/5.1/socket/core.so
/usr/lib64/lua/5.1/socket/serial.so
/usr/lib64/lua/5.1/socket/unix.so
/usr/share/doc/lua-socket-compat/README
/usr/share/doc/lua-socket-compat/dns.html
/usr/share/doc/lua-socket-compat/ftp.html
/usr/share/doc/lua-socket-compat/http.html
/usr/share/doc/lua-socket-compat/index.html
/usr/share/doc/lua-socket-compat/installation.html
/usr/share/doc/lua-socket-compat/introduction.html
/usr/share/doc/lua-socket-compat/ltn12.html
/usr/share/doc/lua-socket-compat/lua05.ppt
/usr/share/doc/lua-socket-compat/luasocket.png
/usr/share/doc/lua-socket-compat/mime.html
/usr/share/doc/lua-socket-compat/reference.css
/usr/share/doc/lua-socket-compat/reference.html
/usr/share/doc/lua-socket-compat/smtp.html
/usr/share/doc/lua-socket-compat/socket.html
/usr/share/doc/lua-socket-compat/tcp.html
/usr/share/doc/lua-socket-compat/udp.html
/usr/share/doc/lua-socket-compat/url.html
/usr/share/licenses/lua-socket-compat/LICENSE
/usr/share/lua/5.1/ltn12.lua
/usr/share/lua/5.1/mime.lua
/usr/share/lua/5.1/socket.lua
/usr/share/lua/5.1/socket/ftp.lua
/usr/share/lua/5.1/socket/headers.lua
/usr/share/lua/5.1/socket/http.lua
/usr/share/lua/5.1/socket/smtp.lua
/usr/share/lua/5.1/socket/tp.lua
/usr/share/lua/5.1/socket/url.lua

Changelog

See lua-socket-3.0-0.18.rc1.fc29.x86_64.rpm changelog.

See Also

Package Description
lua-socket-devel-3.0-0.18.rc1.fc29.i686.rpm Development files for lua-socket
lua-socket-devel-3.0-0.18.rc1.fc29.x86_64.rpm Development files for lua-socket
lua-sql-2.3.5-8.fc29.x86_64.rpm Database connectivity for the Lua programming language
lua-sql-doc-2.3.5-8.fc29.x86_64.rpm Documentation for LuaSQL
lua-sql-mysql-2.3.5-8.fc29.x86_64.rpm MySQL database connectivity for the Lua programming language
lua-sql-postgresql-2.3.5-8.fc29.x86_64.rpm PostgreSQL database connectivity for the Lua programming language
lua-sql-sqlite-2.3.5-8.fc29.x86_64.rpm SQLite database connectivity for the Lua programming language
lua-static-5.3.5-2.fc29.i686.rpm Static library for lua
lua-static-5.3.5-2.fc29.x86_64.rpm Static library for lua
lua-term-0.07-7.fc29.x86_64.rpm Terminal functions for Lua
lua-wsapi-1.6.1-8.fc29.noarch.rpm Lua Web Server API
lua-xmlrpc-1.2.2-7.fc29.noarch.rpm Lua package to access and provide XML-RPC services
luabind-0.9.1-30.fc29.i686.rpm A library that helps create bindings between C++ and Lua
luabind-0.9.1-30.fc29.x86_64.rpm A library that helps create bindings between C++ and Lua
luabind-devel-0.9.1-30.fc29.i686.rpm Development libraries and headers for luabind
Advertisement
Advertisement